# Re: \[PATCH -mm 18/43\] powerpc compat\_binfmt\_elf

- From: Arnd Bergmann \<arnd@arndb.de\>
- Date: 2007-12-21 19:36:50 
- List: linuxppc-dev
- Page: https://ratatoskr.run/linuxppc-dev/2007/12/1039454
- Thread: https://ratatoskr.run/linux-arch/2007/12/1039294/t.md

```text
On Friday 21 December 2007, Kyle McMartin wrote:
> Just taking a stab that hch means,
>=20
> config BINFMT_COMPAT_ELF
> =A0=A0=A0=A0=A0=A0=A0=A0def_bool n
> =A0=A0=A0=A0=A0=A0=A0=A0depends on 64BIT
>=20

I'd call it COMPAT_BINFMT_ELF, for consistency with the file name.
Also, the definition and the depends are redundant if you expect the
option to be autoselected. You can do either of

config COMPAT_BINFMT_ELF
	bool

or=20

config COMPAT_BINFMT_ELF
	def_bool y
	depends on COMPAT

The second option makes sense at the point where all architectures with
compat code are using the same compat_binfmt_elf code.

	Arnd <><
```
