of_iomap confusion

From: Benjamin Herrenschmidt <benh@kernel.crashing.org>
Date: 2007-11-12 05:07:26

I just noticed this of_iomap() helper thing we have in prom_parse.c
nowadays.

It's a bit confusing as "iomap" is generally what we use to name the new
iomap interface (ioport_map, pci_iomap, ...) and that requires
-different- accessors than memory obtained from ioremap.

This I think this needs to be changed.

We should call it of_ioremap() or of_map_resource() and if we want an
of_iomap(), it should provide an iomap token, not an ioremap address
(they look the same on powerpc, but they shouldn't be mixed up).

Ben.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help