Re: ZMII Code Panics on 440GP Ebony

2 messages, 2 authors, 2002-05-24 · open the first message on its own page

Re: ZMII Code Panics on 440GP Ebony

From: Matt Porter <hidden>
Date: 2002-05-24 19:20:24

On Fri, May 24, 2002 at 09:40:53AM -0700, Roland Dreier wrote:
quoted
quoted
quoted
quoted
quoted
"Venkatesh" == Venkatesh Rao [off-list ref] writes:
    Venkatesh> Hi, I am using a Rev B board and when i compiled the
    Venkatesh> latest kernel (pulled yesterday after Matt's
    Venkatesh> Checkin)and booted my ebony board, i got a panic in
    Venkatesh> ZMII. I am including a portion of the bootup log.

Yes, the linux_2_4_devel tree I pulled yesterday was not in a
consistent state for my 440GP Ebony board.  The problem is that the
Ebony setup code has not been updated for the new OCP handling code
yet.  To fix it, you need to edit arch/ppc/platforms/ebony.c and
delete the lines:
Yes, I'm lagging a little behind all the OCP updates that are
occurring.  I pushed the included patch.
In addition, it seems to me that the EBONY_{ZMII,EMAC0,EMAC1}_{ADDR
constants should be renamed to PPC440GP_xxx constants since they are
not Ebony specific but rather apply to all IBM 440GP designs.  As
further cleanup, one can probably remove the EMAC_ADDR and ZMII_ADDR
variables.

I would be happy to help with this cleanup; however, I don't want to
step on anyone's work in progress.  However, if anyone would like
patches to do some of this cleanup I could put some together fairly
quickly.
I started some things but have been busy with functionality for
some time now.  I'd be interested in any cleanup patches you
would produce.  The idea is to separate ibm440.h, ibm440gp.h, and
<board>.h as appropriate.  As you've noticed, I took some shortcuts
in the interest of getting the core code in front of everybody
quickly. :)

Thanks,
--
Matt Porter
porter@cox.net
This is Linux Country. On a quiet night, you can hear Windows reboot.

** Sent via the linuxppc-embedded mail list. See http://lists.linuxppc.org/

Re: ZMII Code Panics on 440GP Ebony

From: Roland Dreier <hidden>
Date: 2002-05-24 19:17:47

quoted
quoted
quoted
quoted
"Matt" == Matt Porter [off-list ref] writes:
    Matt> I started some things but have been busy with functionality
    Matt> for some time now.  I'd be interested in any cleanup patches
    Matt> you would produce.  The idea is to separate ibm440.h,
    Matt> ibm440gp.h, and <board>.h as appropriate.  As you've
    Matt> noticed, I took some shortcuts in the interest of getting
    Matt> the core code in front of everybody quickly. :)

OK, I will send you some trivial stuff soon.  I do have one question:
what belongs in ibm440.h (as opposed to ibm440gp.h)?  The only
documentation I have is specifically for the 440GP (other than a
presentation on the 440GX) -- how do we know what is common to the 440
family?

Best,
Roland

** Sent via the linuxppc-embedded mail list. See http://lists.linuxppc.org/
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help