[PATCH] Several patches against linuxppc_devel-2.4.18-rc1

STALE8937d

3 messages, 2 authors, 2002-02-18 · open the first message on its own page

[PATCH] Several patches against linuxppc_devel-2.4.18-rc1

From: David Müller (ELSOFT AG) <hidden>
Date: 2002-02-16 12:52:19

Hello

The attached patch fixes the following issues:

    - arch/ppc/kernel/Makefile
       ppc4xx_pm.o missing in export-objs list

    - arch/ppc/kernel/ppc4xx_pm.c
       missing include file + missing #ifdef #endif

    - arch/ppc/kernel/ppc4xx_pic.c
       fixed constant in ppc405_pic_get_irq()
       (NR_IRQS is not necessarily the total number of UIC irqs)

    - arch/ppc/platforms/ibm_ocp.h
       wrong header file included + some little name fixes


Regarding the newly introduce support for cascaded UICs:

Isn't the CONFIG_CASCADING_UIC option redundant?
If (CONFIG_CASCADING_UIC == (NR_UICS > 1)) is true, CONFIG_CASCADING_UIC
could be replace by (NR_UICS > 1).

Dave

Re: [PATCH] Several patches against linuxppc_devel-2.4.18-rc1

From: Armin <hidden>
Date: 2002-02-17 15:27:57

David Müller (ELSOFT AG) wrote:
Hello

The attached patch fixes the following issues:

   - arch/ppc/kernel/Makefile
      ppc4xx_pm.o missing in export-objs list

   - arch/ppc/kernel/ppc4xx_pm.c
      missing include file + missing #ifdef #endif
ok.
   - arch/ppc/kernel/ppc4xx_pic.c
      fixed constant in ppc405_pic_get_irq()
      (NR_IRQS is not necessarily the total number of UIC irqs)a
hmmmmm... we should get ride of "NR_BOARD_IRQS" instead?
   - arch/ppc/platforms/ibm_ocp.h
      wrong header file included + some little name fixes
header file fix all ready in.  I will get the name change next patch in.


Regarding the newly introduce support for cascaded UICs:

Isn't the CONFIG_CASCADING_UIC option redundant?
If (CONFIG_CASCADING_UIC == (NR_UICS > 1)) is true, CONFIG_CASCADING_UIC
could be replace by (NR_UICS > 1).
Good point:)
Dave
Armin


** Sent via the linuxppc-embedded mail list. See http://lists.linuxppc.org/

Re: [PATCH] Several patches against linuxppc_devel-2.4.18-rc1

From: David Müller (ELSOFT AG) <hidden>
Date: 2002-02-18 12:35:05

Hi

Armin wrote:
David Müller (ELSOFT AG) wrote:
quoted
Hello

   - arch/ppc/kernel/ppc4xx_pic.c
      fixed constant in ppc405_pic_get_irq()
      (NR_IRQS is not necessarily the total number of UIC irqs)a

hmmmmm... we should get ride of "NR_BOARD_IRQS" instead?
What do you mean by "get ride of "NR_BOARD_IRQS"".
Remove "NR_BOARD_IRQS" and the whole functionality behind of it
completely or just replace "NR_BOARD_IRQS" by a more meaningful name?


Dave


** Sent via the linuxppc-embedded mail list. See http://lists.linuxppc.org/
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help