Re: ppc405 enet changes (fwd)

2 messages, 2 authors, 2001-09-05 · open the first message on its own page

Re: ppc405 enet changes (fwd)

From: andrew may <hidden>
Date: 2001-09-04 22:26:08

On Tue, Sep 04, 2001 at 06:38:02PM -0400, Dan Malek wrote:
John Tyner wrote:
quoted
Is this patch going to be applied to the kernel? I haven't seen it in the
logs...
I dunno.....from the code it doesn't look like you allow multiple
device support (probe is only done once for one device).  If you
have something that actually enables a new feature, add that too.
Otherwise, it just looks like you added some additional indirection
that doesn't add anything new and just adds overhead to the existing
driver.  I'm also trying to determine why your patch seems to add
things to the driver that should already be there.
Well we don't have the hardware to do multiple devices. I just know
that is possible in the future. I would prefer to go through the
pain of removing the static's now rather than later.

If you want to argue that we are just adding more redirection I will
be happy to send a patch to remove the entire struct ppc405_enet_private
to remove some more "useless" redirection. One of my biggest gripes
with the driver is that half of the stuff is kept as static and the
other half in the private sturct, for example ep_xmit_skb is in the
private stuct and ppc405_skb_rx is static. With things like this it
makes the entire driver hard to follow. I can't really think of an
explanation on why this is done in the driver. My only guess would
be that the person that did the driver has not done a linux network
driver before. There are other little clues throughout the driver
that point to this as well.
We don't just blindly take stuff from people and patch it.  We
actually have to believe it adds some benefits, we have to test
it, and then it gets checked in.  This doesn't happen overnight.
No I don't expect the patch to go in quickly. I just wanted John
to start the process off. This patch does not do much to fix anything
but I would like to make any future changes off the new variable
names rather than what is in there now. Since this patch touches
so much stuff I think it would be better to keep any real changes
out of it until it gets tested.

So if you want to point to specific code that you don't like let
us know.

--
Thanks

** Sent via the linuxppc-embedded mail list. See http://lists.linuxppc.org/

Re: ppc405 enet changes (fwd)

From: Dan Malek <hidden>
Date: 2001-09-05 00:06:26

andrew may wrote:
Well we don't have the hardware to do multiple devices. I just know
that is possible in the future. I would prefer to go through the
pain of removing the static's now rather than later.
Ummm...OK, I guess.

No I don't expect the patch to go in quickly. I just wanted John
to start the process off.
OK.  Once I actually get the 2_4_devel kernel booting and running with
some sense of reliability, I'll add the patch and give it a go.
So if you want to point to specific code that you don't like let
us know.
Yeah, all of the linux version stuff.  It is nice to get patches against
the current 2_4 or 2_4_devel that are known to be tested and working.
If you can't test it, don't expect a quick turn around because someone
else (like me :-) has to spend the time doing it.

Thanks.


	-- Dan

** Sent via the linuxppc-embedded mail list. See http://lists.linuxppc.org/
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help