slab allocator · Maintained
Maintainers
- M Vlastimil Babka <vbabka@kernel.org>
- M Harry Yoo <harry@kernel.org>
- M Andrew Morton <akpm@linux-foundation.org>
- R Hao Li <hao.li@linux.dev>
- R Christoph Lameter <cl@gentwo.org>
- R David Rientjes <rientjes@google.com>
- R Roman Gushchin <roman.gushchin@linux.dev>
Paths
- F
Documentation/admin-guide/mm/slab.rst - F
Documentation/mm/slab.rst - F
include/linux/mempool.h - F
include/linux/slab.h - F
lib/tests/slub_kunit.c - F
mm/failslab.c - F
mm/mempool.c - F
mm/slab.h - F
mm/slab_common.c - F
mm/slub.c - F
scripts/gdb/linux/slab.py - F
tools/cgroup/memcg_slabinfo.py - F
tools/include/linux/slab.h - F
tools/lib/slab.c - F
tools/mm/slabinfo-gnuplot.sh - F
tools/mm/slabinfo.c
Last 30 days
Recent patches
Most-recent 17 patches in this subsystem on linux-wireless, ordered by date desc.
-
STALE1356d
REVIEWED: 28 (27M) [PATCH v6 1/7] treewide: use prandom_u32_max() when possible, part 1
2022-10-10 · "Jason A. Donenfeld" <Jason@zx2c4.com> -
STALE1364d
REVIEWED: 2 (1M) [PATCH v5 1/7] treewide: use prandom_u32_max() when possible, part 1
2022-10-08 · "Jason A. Donenfeld" <Jason@zx2c4.com> -
STALE1365d
REVIEWED: 2 (1M) [PATCH v4 1/6] treewide: use prandom_u32_max() when possible, mechanically
2022-10-07 · "Jason A. Donenfeld" <Jason@zx2c4.com> -
STALE1364d
REVIEWED: 2 (1M) [PATCH v3 1/5] treewide: use prandom_u32_max() when possible
2022-10-06 · "Jason A. Donenfeld" <Jason@zx2c4.com> -
STALE1380d
[PATCH 12/12] slab: Restore __alloc_size attribute to __kmalloc_track_caller
2022-09-22 · Kees Cook <hidden> -
STALE1380d
[PATCH 11/12] slab: Remove __malloc attribute from realloc functions
2022-09-22 · Kees Cook <hidden> -
STALE1380d
[PATCH 01/12] slab: Introduce kmalloc_size_roundup()
2022-09-22 · Kees Cook <hidden> -
STALE2180d
[PATCH v2 15/16] treewide: Remove uninitialized_var() usage
2020-06-20 · Kees Cook <hidden> -
STALE2209d
REVIEWED: 4 (4M) [PATCH v5 1/2] mm/slab: Use memzero_explicit() in kzfree()
2020-06-16 · Waiman Long <longman@redhat.com> -
STALE2209d
REVIEWED: 19 (19M) [PATCH v5 2/2] mm, treewide: Rename kzfree() to kfree_sensitive()
2020-06-16 · Waiman Long <longman@redhat.com> -
STALE2208d
REVIEWED: 19 (19M) [PATCH v4 2/3] mm, treewide: Rename kzfree() to kfree_sensitive()
2020-06-16 · Waiman Long <longman@redhat.com> -
STALE2208d
[PATCH v4 1/3] mm/slab: Use memzero_explicit() in kzfree()
2020-06-16 · Waiman Long <longman@redhat.com> -
STALE2210d
[PATCH 09/10] treewide: Remove uninitialized_var() usage
2020-06-03 · Kees Cook <hidden> -
STALE2210d
[PATCH 1/2] mm, treewide: Rename kzfree() to kfree_sensitive()
2020-04-13 · Waiman Long <longman@redhat.com> -
STALE3926d
REVIEWED: 9 (8M) [PATCH V5 2/2] debugfs: Pass bool pointer to debugfs_create_bool()
2015-09-26 · Viresh Kumar <viresh.kumar@linaro.org> -
STALE3933d
REVIEWED: 9 (8M) [PATCH V4 2/2] debugfs: Pass bool pointer to debugfs_create_bool()
2015-09-25 · Viresh Kumar <viresh.kumar@linaro.org> -
DORMANTno replies
[POC] recoverable fault injection
2012-11-22 · Johannes Berg <johannes@sipsolutions.net>