security subsystem · Supported
Maintainers
- M Paul Moore <paul@paul-moore.com>
- M James Morris <jmorris@namei.org>
- M "Serge E. Hallyn" <serge@hallyn.com>
Paths
- F
include/linux/lsm/ - F
include/linux/lsm_audit.h - F
include/linux/lsm_hook_defs.h - F
include/linux/lsm_hooks.h - F
include/linux/security.h - F
include/uapi/linux/lsm.h - F
security/ - F
tools/testing/selftests/lsm/ - F
rust/kernel/security.rs - X
security/selinux/
Last 30 days
Most active threads (last 7 days)
-
HOTtoday
REVIEWED: 4 (4M) [PATCH 01/16 net-next v3] ipv4: introduce CONFIG_IPV4 to decouple the IPv4 stack
2026-09-30 13:54 · 0 replies in 7d · Fernando Fernandez Mancera <hidden> -
WARM1d
REVIEWED: 4 (4M) [PATCH 01/16 net-next v2] ipv4: introduce CONFIG_IPV4 to decouple the IPv4 stack
2026-09-28 19:31 · 0 replies in 7d · Fernando Fernandez Mancera <hidden>
Active reviewers (last 30 days)
-
Chuck Lever <cel@kernel.org>
2 attestations (2 Acked-by) · last on 2026-09-30
Recent patches
Most-recent 30 patches in this subsystem on linux-wireless (capped at 30), ordered by date desc.
-
HOTtoday
REVIEWED: 4 (4M) [PATCH 01/16 net-next v3] ipv4: introduce CONFIG_IPV4 to decouple the IPv4 stack
2026-09-30 · Fernando Fernandez Mancera <hidden> -
WARM1d
REVIEWED: 4 (4M) [PATCH 01/16 net-next v2] ipv4: introduce CONFIG_IPV4 to decouple the IPv4 stack
2026-09-28 · Fernando Fernandez Mancera <hidden> -
WARM2d
[PATCH 01/13 net-next] net: ipv4: introduce CONFIG_IPV4 to decouple the IPv4 stack
2026-09-10 · Fernando Fernandez Mancera <hidden> -
STALE167d
[PATCH 20/61] apparmor: Prefer IS_ERR_OR_NULL over manual NULL check
2026-03-10 · Philipp Hahn <hidden> -
STALE247d
[PATCH v5 34/36] security/tomoyo: Enable context analysis
2025-12-19 · Marco Elver <elver@google.com> -
STALE285d
[PATCH v4 33/35] security/tomoyo: Enable context analysis
2025-11-20 · Marco Elver <elver@google.com> -
STALE153d
[PATCH v3 07/14] yama: Remove redundant rcu_read_lock/unlock() in spin_lock
2025-09-16 · pengdonglin <hidden> -
STALE650d
REVIEWED: 19 (19M) [PATCH v2 4/5] security: Remove get_task_comm() and print task comm directly
2024-12-19 · Yafang Shao <hidden> -
STALE653d
[PATCH 5/7] security: Replace get_task_comm() with %pTN
2024-12-13 · Yafang Shao <hidden> -
STALE841d
[PATCH v1 1/1] treewide: Align match_string() with sysfs_match_string()
2024-06-03 · Andy Shevchenko <andriy.shevchenko@linux.intel.com> -
STALE1598d
[PATCH 27/32] KEYS: Use mem_to_flex_dup() with struct user_key_payload
2022-05-04 · Kees Cook <hidden> -
STALE1598d
[PATCH 26/32] ima: Use mem_to_flex_dup() with struct modsig
2022-05-04 · Kees Cook <hidden> -
STALE1771d
[PATCH v2 63/63] fortify: Work around Clang inlining bugs
2021-08-18 · Kees Cook <hidden> -
STALE1771d
[PATCH v2 28/63] fortify: Explicitly disable Clang support
2021-08-18 · Kees Cook <hidden> -
STALE1874d
[PATCH 60/64] fortify: Work around Clang inlining bugs
2021-07-27 · Kees Cook <hidden> -
STALE1874d
[PATCH 31/64] fortify: Explicitly disable Clang support
2021-07-27 · Kees Cook <hidden> -
STALE1829d
[PATCH 03/11] security: commoncap: fix -Wstringop-overread warning
2021-03-22 · Arnd Bergmann <arnd@kernel.org> -
STALE2171d
LANDED [RFC] treewide: cleanup unreachable breaks
2020-10-17 · trix@redhat.com -
STALE2297d
REVIEWED: 19 (19M) [PATCH v5 2/2] mm, treewide: Rename kzfree() to kfree_sensitive()
2020-06-16 · Waiman Long <longman@redhat.com> -
STALE2296d
REVIEWED: 19 (19M) [PATCH v4 2/3] mm, treewide: Rename kzfree() to kfree_sensitive()
2020-06-16 · Waiman Long <longman@redhat.com> -
STALE2298d
[PATCH 1/2] mm, treewide: Rename kzfree() to kfree_sensitive()
2020-04-13 · Waiman Long <longman@redhat.com> -
STALE2640d
[PATCH v1 01/22] docs: Documentation/*.txt: rename all ReST files to *.rst
2019-06-18 · Mauro Carvalho Chehab <mchehab+samsung@kernel.org> -
STALE2682d
[PATCH 2/3][V2] treewide: rename match_string() -> __match_string()
2019-05-28 · Alexandru Ardelean <hidden> -
STALE2682d
[PATCH 02/16] treewide: rename match_string() -> __match_string()
2019-05-08 · Alexandru Ardelean <hidden> -
STALE3152d
[PATCH v2] net: make getname() functions return length rather than use int* parameter
2018-02-12 · Denys Vlasenko <hidden> -
STALE3277d
[PATCH 10/13] timer: Remove expires and data arguments from DEFINE_TIMER
2017-10-04 · Kees Cook <hidden> -
STALE3900d
[PATCH 14/26] KEYS: Use skcipher
2016-01-24 · Herbert Xu <herbert@gondor.apana.org.au> -
DORMANTno replies
[PATCH 27/27] KEYS: Restrict signature verification to keys appropriate to the purpose
2015-07-17 · David Howells <dhowells@redhat.com> -
STALE4178d
[PATCH v2 1/8] kernel/params: constify struct kernel_param_ops uses
2015-04-22 · Luis R. Rodriguez <hidden> -
STALE4179d
[PATCH v1 0/6] module params: few simplifications
2015-04-20 · Luis R. Rodriguez <hidden>
Quiet for 30+ days
Patches with no review trailers and no replies. Either the author is heads-down elsewhere or these slipped through. Oldest first.
-
STALE167d
[PATCH 20/61] apparmor: Prefer IS_ERR_OR_NULL over manual NULL check
2026-03-10 · Philipp Hahn <hidden>