[PATCH 3/3] HID: usbhid: Simplify code in hid_submit_ctrl()
From: Alan Stern <stern@rowland.harvard.edu>
Date: 2021-09-01 16:36:12
Also in:
linux-input
This patch makes a small simplification to the code in hid_submit_ctrl(). The test for maxpacket being > 0 is unnecessary, because endpoint 0 always has a maxpacket value which is >= 8. Furthermore, endpoint 0's maxpacket value is always a power of 2, so instead of open-coding the round-to-next-multiple computation we can call the optimized round_up() routine. Signed-off-by: Alan Stern <stern@rowland.harvard.edu> Tested-by: Benjamin Tissoires <redacted> Acked-by: Benjamin Tissoires <redacted> --- drivers/hid/usbhid/hid-core.c | 12 ++++-------- 1 file changed, 4 insertions(+), 8 deletions(-) Index: usb-devel/drivers/hid/usbhid/hid-core.c ===================================================================
--- usb-devel.orig/drivers/hid/usbhid/hid-core.c
+++ usb-devel/drivers/hid/usbhid/hid-core.c@@ -388,14 +388,10 @@ static int hid_submit_ctrl(struct hid_de usbhid->urbctrl->pipe = usb_rcvctrlpipe(hid_to_usb_dev(hid), 0); maxpacket = usb_maxpacket(hid_to_usb_dev(hid), usbhid->urbctrl->pipe, 0); - if (maxpacket > 0) { - len += (len == 0); /* Don't allow 0-length reports */ - len = DIV_ROUND_UP(len, maxpacket); - len *= maxpacket; - if (len > usbhid->bufsize) - len = usbhid->bufsize; - } else - len = 0; + len += (len == 0); /* Don't allow 0-length reports */ + len = round_up(len, maxpacket); + if (len > usbhid->bufsize) + len = usbhid->bufsize; } usbhid->urbctrl->transfer_buffer_length = len; usbhid->urbctrl->dev = hid_to_usb_dev(hid);