page cache · Supported
Maintainers
- M Matthew Wilcox <willy@infradead.org>
- M Jan Kara <jack@suse.cz>
Paths
- F
Documentation/filesystems/locking.rst - F
Documentation/filesystems/vfs.rst - F
include/linux/pagemap.h - F
include/linux/writeback.h - F
include/trace/events/filemap.h - F
include/trace/events/readahead.h - F
include/trace/events/writeback.h - F
mm/filemap.c - F
mm/page-writeback.c - F
mm/readahead.c - F
mm/truncate.c
Last 30 days
Most active threads (last 7 days)
-
HOTtoday
IN LINUX-NEXT [PATCH v2 00/33] mm: make VMA page offset handling more consistent
2026-07-10 20:24 · 2 replies in 7d · Lorenzo Stoakes <ljs@kernel.org>
Active reviewers (last 30 days)
-
Gregory Price <gourry@gourry.net>
2 attestations (2 Reviewed-by) · last on 2026-07-10 -
Pedro Falcato <pfalcato@suse.de>
2 attestations (2 Reviewed-by) · last on 2026-07-10 -
SJ Park <sj@kernel.org>
1 attestation (1 Reviewed-by) · last on 2026-07-10 -
Ackerley Tng <hidden>
1 attestation (1 Reviewed-by) · last on 2026-07-10
Recent patches
Most-recent 30 patches in this subsystem on linux-trace-kernel (capped at 30), ordered by date desc.
-
HOTtoday
IN LINUX-NEXT: 3 (3M) [PATCH v2 18/33] mm/vma: use vma_start_pgoff(), linear_page_index() in mm code
2026-07-10 · Lorenzo Stoakes <ljs@kernel.org> -
HOTtoday
IN LINUX-NEXT: 3 (2M) [PATCH v2 17/33] mm: introduce and use linear_page_delta()
2026-07-10 · Lorenzo Stoakes <ljs@kernel.org> -
COOLING4d
[PATCH 16/30] mm/vma: use vma_start_pgoff(), linear_page_index() in mm code
2026-06-29 · Lorenzo Stoakes <ljs@kernel.org> -
COOLING4d
[PATCH 15/30] mm: introduce and use linear_page_delta()
2026-06-29 · Lorenzo Stoakes <ljs@kernel.org> -
STALE78d
[PATCH v3 2/4] mm: kick writeback flusher for IOCB_DONTCACHE with targeted dirty tracking
2026-04-26 · Jeff Layton <jlayton@kernel.org> -
STALE78d
[PATCH v3 1/4] mm: add NR_DONTCACHE_DIRTY node page counter
2026-04-26 · Jeff Layton <jlayton@kernel.org> -
STALE111d
[PATCH 46/53] Remove references to d_add() in documentation and comments.
2026-03-12 · NeilBrown <hidden> -
STALE111d
[PATCH 02/53] VFS: enhance d_splice_alias() to handle in-lookup dentries
2026-03-12 · NeilBrown <hidden> -
STALE121d
[PATCH v3 04/12] vfs: widen trace event i_ino fields to u64
2026-03-04 · Jeff Layton <jlayton@kernel.org> -
STALE133d
[PATCH v2 006/110] trace: reorder TP_STRUCT__entry fields for better packing on 32-bit
2026-03-02 · Jeff Layton <jlayton@kernel.org> -
STALE133d
[PATCH v2 005/110] trace: store i_ino as u64 instead of ino_t/unsigned long
2026-03-02 · Jeff Layton <jlayton@kernel.org> -
STALE138d
[PATCH 03/61] trace: update VFS-layer trace events for u64 i_ino
2026-02-26 · Jeff Layton <jlayton@kernel.org> -
STALE139d
[PATCH v1] mm: annotate data race of f_ra.prev_pos
2026-02-26 · Jiayuan Chen <jiayuan.chen@linux.dev> -
STALE160d
[RFC PATCH v1 09/37] KVM: guest_memfd: Skip LRU for guest_memfd folios
2025-10-17 · Ackerley Tng <hidden> -
STALE295d
[RFC PATCH v0] mm/vmscan: Add readahead LRU to improve readahead file page reclamation efficiency
2025-09-16 · Lei Liu <hidden> -
STALE356d
[PATCH v5 3/3] treewide: Switch from tsk->comm to tsk->comm_str which is 64 bytes long
2025-07-16 · Bhupesh <hidden> -
STALE322d
[PATCH 2/3] mm: update core kernel code to use vm_flags_t consistently
2025-06-18 · Lorenzo Stoakes <hidden> -
STALE524d
Re: [PATCHv3 06/11] mm/vmscan: Use PG_dropbehind instead of PG_reclaim
2025-02-01 · Kairui Song <hidden> -
STALE524d
REVIEWED: 1 (0M) [PATCHv3 09/11] mm: Remove PG_reclaim
2025-01-30 · Kirill A. Shutemov <hidden> -
STALE524d
[PATCHv3 11/11] mm: Rename PG_dropbehind to PG_reclaim
2025-01-30 · Kirill A. Shutemov <hidden> -
STALE524d
[PATCHv3 05/11] mm/truncate: Use folio_set_dropbehind() instead of deactivate_file_folio()
2025-01-30 · Kirill A. Shutemov <hidden> -
STALE544d
[PATCHv2 11/11] mm: Rename PG_dropbehind to PG_reclaim
2025-01-15 · Kirill A. Shutemov <hidden> -
STALE544d
[PATCHv2 09/11] mm: Remove PG_reclaim
2025-01-15 · Kirill A. Shutemov <hidden> -
STALE544d
[PATCHv2 05/11] mm/truncate: Use folio_set_dropbehind() instead of deactivate_file_folio()
2025-01-15 · Kirill A. Shutemov <hidden> -
STALE547d
Re: [PATCH 4/8] mm/swap: Use PG_dropbehind instead of PG_reclaim
2025-01-15 · Yu Zhao <hidden> -
STALE547d
[PATCH 8/8] mm: Remove PG_reclaim
2025-01-13 · Kirill A. Shutemov <hidden> -
STALE532d
REVIEWED: 5 (3M) [PATCH v2] treewide: const qualify ctl_tables where applicable
2025-01-10 · Joel Granados <joel.granados@kernel.org> -
STALE551d
[PATCH] treewide: const qualify ctl_tables where applicable
2025-01-09 · Joel Granados <joel.granados@kernel.org> -
STALE685d
LANDED [PATCH v2] writeback: Refine the show_inode_state() macro definition
2024-08-28 · Julian Sun <hidden> -
STALE686d
[PATCH] writeback: Refine the show_inode_state() macro definition
2024-08-20 · Julian Sun <hidden>
Quiet for 30+ days
Patches with no review trailers and no replies. Either the author is heads-down elsewhere or these slipped through. Oldest first.
-
STALE133d
[PATCH v2 005/110] trace: store i_ino as u64 instead of ino_t/unsigned long
2026-03-02 · Jeff Layton <jlayton@kernel.org> -
STALE133d
[PATCH v2 006/110] trace: reorder TP_STRUCT__entry fields for better packing on 32-bit
2026-03-02 · Jeff Layton <jlayton@kernel.org> -
STALE111d
[PATCH 02/53] VFS: enhance d_splice_alias() to handle in-lookup dentries
2026-03-12 · NeilBrown <hidden> -
STALE111d
[PATCH 46/53] Remove references to d_add() in documentation and comments.
2026-03-12 · NeilBrown <hidden> -
STALE78d
[PATCH v3 1/4] mm: add NR_DONTCACHE_DIRTY node page counter
2026-04-26 · Jeff Layton <jlayton@kernel.org>