Reviews by mark.rutland@arm.com
· linux-trace-kernel
All review-attestation trailers
(Reviewed-by / Acked-by /
Tested-by / Reported-by /
Suggested-by / Co-developed-by /
Reported-and-tested-by)
by this address on the linux-trace-kernel archive.
100 attestations · capped at 100 most-recent. (54 Acked-by, 8 Co-developed-by, 6 Reported-by, 10 Reviewed-by, 3 Suggested-by, 19 Tested-by)
-
STALE204d
REVIEWED: 7 (7M) Re: [PATCH v2] arm64: Disable branch profiling for all arm64 code
2026-01-06 · Acked-by -
STALE329d
REVIEWED: 7 (7M) Re: [PATCH v2] arm64: ftrace: fix unreachable PLT for ftrace_caller in init_module with CONFIG_DYNAMIC_FTRACE
2025-09-05 · Acked-by -
STALE329d
REVIEWED: 7 (7M) Re: [PATCH v1] arm64: ftrace: fix unreachable PLT for ftrace_caller in init_module with CONFIG_DYNAMIC_FTRACE
2025-09-04 · Acked-by -
STALE648d
LANDED: 7 (7M) [PATCH v16 02/18] tracing: Rename ftrace_regs_return_value to ftrace_regs_get_return_value
2024-10-15 · Acked-by -
STALE648d
REVIEWED: 7 (7M) Re: [PATCH v2] arm64: insn: Simulate nop instruction for better uprobe performance
2024-10-10 · Acked-by -
STALE660d
REVIEWED: 7 (7M) [PATCH v15 02/19] tracing: Rename ftrace_regs_return_value to ftrace_regs_get_return_value
2024-09-15 · Acked-by -
STALE660d
REVIEWED: 7 (7M) [PATCH v15 01/19] tracing: Add a comment about ftrace_regs definition
2024-09-15 · Acked-by -
STALE667d
REVIEWED: 7 (7M) [PATCH v14 02/19] tracing: Rename ftrace_regs_return_value to ftrace_regs_get_return_value
2024-09-12 · Acked-by -
STALE667d
REVIEWED: 7 (7M) [PATCH v14 01/19] tracing: Add a comment about ftrace_regs definition
2024-09-12 · Acked-by -
DORMANTno replies
[PATCH v3] arm64: Replace linked list with switch statement for BRK handlers
2024-09-06 · Suggested-by -
STALE696d
[PATCH v2] arm64: Replace linked list with switch statement for breakpoint handlers
2024-08-31 · Suggested-by -
DORMANTno replies
[PATCH] arm64: Replace linked list with switch statement for breakpoint handlers
2024-08-31 · Suggested-by -
STALE688d
REVIEWED: 7 (7M) [PATCH v13 03/20] tracing: Rename ftrace_regs_return_value to ftrace_regs_get_return_value
2024-08-18 · Acked-by -
STALE688d
REVIEWED: 7 (7M) [PATCH v13 02/20] tracing: Add a comment about ftrace_regs definition
2024-08-18 · Acked-by -
STALE758d
REVIEWED: 7 (7M) [PATCH v12 02/19] tracing: Rename ftrace_regs_return_value to ftrace_regs_get_return_value
2024-07-03 · Acked-by -
STALE758d
REVIEWED: 7 (7M) [PATCH v12 01/19] tracing: Add a comment about ftrace_regs definition
2024-07-03 · Acked-by -
STALE767d
REVIEWED: 7 (7M) [PATCH v11 02/18] tracing: Rename ftrace_regs_return_value to ftrace_regs_get_return_value
2024-06-17 · Acked-by -
STALE767d
REVIEWED: 7 (7M) [PATCH v11 01/18] tracing: Add a comment about ftrace_regs definition
2024-06-17 · Acked-by -
STALE785d
REVIEWED: 7 (7M) Re: [PATCH v2 5/5] ftrace: Add comments to ftrace_hash_move() and friends
2024-06-06 · Acked-by -
STALE785d
REVIEWED: 7 (7M) Re: [PATCH v2 4/5] ftrace: Convert "inc" parameter to bool in ftrace_hash_rec_update_modify()
2024-06-06 · Acked-by -
STALE785d
REVIEWED: 14 (14M) Re: [PATCH v2 2/5] ftrace: Remove "ftrace_hash" parameter from __ftrace_hash_rec_update()
2024-06-06 · Reviewed-by -
STALE785d
REVIEWED: 14 (14M) Re: [PATCH v2 2/5] ftrace: Remove "ftrace_hash" parameter from __ftrace_hash_rec_update()
2024-06-06 · Tested-by -
STALE785d
REVIEWED: 7 (7M) Re: [PATCH v2 1/5] ftrace: Rename dup_hash() and comment it
2024-06-06 · Acked-by -
STALE785d
LANDED: 7 (7M) [PATCH v2 3/5] ftrace: Add comments to ftrace_hash_rec_disable/enable()
2024-06-05 · Acked-by -
STALE786d
REVIEWED: 7 (7M) Re: [PATCH 4/5] ftrace: Convert "filter_hash" and "inc" to bool in ftrace_hash_rec_update_modify()
2024-06-05 · Acked-by -
STALE786d
REVIEWED: 7 (7M) Re: [PATCH 3/5] ftrace: Remove "filter_hash" parameter from ftrace_hash_rec_disable/enable()
2024-06-05 · Acked-by -
DORMANTno replies
REVIEWED: 7 (7M) Re: [PATCH] ftrace/selftests: Fix pid test with function graph not showing pids
2024-06-05 · Tested-by -
STALE786d
LANDED [PATCH] ftrace/selftests: Fix pid test with function graph not showing pids
2024-06-04 · Reported-by -
STALE797d
REVIEWED: 7 (7M) [PATCH v10 02/36] tracing: Rename ftrace_regs_return_value to ftrace_regs_get_return_value
2024-05-07 · Acked-by -
STALE797d
REVIEWED: 7 (7M) [PATCH v10 01/36] tracing: Add a comment about ftrace_regs definition
2024-05-07 · Acked-by -
STALE808d
REVIEWED: 7 (7M) [PATCH 14/48] tracing: Select new NEED_TASKS_RCU Kconfig option
2024-05-07 · Acked-by -
STALE815d
REVIEWED: 7 (7M) [PATCH v9 02/36] tracing: Rename ftrace_regs_return_value to ftrace_regs_get_return_value
2024-04-15 · Acked-by -
STALE815d
REVIEWED: 7 (7M) [PATCH v9 01/36] tracing: Add a comment about ftrace_regs definition
2024-04-15 · Acked-by -
STALE885d
REVIEWED: 7 (7M) [PATCH v8 02/35] tracing: Rename ftrace_regs_return_value to ftrace_regs_get_return_value
2024-02-25 · Acked-by -
STALE885d
REVIEWED: 7 (7M) [PATCH v8 01/35] tracing: Add a comment about ftrace_regs definition
2024-02-25 · Acked-by -
STALE893d
REVIEWED: 7 (7M) [PATCH v7 03/36] tracing: Rename ftrace_regs_return_value to ftrace_regs_get_return_value
2024-02-06 · Acked-by -
STALE893d
REVIEWED: 7 (7M) [PATCH v7 02/36] tracing: Add a comment about ftrace_regs definition
2024-02-06 · Acked-by -
STALE893d
REVIEWED: 10 (10M) [PATCH v7 01/36] ftrace: Fix DIRECT_CALLS to use SAVE_REGS by default
2024-02-06 · Reviewed-by -
STALE914d
REVIEWED: 7 (7M) [PATCH v6 03/36] tracing: Rename ftrace_regs_return_value to ftrace_regs_get_return_value
2024-01-12 · Acked-by -
STALE914d
REVIEWED: 7 (7M) [PATCH v6 02/36] tracing: Add a comment about ftrace_regs definition
2024-01-12 · Acked-by -
STALE914d
REVIEWED: 10 (10M) [PATCH v6 01/36] ftrace: Fix DIRECT_CALLS to use SAVE_REGS by default
2024-01-12 · Reviewed-by -
STALE933d
REVIEWED: 7 (7M) Re: [PATCH] ftrace: Fix DIRECT_CALLS to use SAVE_REGS by default
2024-01-10 · Reviewed-by -
STALE932d
REVIEWED: 7 (7M) Re: [PATCH v5 22/34] tracing: Rename ftrace_regs_return_value to ftrace_regs_get_return_value
2024-01-05 · Acked-by -
STALE932d
REVIEWED: 7 (7M) Re: [PATCH v5 01/34] tracing: Add a comment about ftrace_regs definition
2024-01-05 · Acked-by -
STALE982d
[PATCH 1/4] eventfs: Use GFP_NOFS for allocation when eventfs_mutex is held
2023-11-21 · Reported-by -
DORMANTno replies
[PATCH 1/2] eventfs: Remove expectation that ei->is_freed means ei->dentry == NULL
2023-11-20 · Reported-by -
STALE984d
[PATCH 2/2] eventfs: Do not invalidate dentry in create_file/dir_dentry()
2023-11-20 · Reported-by -
STALE1010d
REVIEWED: 7 (7M) Re: [PATCH] locking/atomic: sh: Use generic_cmpxchg_local for arch_cmpxchg_local()
2023-10-25 · Acked-by -
STALE1144d
REVIEWED: 7 (7M) Re: [PATCH v2] ftrace: Allow inline functions not inlined to be traced
2023-06-12 · Acked-by -
STALE1117d
REVIEWED: 14 (14M) [PATCH 2/2] arm64: ftrace: Add direct call trampoline samples support
2023-04-27 · Reviewed-by -
STALE1117d
REVIEWED: 14 (14M) [PATCH 2/2] arm64: ftrace: Add direct call trampoline samples support
2023-04-27 · Tested-by -
STALE1117d
REVIEWED: 24 (24M) [PATCH 1/2] samples: ftrace: Save required argument registers in sample trampolines
2023-04-27 · Reviewed-by -
STALE1137d
REVIEWED: 14 (14M) [PATCH v11 4/8] arm64: ftrace: Enable HAVE_FUNCTION_GRAPH_RETVAL
2023-04-08 · Reviewed-by -
STALE1137d
REVIEWED: 14 (14M) [PATCH v11 4/8] arm64: ftrace: Enable HAVE_FUNCTION_GRAPH_RETVAL
2023-04-08 · Tested-by -
STALE1194d
REVIEWED: 14 (14M) Re: [PATCH v6 4/5] arm64: ftrace: Add direct call trampoline samples support
2023-04-06 · Reviewed-by -
STALE1194d
REVIEWED: 14 (14M) Re: [PATCH v6 4/5] arm64: ftrace: Add direct call trampoline samples support
2023-04-06 · Tested-by -
STALE1194d
REVIEWED: 7 (7M) Re: [PATCH v6 3/5] samples: ftrace: Save required argument registers in sample trampolines
2023-04-06 · Reviewed-by -
STALE1194d
LANDED: 7 (7M) [PATCH v6 2/5] arm64: ftrace: Simplify get_ftrace_plt
2023-04-05 · Acked-by -
STALE1194d
LANDED [PATCH v6 1/5] arm64: ftrace: Add direct call support
2023-04-05 · Co-developed-by -
STALE1214d
REVIEWED: 7 (7M) [PATCH v5 2/4] arm64: ftrace: Simplify get_ftrace_plt
2023-04-03 · Acked-by -
STALE1214d
[PATCH v5 1/4] arm64: ftrace: Add direct call support
2023-04-03 · Co-developed-by -
STALE1215d
REVIEWED: 7 (7M) [PATCH v4 2/4] arm64: ftrace: Simplify get_ftrace_plt
2023-04-03 · Acked-by -
STALE1215d
[PATCH v4 1/4] arm64: ftrace: Add direct call support
2023-04-03 · Co-developed-by -
STALE1212d
REVIEWED: 14 (14M) Re: [PATCH v10 4/8] arm64: ftrace: Enable HAVE_FUNCTION_GRAPH_RETVAL
2023-04-03 · Reviewed-by -
STALE1212d
REVIEWED: 14 (14M) Re: [PATCH v10 4/8] arm64: ftrace: Enable HAVE_FUNCTION_GRAPH_RETVAL
2023-04-03 · Tested-by -
STALE1222d
REVIEWED: 7 (7M) Re: [PATCH v3 2/4] arm64: ftrace: Simplify get_ftrace_plt
2023-03-24 · Acked-by -
STALE1222d
[PATCH v3 1/4] arm64: ftrace: Add direct call support
2023-03-24 · Co-developed-by -
STALE1225d
[PATCH v2 6/7] ftrace: Make DIRECT_CALLS work WITH_ARGS and !WITH_REGS
2023-03-21 · Co-developed-by -
STALE1225d
REVIEWED: 14 (14M) [PATCH v2 4/7] ftrace: Rename _ftrace_direct_multi APIs to _ftrace_direct APIs
2023-03-21 · Acked-by -
STALE1225d
REVIEWED: 14 (14M) [PATCH v2 4/7] ftrace: Rename _ftrace_direct_multi APIs to _ftrace_direct APIs
2023-03-21 · Tested-by -
STALE1225d
REVIEWED: 14 (14M) [PATCH v2 3/7] ftrace: Remove the legacy _ftrace_direct API
2023-03-21 · Acked-by -
STALE1225d
REVIEWED: 14 (14M) [PATCH v2 3/7] ftrace: Remove the legacy _ftrace_direct API
2023-03-21 · Tested-by -
STALE1225d
REVIEWED: 14 (14M) [PATCH v2 2/7] ftrace: Replace uses of _ftrace_direct APIs with _ftrace_direct_multi
2023-03-21 · Acked-by -
STALE1225d
REVIEWED: 14 (14M) [PATCH v2 2/7] ftrace: Replace uses of _ftrace_direct APIs with _ftrace_direct_multi
2023-03-21 · Tested-by -
STALE1225d
REVIEWED: 7 (7M) [PATCH v2 1/7] ftrace: Let unregister_ftrace_direct_multi() call ftrace_free_filter()
2023-03-21 · Acked-by -
STALE1228d
REVIEWED: 7 (7M) Re: [PATCH 1/7] ftrace: Let unregister_ftrace_direct_multi() call ftrace_free_filter()
2023-03-21 · Acked-by -
STALE1228d
REVIEWED: 7 (7M) Re: [PATCH] ftrace: set direct_ops storage-class-specifier to static
2023-03-20 · Acked-by -
STALE1228d
[PATCH 6/7] ftrace: Make DIRECT_CALLS work WITH_ARGS and !WITH_REGS
2023-03-16 · Co-developed-by -
STALE1228d
REVIEWED: 14 (14M) [PATCH 4/7] ftrace: Rename _ftrace_direct_multi APIs to _ftrace_direct APIs
2023-03-16 · Acked-by -
STALE1228d
REVIEWED: 14 (14M) [PATCH 4/7] ftrace: Rename _ftrace_direct_multi APIs to _ftrace_direct APIs
2023-03-16 · Tested-by -
STALE1228d
REVIEWED: 14 (14M) [PATCH 3/7] ftrace: Remove the legacy _ftrace_direct API
2023-03-16 · Acked-by -
STALE1228d
REVIEWED: 14 (14M) [PATCH 3/7] ftrace: Remove the legacy _ftrace_direct API
2023-03-16 · Tested-by -
STALE1228d
REVIEWED: 14 (14M) [PATCH 2/7] ftrace: Replace uses of _ftrace_direct APIs with _ftrace_direct_multi
2023-03-16 · Acked-by -
STALE1228d
REVIEWED: 14 (14M) [PATCH 2/7] ftrace: Replace uses of _ftrace_direct APIs with _ftrace_direct_multi
2023-03-16 · Tested-by -
DORMANTno replies
REVIEWED: 7 (7M) Re: [PATCH 1/2] tracing: Do not let histogram values have some modifiers
2023-03-02 · Tested-by -
STALE1247d
REVIEWED: 7 (7M) Re: [PATCH 2/2] tracing: Check field value in hist_field_name()
2023-03-02 · Tested-by -
STALE1247d
[PATCH 1/2] tracing: Do not let histogram values have some modifiers
2023-03-02 · Reported-by -
STALE1247d
[PATCH 2/2] tracing: Check field value in hist_field_name()
2023-03-02 · Reported-by -
STALE1233d
[PATCH v2 07/10] arm64: ftrace: Add direct call support
2023-02-07 · Co-developed-by -
STALE1233d
[PATCH v2 05/10] ftrace: Make DIRECT_CALLS work WITH_ARGS and !WITH_REGS
2023-02-07 · Co-developed-by -
STALE1233d
REVIEWED: 14 (14M) [PATCH v2 03/10] ftrace: Rename _ftrace_direct_multi APIs to _ftrace_direct APIs
2023-02-07 · Acked-by -
STALE1233d
REVIEWED: 14 (14M) [PATCH v2 03/10] ftrace: Rename _ftrace_direct_multi APIs to _ftrace_direct APIs
2023-02-07 · Tested-by -
STALE1233d
REVIEWED: 14 (14M) [PATCH v2 02/10] ftrace: Remove the legacy _ftrace_direct API
2023-02-07 · Acked-by -
STALE1233d
REVIEWED: 14 (14M) [PATCH v2 02/10] ftrace: Remove the legacy _ftrace_direct API
2023-02-07 · Tested-by -
STALE1233d
REVIEWED: 14 (14M) [PATCH v2 01/10] ftrace: Replace uses of _ftrace_direct APIs with _ftrace_direct_multi
2023-02-07 · Acked-by -
STALE1233d
REVIEWED: 14 (14M) [PATCH v2 01/10] ftrace: Replace uses of _ftrace_direct APIs with _ftrace_direct_multi
2023-02-07 · Tested-by -
STALE1270d
REVIEWED: 14 (14M) Re: [PATCH 3/8] ftrace: Rename _ftrace_direct_multi APIs to _ftrace_direct APIs
2023-02-02 · Acked-by -
STALE1270d
REVIEWED: 14 (14M) Re: [PATCH 3/8] ftrace: Rename _ftrace_direct_multi APIs to _ftrace_direct APIs
2023-02-02 · Tested-by -
STALE1270d
REVIEWED: 14 (14M) Re: [PATCH 2/8] ftrace: Remove the legacy _ftrace_direct API
2023-02-02 · Acked-by -
STALE1270d
REVIEWED: 14 (14M) Re: [PATCH 2/8] ftrace: Remove the legacy _ftrace_direct API
2023-02-02 · Tested-by