namespaces: · Maintained
Maintainers
- M Christian Brauner <christian@brauner.io>
- R Pavel Tikhomirov <ptikhomirov@virtuozzo.com>
Paths
- F
rust/kernel/pid_namespace.rs - F
kernel/pid_namespace.c - F
tools/testing/selftests/pid_namespace/
Last 30 days
Active reviewers (last 30 days)
-
Alice Ryhl <aliceryhl@google.com>
5 attestations (3 Reviewed-by, 2 Suggested-by) · last on 2026-06-28 -
Benno Lossin <lossin@kernel.org>
3 attestations (3 Suggested-by) · last on 2026-06-28 -
Daniel Almeida <daniel.almeida@collabora.com>
2 attestations (2 Reviewed-by) · last on 2026-06-26 -
Igor Korotin <hidden>
2 attestations (2 Acked-by) · last on 2026-06-26 -
Danilo Krummrich <dakr@kernel.org>
2 attestations (2 Acked-by) · last on 2026-06-26 -
Viresh Kumar <viresh.kumar@linaro.org>
2 attestations (2 Acked-by) · last on 2026-06-26 -
Gary Guo <gary@garyguo.net>
2 attestations (2 Reviewed-by) · last on 2026-06-26 -
Andreas Hindborg <a.hindborg@kernel.org>
2 attestations (2 Co-developed-by) · last on 2026-06-26
Recent patches
Most-recent 30 patches in this subsystem on linux-security-module (capped at 30), ordered by date desc.
-
COOLING12d
REVIEWED: 12 (12M) [PATCH v7] rust: aref: make `AlwaysRefCounted::inc_ref` an associated function
2026-06-28 · Trevor Chan <hidden> -
COOLING12d
REVIEWED: 12 (12M) [PATCH v6] rust: aref: make `AlwaysRefCounted::inc_ref` an associated function
2026-06-28 · Trevor Chan <hidden> -
COOLING13d
REVIEWED: 12 (12M) [PATCH v5] rust: aref: make `AlwaysRefCounted::inc_ref` an associated function
2026-06-28 · Trevor Chan <hidden> -
COOLING4d
REVIEWED: 34 (33M) [PATCH v19 5/8] rust: rename `AlwaysRefCounted` to `RefCounted`.
2026-06-26 · Andreas Hindborg <a.hindborg@kernel.org> -
COLD16d
REVIEWED: 34 (33M) [PATCH v18 5/8] rust: rename `AlwaysRefCounted` to `RefCounted`.
2026-06-25 · Andreas Hindborg <a.hindborg@kernel.org> -
COLD17d
REVIEWED: 34 (33M) [PATCH v17 06/10] rust: rename `AlwaysRefCounted` to `RefCounted`.
2026-06-04 · Andreas Hindborg <a.hindborg@kernel.org> -
STALE115d
[PATCH v2 2/2] tree-wide: rename do_exit() to task_exit()
2026-03-10 · Christian Brauner <brauner@kernel.org> -
STALE131d
REVIEWED: 34 (33M) [PATCH v16 03/10] rust: rename `AlwaysRefCounted` to `RefCounted`.
2026-02-24 · Andreas Hindborg <a.hindborg@kernel.org> -
STALE137d
REVIEWED: 34 (33M) [PATCH v15 2/9] rust: rename `AlwaysRefCounted` to `RefCounted`.
2026-02-20 · Andreas Hindborg <a.hindborg@kernel.org> -
STALE155d
REVIEWED: 7 (7M) [PATCH v14 2/9] rust: rename `AlwaysRefCounted` to `RefCounted`.
2026-02-04 · Andreas Hindborg <a.hindborg@kernel.org> -
STALE159d
[PATCH v13 2/4] rust: `AlwaysRefCounted` is renamed to `RefCounted`.
2025-11-17 · Oliver Mangold <hidden> -
DORMANTno replies
Re: [GIT PULL] Block fixes for 6.18-rc3
2025-11-01 · Christian Brauner <brauner@kernel.org> -
STALE182d
REVIEWED: 1 (0M) [PATCH v3] selftests: complete kselftest include centralization
2025-10-16 · Bala-Vignesh-Reddy <hidden> -
STALE296d
LANDED: 1 (0M) [PATCH v2 2/4] copy_process: pass clone_flags as u64 across calltree
2025-09-01 · Simon Schuster via B4 Relay <devnull+schuster.simon.siemens-energy.com@kernel.org> -
STALE182d
[PATCH v2 2/2] selftests: Replace relative includes with non-relative for kselftest.h and kselftest_harness.h
2025-08-30 · Bala-Vignesh-Reddy <hidden> -
STALE182d
[PATCH 2/2] selftests: Replace relative includes with non-relative for kselftest.h and kselftest_harness.h
2025-08-27 · Bala-Vignesh-Reddy <hidden> -
STALE528d
REVIEWED: 5 (3M) [PATCH v2] treewide: const qualify ctl_tables where applicable
2025-01-10 · Joel Granados <joel.granados@kernel.org> -
STALE547d
[PATCH] treewide: const qualify ctl_tables where applicable
2025-01-09 · Joel Granados <joel.granados@kernel.org> -
STALE642d
LANDED [PATCH v5] rust: add PidNamespace
2024-10-02 · Christian Brauner <brauner@kernel.org> -
STALE647d
[PATCH v4] rust: add PidNamespace
2024-10-02 · Christian Brauner <brauner@kernel.org> -
DORMANTno replies
[PATCH v3] rust: add PidNamespace
2024-10-01 · Christian Brauner <brauner@kernel.org> -
STALE647d
[PATCH v2] rust: add PidNamespace
2024-10-01 · Christian Brauner <brauner@kernel.org> -
STALE647d
[PATCH] [RFC] rust: add PidNamespace wrapper
2024-09-26 · Christian Brauner <brauner@kernel.org> -
STALE779d
REVIEWED: 2 (1M) [PATCH v5 41/68] selftests/pid_namespace: Drop define _GNU_SOURCE
2024-05-22 · Edward Liaw <hidden> -
STALE785d
REVIEWED: 2 (1M) [PATCH v4 41/66] selftests/pid_namespace: Drop define _GNU_SOURCE
2024-05-10 · Edward Liaw <hidden> -
STALE789d
REVIEWED: 2 (1M) [PATCH v3 43/68] selftests/pid_namespace: Drop define _GNU_SOURCE
2024-05-09 · Edward Liaw <hidden> -
STALE793d
[PATCH v2 4/5] selftests: Drop define _GNU_SOURCE
2024-05-07 · Edward Liaw <hidden> -
STALE790d
[PATCH v3 11/11] sysctl: treewide: constify the ctl_table argument of handlers
2024-04-23 · Thomas Weißschuh <linux@weissschuh.net> -
STALE848d
[PATCH 11/11] sysctl: treewide: constify the ctl_table argument of handlers
2024-03-15 · Thomas Weißschuh <linux@weissschuh.net> -
STALE1114d
[PATCH 09/11] sysctl: Remove the end element in sysctl table arrays
2023-06-21 · Joel Granados <hidden>