drm drivers · Maintained
Maintainers
- M David Airlie <airlied@gmail.com>
- M Simona Vetter <simona@ffwll.ch>
Paths
- F
Documentation/devicetree/bindings/display/ - F
Documentation/devicetree/bindings/gpu/ - F
Documentation/gpu/ - F
drivers/gpu/ - F
rust/kernel/drm/ - F
include/drm/ - F
include/linux/vga* - F
include/uapi/drm/
Last 30 days
Active reviewers (last 30 days)
-
Alice Ryhl <aliceryhl@google.com>
5 attestations (3 Reviewed-by, 2 Suggested-by) · last on 2026-06-28 -
Benno Lossin <lossin@kernel.org>
3 attestations (3 Suggested-by) · last on 2026-06-28 -
Daniel Almeida <daniel.almeida@collabora.com>
2 attestations (2 Reviewed-by) · last on 2026-06-26 -
Igor Korotin <hidden>
2 attestations (2 Acked-by) · last on 2026-06-26 -
Danilo Krummrich <dakr@kernel.org>
2 attestations (2 Acked-by) · last on 2026-06-26 -
Viresh Kumar <viresh.kumar@linaro.org>
2 attestations (2 Acked-by) · last on 2026-06-26 -
Gary Guo <gary@garyguo.net>
2 attestations (2 Reviewed-by) · last on 2026-06-26 -
Andreas Hindborg <a.hindborg@kernel.org>
2 attestations (2 Co-developed-by) · last on 2026-06-26
Recent patches
Most-recent 30 patches in this subsystem on linux-security-module (capped at 30), ordered by date desc.
-
COOLING13d
REVIEWED: 12 (12M) [PATCH v7] rust: aref: make `AlwaysRefCounted::inc_ref` an associated function
2026-06-28 · Trevor Chan <hidden> -
COOLING13d
REVIEWED: 12 (12M) [PATCH v6] rust: aref: make `AlwaysRefCounted::inc_ref` an associated function
2026-06-28 · Trevor Chan <hidden> -
COOLING14d
REVIEWED: 12 (12M) [PATCH v5] rust: aref: make `AlwaysRefCounted::inc_ref` an associated function
2026-06-28 · Trevor Chan <hidden> -
COOLING5d
REVIEWED: 34 (33M) [PATCH v19 5/8] rust: rename `AlwaysRefCounted` to `RefCounted`.
2026-06-26 · Andreas Hindborg <a.hindborg@kernel.org> -
COLD16d
REVIEWED: 34 (33M) [PATCH v18 5/8] rust: rename `AlwaysRefCounted` to `RefCounted`.
2026-06-25 · Andreas Hindborg <a.hindborg@kernel.org> -
COLD17d
REVIEWED: 34 (33M) [PATCH v17 06/10] rust: rename `AlwaysRefCounted` to `RefCounted`.
2026-06-04 · Andreas Hindborg <a.hindborg@kernel.org> -
COLD31d
[PATCH 10/11] treewide: Manually convert custom kernel_param_ops .get callbacks
2026-05-21 · Kees Cook <kees@kernel.org> -
COLD31d
[PATCH 09/11] treewide: Convert custom kernel_param_ops .get callbacks to seq_buf via cocci
2026-05-21 · Kees Cook <kees@kernel.org> -
COLD31d
[PATCH 04/11] treewide: Convert struct kernel_param_ops initializers to DEFINE_KERNEL_PARAM_OPS
2026-05-21 · Kees Cook <kees@kernel.org> -
STALE87d
[PATCH 37/61] drm: Prefer IS_ERR_OR_NULL over manual NULL check
2026-03-10 · Philipp Hahn <hidden> -
STALE117d
[PATCH v3 12/12] treewide: change inode->i_ino from unsigned long to u64
2026-03-04 · Jeff Layton <jlayton@kernel.org> -
STALE130d
[PATCH v2 106/110] drm/amdgpu: replace PRIino with %llu/%llx format strings
2026-03-02 · Jeff Layton <jlayton@kernel.org> -
STALE130d
[PATCH v2 050/110] drm/amdgpu: use PRIino format for i_ino
2026-03-02 · Jeff Layton <jlayton@kernel.org> -
STALE134d
[PATCH 52/61] drm/amdgpu: update for u64 i_ino
2026-02-26 · Jeff Layton <jlayton@kernel.org> -
STALE132d
REVIEWED: 34 (33M) [PATCH v16 03/10] rust: rename `AlwaysRefCounted` to `RefCounted`.
2026-02-24 · Andreas Hindborg <a.hindborg@kernel.org> -
STALE138d
REVIEWED: 34 (33M) [PATCH v15 2/9] rust: rename `AlwaysRefCounted` to `RefCounted`.
2026-02-20 · Andreas Hindborg <a.hindborg@kernel.org> -
STALE155d
REVIEWED: 7 (7M) [PATCH v14 2/9] rust: rename `AlwaysRefCounted` to `RefCounted`.
2026-02-04 · Andreas Hindborg <a.hindborg@kernel.org> -
STALE151d
[PATCH v2 08/13] mm: update shmem_[kernel]_file_*() functions to use vma_flags_t
2026-01-22 · Lorenzo Stoakes <hidden> -
STALE171d
[PATCH RESEND 07/12] mm: update shmem_[kernel]_file_*() functions to use vma_flags_t
2026-01-19 · Lorenzo Stoakes <hidden> -
STALE173d
[PATCH 07/12] mm: update shmem_[kernel]_file_*() functions to use vma_flags_t
2026-01-19 · Lorenzo Stoakes <hidden> -
STALE160d
[PATCH v13 2/4] rust: `AlwaysRefCounted` is renamed to `RefCounted`.
2025-11-17 · Oliver Mangold <hidden> -
STALE72d
[PATCH v3 02/14] drm/i915/gt: Remove redundant rcu_read_lock/unlock() in spin_lock
2025-09-16 · pengdonglin <hidden> -
STALE299d
[PATCH v2] rcu: Remove redundant rcu_read_lock/unlock() in spin_lock critical sections
2025-09-15 · pengdonglin <hidden> -
STALE300d
[PATCH] rcu: Remove redundant rcu_read_lock/unlock() in spin_lock critical sections
2025-09-12 · pengdonglin <hidden> -
STALE481d
REVIEWED: 7 (7M) [PATCH v2 07/11] drm/panthor: reorder capability check last
2025-03-02 · Christian Göttsche <hidden> -
STALE529d
REVIEWED: 5 (3M) [PATCH v2] treewide: const qualify ctl_tables where applicable
2025-01-10 · Joel Granados <joel.granados@kernel.org> -
STALE548d
[PATCH] treewide: const qualify ctl_tables where applicable
2025-01-09 · Joel Granados <joel.granados@kernel.org> -
STALE570d
[PATCH v2 5/5] drivers: Remove get_task_comm() and print task comm directly
2024-12-19 · Yafang Shao <hidden> -
STALE572d
[PATCH 6/7] drivers: Repace get_task_comm() with %pTN
2024-12-13 · Yafang Shao <hidden> -
STALE589d
[PATCH 06/11] ubifs: reorder capability check last
2024-11-25 · Christian Göttsche <hidden>
Needs attention (review trailers in, no pickup)
Patches with review trailers that haven't landed in mainline and haven't been Acked by a maintainer. Oldest first.
-
COOLING14d
REVIEWED: 12 (12M) [PATCH v5] rust: aref: make `AlwaysRefCounted::inc_ref` an associated function
2026-06-28 · Trevor Chan <hidden> · 1 Reviewed-by -
COOLING13d
REVIEWED: 12 (12M) [PATCH v6] rust: aref: make `AlwaysRefCounted::inc_ref` an associated function
2026-06-28 · Trevor Chan <hidden> · 1 Reviewed-by -
COOLING13d
REVIEWED: 12 (12M) [PATCH v7] rust: aref: make `AlwaysRefCounted::inc_ref` an associated function
2026-06-28 · Trevor Chan <hidden> · 1 Reviewed-by
Quiet for 30+ days
Patches with no review trailers and no replies. Either the author is heads-down elsewhere or these slipped through. Oldest first.
-
STALE173d
[PATCH 07/12] mm: update shmem_[kernel]_file_*() functions to use vma_flags_t
2026-01-19 · Lorenzo Stoakes <hidden> -
STALE171d
[PATCH RESEND 07/12] mm: update shmem_[kernel]_file_*() functions to use vma_flags_t
2026-01-19 · Lorenzo Stoakes <hidden> -
STALE134d
[PATCH 52/61] drm/amdgpu: update for u64 i_ino
2026-02-26 · Jeff Layton <jlayton@kernel.org> -
STALE130d
[PATCH v2 050/110] drm/amdgpu: use PRIino format for i_ino
2026-03-02 · Jeff Layton <jlayton@kernel.org> -
STALE130d
[PATCH v2 106/110] drm/amdgpu: replace PRIino with %llu/%llx format strings
2026-03-02 · Jeff Layton <jlayton@kernel.org>