Reviews by john.johansen@canonical.com
· linux-security-module
All review-attestation trailers
(Reviewed-by / Acked-by /
Tested-by / Reported-by /
Suggested-by / Co-developed-by /
Reported-and-tested-by)
by this address on the linux-security-module archive.
100 attestations · capped at 100 most-recent. (36 Acked-by, 64 Reviewed-by)
-
DORMANTno replies
REVIEWED: 1 (1M) Re: [PATCH] apparmor: switch website link to https
2026-07-23 · Acked-by -
COOLING11d
REVIEWED: 1 (1M) Re: [PATCH] apparmor: leverage audit_log_n_untrustedstring() when possible
2026-07-21 · Acked-by -
DORMANTno replies
REVIEWED: 1 (1M) Re: [PATCH] tests: add a regression test for the TCP Fast Open connect-mediation bypass
2026-06-23 · Acked-by -
DORMANTno replies
REVIEWED: 1 (1M) Re: [PATCH] apparmor: mediate the implicit connect of TCP fast open sendmsg
2026-06-23 · Acked-by -
DORMANTno replies
REVIEWED: 1 (1M) Re: [PATCH 1/3] apparmor: Fix return in ns_mkdir_op
2026-06-13 · Acked-by -
DORMANTno replies
REVIEWED: 1 (1M) Re: [PATCH] apparmor/lsm: Fix aa_dfa_unpack's error handling in aa_setup_dfa_engine
2026-06-13 · Acked-by -
DORMANTno replies
REVIEWED: 1 (1M) Re: [PATCH RESEND] apparmor: Fix string overrun due to missing termination
2026-06-13 · Acked-by -
DORMANTno replies
REVIEWED: 1 (1M) Re: [PATCH] apparmor: hide unused get_loaddata_common_ref() function
2026-03-18 · Acked-by -
STALE134d
REVIEWED: 1 (1M) Re: [apparmor][PATCH] apparmor: fix incorrect success return value in unpack_tag_headers()
2026-03-18 · Acked-by -
DORMANTno replies
REVIEWED: 1 (1M) Re: [PATCH] apparmor: Remove redundant if check in sk_peer_get_label
2026-03-18 · Acked-by -
DORMANTno replies
REVIEWED: 1 (1M) Re: [PATCH] apparmor: Replace memcpy + NUL termination with kmemdup_nul in do_setattr
2026-03-18 · Acked-by -
DORMANTno replies
REVIEWED: 1 (1M) Re: [PATCH] apparmor: add .kunitconfig
2026-02-05 · Acked-by -
DORMANTno replies
REVIEWED: 1 (1M) Re: [PATCH RESEND] apparmor: replace sprintf with snprintf in aa_new_learning_profile
2025-11-27 · Acked-by -
DORMANTno replies
REVIEWED: 1 (1M) Re: [PATCH RESEND] apparmor: Replace sprintf/strcpy with scnprintf/strscpy in aa_policy_init
2025-11-27 · Acked-by -
STALE177d
REVIEWED: 1 (1M) Re: [PATCH RESEND] apparmor: Replace deprecated strcpy with memcpy in gen_symlink_name
2025-11-27 · Acked-by -
STALE245d
REVIEWED: 1 (1M) Re: [PATCH 0/2] apparmor unaligned memory fixes
2025-11-26 · Acked-by -
STALE245d
REVIEWED: 1 (1M) Re: [PATCH 0/2] apparmor unaligned memory fixes
2025-11-25 · Acked-by -
STALE183d
REVIEWED: 15 (15M) [PATCH v5 06/11] apparmor: move initcalls to the LSM framework
2025-10-17 · Acked-by -
STALE183d
REVIEWED: 21 (21M) [PATCH v5 17/34] lsm: cleanup initialize_lsm() and rename to lsm_init_single()
2025-10-17 · Reviewed-by -
STALE183d
REVIEWED: 21 (21M) [PATCH v5 16/34] lsm: cleanup the LSM blob size code
2025-10-17 · Reviewed-by -
STALE183d
REVIEWED: 21 (21M) [PATCH v5 09/34] lsm: rename the lsm order variables for consistency
2025-10-17 · Reviewed-by -
STALE183d
REVIEWED: 21 (21M) [PATCH v5 08/34] lsm: replace the name field with a pointer to the lsm_id struct
2025-10-17 · Reviewed-by -
STALE183d
REVIEWED: 21 (21M) [PATCH v5 02/34] lsm: split the init code out into lsm_init.c
2025-10-17 · Reviewed-by -
STALE183d
REVIEWED: 21 (21M) [PATCH v5 01/34] lsm: split the notifier code out into lsm_notifier.c
2025-10-17 · Reviewed-by -
STALE294d
REVIEWED: 15 (15M) [PATCH v4 29/34] apparmor: move initcalls to the LSM framework
2025-09-16 · Acked-by -
STALE294d
REVIEWED: 16 (16M) [PATCH v4 17/34] lsm: cleanup initialize_lsm() and rename to lsm_init_single()
2025-09-16 · Reviewed-by -
STALE294d
REVIEWED: 16 (16M) [PATCH v4 16/34] lsm: cleanup the LSM blob size code
2025-09-16 · Reviewed-by -
STALE294d
REVIEWED: 16 (16M) [PATCH v4 09/34] lsm: rename the lsm order variables for consistency
2025-09-16 · Reviewed-by -
STALE294d
REVIEWED: 16 (16M) [PATCH v4 08/34] lsm: replace the name field with a pointer to the lsm_id struct
2025-09-16 · Reviewed-by -
STALE294d
REVIEWED: 16 (16M) [PATCH v4 02/34] lsm: split the init code out into lsm_init.c
2025-09-16 · Reviewed-by -
STALE294d
REVIEWED: 16 (16M) [PATCH v4 01/34] lsm: split the notifier code out into lsm_notifier.c
2025-09-16 · Reviewed-by -
STALE322d
REVIEWED: 1 (1M) Re: [PATCH v3 29/34] apparmor: move initcalls to the LSM framework
2025-09-08 · Acked-by -
STALE322d
REVIEWED: 1 (1M) Re: [PATCH v3 20/34] lsm: cleanup the debug and console output in lsm_init.c
2025-09-03 · Reviewed-by -
STALE322d
REVIEWED: 1 (1M) Re: [PATCH v3 21/34] lsm: output available LSMs when debugging
2025-09-03 · Reviewed-by -
STALE322d
REVIEWED: 1 (1M) Re: [PATCH v3 19/34] lsm: add/tweak function header comment blocks in lsm_init.c
2025-09-03 · Reviewed-by -
STALE322d
REVIEWED: 1 (1M) Re: [PATCH v3 18/34] lsm: fold lsm_init_ordered() into security_init()
2025-09-03 · Reviewed-by -
STALE322d
REVIEWED: 1 (1M) Re: [PATCH v3 15/34] lsm: rename/rework ordered_lsm_parse() to lsm_order_parse()
2025-09-03 · Reviewed-by -
STALE322d
REVIEWED: 1 (1M) Re: [PATCH v3 14/34] lsm: rename/rework append_ordered_lsm() into lsm_order_append()
2025-09-03 · Reviewed-by -
STALE322d
REVIEWED: 1 (1M) Re: [PATCH v3 34/34] lsm: add a LSM_STARTED_ALL notification event
2025-09-02 · Reviewed-by -
STALE322d
REVIEWED: 1 (1M) Re: [PATCH v3 33/34] lsm: consolidate all of the LSM framework initcalls
2025-09-02 · Reviewed-by -
STALE322d
REVIEWED: 1 (1M) Re: [PATCH v3 30/34] lockdown: move initcalls to the LSM framework
2025-09-02 · Reviewed-by -
STALE322d
REVIEWED: 1 (1M) Re: [PATCH v3 28/34] safesetid: move initcalls to the LSM framework
2025-09-02 · Reviewed-by -
STALE322d
REVIEWED: 1 (1M) Re: [PATCH v3 27/34] tomoyo: move initcalls to the LSM framework
2025-09-02 · Reviewed-by -
STALE322d
REVIEWED: 1 (1M) Re: [PATCH v3 26/34] smack: move initcalls to the LSM framework
2025-09-02 · Reviewed-by -
STALE322d
REVIEWED: 1 (1M) Re: [PATCH v3 25/34] ipe: move initcalls to the LSM framework
2025-09-02 · Reviewed-by -
STALE322d
REVIEWED: 1 (1M) Re: [PATCH v3 24/34] loadpin: move initcalls to the LSM framework
2025-09-02 · Reviewed-by -
STALE322d
REVIEWED: 1 (1M) Re: [PATCH v3 23/34] lsm: introduce an initcall mechanism into the LSM framework
2025-09-02 · Reviewed-by -
STALE322d
REVIEWED: 1 (1M) Re: [PATCH v3 22/34] lsm: group lsm_order_parse() with the other lsm_order_*() functions
2025-09-02 · Reviewed-by -
STALE322d
REVIEWED: 1 (1M) Re: [PATCH v3 13/34] lsm: rename exists_ordered_lsm() to lsm_order_exists()
2025-09-02 · Reviewed-by -
STALE322d
REVIEWED: 1 (1M) Re: [PATCH v3 12/34] lsm: rework the LSM enable/disable setter/getter functions
2025-09-02 · Reviewed-by -
STALE322d
REVIEWED: 1 (1M) Re: [PATCH v3 10/34] lsm: rework lsm_active_cnt and lsm_idlist[]
2025-09-02 · Reviewed-by -
STALE322d
REVIEWED: 1 (1M) Re: [PATCH v3 07/34] lsm: rename ordered_lsm_init() to lsm_init_ordered()
2025-09-02 · Reviewed-by -
STALE322d
REVIEWED: 1 (1M) Re: [PATCH v3 06/34] lsm: integrate lsm_early_cred() and lsm_early_task() into caller
2025-09-02 · Reviewed-by -
STALE322d
REVIEWED: 1 (1M) Re: [PATCH v3 05/34] lsm: integrate report_lsm_order() code into caller
2025-09-02 · Reviewed-by -
STALE322d
REVIEWED: 1 (1M) Re: [PATCH v3 04/34] lsm: introduce looping macros for the initialization code
2025-09-02 · Reviewed-by -
STALE322d
REVIEWED: 15 (15M) [PATCH v3 17/34] lsm: cleanup initialize_lsm() and rename to lsm_init_single()
2025-08-14 · Reviewed-by -
STALE322d
REVIEWED: 16 (16M) [PATCH v3 16/34] lsm: cleanup the LSM blob size code
2025-08-14 · Reviewed-by -
STALE322d
REVIEWED: 16 (16M) [PATCH v3 09/34] lsm: rename the lsm order variables for consistency
2025-08-14 · Reviewed-by -
STALE322d
REVIEWED: 16 (16M) [PATCH v3 08/34] lsm: replace the name field with a pointer to the lsm_id struct
2025-08-14 · Reviewed-by -
STALE322d
REVIEWED: 16 (16M) [PATCH v3 02/34] lsm: split the init code out into lsm_init.c
2025-08-14 · Reviewed-by -
STALE322d
REVIEWED: 16 (16M) [PATCH v3 01/34] lsm: split the notifier code out into lsm_notifier.c
2025-08-14 · Reviewed-by -
DORMANTno replies
REVIEWED: 1 (1M) Re: [PATCH -next] apparmor: Remove the unused variable rules
2025-07-30 · Acked-by -
STALE368d
REVIEWED: 15 (15M) [RFC PATCH v2 17/34] lsm: cleanup initialize_lsm() and rename to lsm_init_single()
2025-07-21 · Reviewed-by -
STALE368d
REVIEWED: 15 (15M) [RFC PATCH v2 16/34] lsm: cleanup the LSM blob size code
2025-07-21 · Reviewed-by -
STALE368d
REVIEWED: 15 (15M) [RFC PATCH v2 09/34] lsm: rename the lsm order variables for consistency
2025-07-21 · Reviewed-by -
STALE368d
REVIEWED: 15 (15M) [RFC PATCH v2 08/34] lsm: replace the name field with a pointer to the lsm_id struct
2025-07-21 · Reviewed-by -
STALE368d
REVIEWED: 15 (15M) [RFC PATCH v2 02/34] lsm: split the init code out into lsm_init.c
2025-07-21 · Reviewed-by -
STALE368d
REVIEWED: 15 (15M) [RFC PATCH v2 01/34] lsm: split the notifier code out into lsm_notifier.c
2025-07-21 · Reviewed-by -
DORMANTno replies
REVIEWED: 1 (1M) Re: [PATCH v2] apparmor: fix some kernel-doc issues in header files
2025-05-17 · Acked-by -
DORMANTno replies
REVIEWED: 1 (1M) Re: [PATCH][next] apparmor: Fix incorrect profile->signal range check
2025-05-17 · Acked-by -
STALE396d
REVIEWED: 1 (1M) Re: [PATCH] apparmor: use SHA-256 library API instead of crypto_shash API
2025-05-17 · Acked-by -
STALE375d
REVIEWED: 1 (1M) Re: [RFC PATCH 27/29] lsm: consolidate all of the LSM framework initcalls
2025-05-14 · Reviewed-by -
STALE375d
REVIEWED: 1 (1M) Re: [RFC PATCH 28/29] lsm: add a LSM_STARTED_ALL notification event
2025-05-14 · Reviewed-by -
STALE375d
REVIEWED: 1 (1M) Re: [RFC PATCH 23/29] apparmor: move initcalls to the LSM framework
2025-05-14 · Acked-by -
STALE375d
REVIEWED: 1 (1M) Re: [RFC PATCH 24/29] lockdown: move initcalls to the LSM framework
2025-05-14 · Reviewed-by -
STALE375d
REVIEWED: 1 (1M) Re: [RFC PATCH 22/29] safesetid: move initcalls to the LSM framework
2025-05-14 · Reviewed-by -
STALE375d
REVIEWED: 1 (1M) Re: [RFC PATCH 21/29] tomoyo: move initcalls to the LSM framework
2025-05-14 · Reviewed-by -
STALE375d
REVIEWED: 1 (1M) Re: [RFC PATCH 19/29] ipe: move initcalls to the LSM framework
2025-05-14 · Reviewed-by -
STALE375d
REVIEWED: 1 (1M) Re: [RFC PATCH 16/29] lsm: output available LSMs when debugging
2025-05-14 · Reviewed-by -
STALE375d
REVIEWED: 1 (1M) Re: [RFC PATCH 17/29] lsm: introduce an initcall mechanism into the LSM framework
2025-05-14 · Reviewed-by -
STALE375d
REVIEWED: 1 (1M) Re: [RFC PATCH 18/29] loadpin: move initcalls to the LSM framework
2025-05-14 · Reviewed-by -
STALE375d
REVIEWED: 1 (1M) Re: [RFC PATCH 14/29] lsm: add missing function header comment blocks in lsm_init.c
2025-05-14 · Reviewed-by -
DORMANTno replies
REVIEWED: 1 (1M) Re: [RFC PATCH] security/apparmor: use kfree_sensitive() in unpack_secmark()
2025-04-28 · Acked-by -
STALE375d
REVIEWED: 1 (1M) Re: [RFC PATCH 11/29] lsm: cleanup initialize_lsm() and rename to lsm_init_single()
2025-04-15 · Reviewed-by -
STALE375d
REVIEWED: 1 (1M) Re: [RFC PATCH 10/29] lsm: cleanup the LSM blob size code
2025-04-15 · Reviewed-by -
STALE375d
REVIEWED: 1 (1M) Re: [RFC PATCH 06/29] lsm: cleanup and normalize the LSM order symbols naming
2025-04-15 · Reviewed-by -
STALE375d
REVIEWED: 1 (1M) Re: [RFC PATCH 05/29] lsm: replace the name field with a pointer to the lsm_id struct
2025-04-15 · Reviewed-by -
STALE375d
REVIEWED: 1 (1M) Re: [RFC PATCH 03/29] lsm: simplify prepare_lsm() and rename to lsm_prep_single()
2025-04-15 · Reviewed-by -
STALE375d
REVIEWED: 1 (1M) Re: [RFC PATCH 02/29] lsm: split the init code out into lsm_init.c
2025-04-15 · Reviewed-by -
STALE375d
REVIEWED: 1 (1M) Re: [RFC PATCH 01/29] lsm: split the notifier code out into lsm_notifier.c
2025-04-15 · Reviewed-by -
DORMANTno replies
REVIEWED: 1 (1M) Re: [PATCH] apparmor: use the condition in AA_BUG_FMT even with debug disabled
2025-01-29 · Acked-by -
STALE552d
REVIEWED: 1 (1M) Re: [PATCH] apparmor: fix typos and spelling errors
2025-01-24 · Acked-by -
DORMANTno replies
REVIEWED: 1 (1M) Re: [PATCH -next 2/2] apparmor: Modify mismatched function name
2025-01-24 · Acked-by -
STALE553d
REVIEWED: 1 (1M) Re: [PATCH -next 1/2] apparmor: Modify mismatched function name
2025-01-24 · Acked-by -
DORMANTno replies
REVIEWED: 1 (1M) Re: [PATCH] apparmor: Remove unused variable 'sock' in __file_sock_perm()
2025-01-24 · Acked-by -
STALE546d
REVIEWED: 1 (1M) Re: [PATCH] apparmor: Fix checking address of an array in accum_label_info()
2025-01-24 · Acked-by -
STALE553d
REVIEWED: 1 (1M) Re: [RESEND PATCH] apparmor: Use str_yes_no() helper function
2024-12-20 · Acked-by -
DORMANTno replies
REVIEWED: 1 (1M) Re: [PATCH -next] apparmor: Remove unused parameter L1 in macro next_comb
2024-11-09 · Acked-by -
DORMANTno replies
REVIEWED: 1 (1M) Re: [PATCH] apparmor: test: Fix memory leak for aa_unpack_strdup()
2024-11-09 · Acked-by -
DORMANTno replies
REVIEWED: 1 (1M) Re: [PATCH] apparmor: Remove deadcode
2024-11-09 · Acked-by