Reviews by amir73il@gmail.com
· linux-security-module
All review-attestation trailers
(Reviewed-by / Acked-by /
Tested-by / Reported-by /
Suggested-by / Co-developed-by /
Reported-and-tested-by)
by this address on the linux-security-module archive.
98 attestations . (20 Acked-by, 71 Reviewed-by, 7 Suggested-by)
-
COOLING9d
REVIEWED: 13 (13M) [PATCH v3 stable/linux-6.12.y 2/3] lsm: add backing_file LSM hooks
2026-06-29 · Reviewed-by -
COOLING9d
REVIEWED: 8 (8M) [PATCH stable/linux-5.10.y 7/7] selinux: fix overlayfs mmap() and mprotect() access checks
2026-06-29 · Acked-by -
COOLING9d
REVIEWED: 13 (13M) [PATCH stable/linux-5.10.y 6/7] lsm: add backing_file LSM hooks
2026-06-29 · Reviewed-by -
COOLING9d
REVIEWED: 8 (8M) [PATCH v3 stable/linux-6.12.y 3/3] selinux: fix overlayfs mmap() and mprotect() access checks
2026-06-29 · Acked-by -
COOLING11d
REVIEWED: 13 (13M) [PATCH v2 stable/linux-6.6.y 2/3] lsm: add backing_file LSM hooks
2026-06-27 · Reviewed-by -
COOLING11d
REVIEWED: 8 (8M) [PATCH v2 stable/linux-6.6.y 3/3] selinux: fix overlayfs mmap() and mprotect() access checks
2026-06-27 · Acked-by -
COOLING12d
REVIEWED: 8 (8M) [PATCH v2 stable/linux-6.12.y 2/2] selinux: fix overlayfs mmap() and mprotect() access checks
2026-06-27 · Acked-by -
COOLING12d
REVIEWED: 13 (13M) [PATCH v2 stable/linux-6.12.y 1/2] lsm: add backing_file LSM hooks
2026-06-27 · Reviewed-by -
COOLING13d
REVIEWED: 8 (8M) [PATCH v2 stable/linux-6.18.y 2/2] selinux: fix overlayfs mmap() and mprotect() access checks
2026-06-26 · Acked-by -
COOLING13d
REVIEWED: 13 (13M) [PATCH v2 stable/linux-6.18.y 1/2] lsm: add backing_file LSM hooks
2026-06-26 · Reviewed-by -
COOLING13d
REVIEWED: 13 (13M) [PATCH v2 stable/linux-6.18.y 1/2] lsm: add backing_file LSM hooks
2026-06-26 · Reviewed-by -
COOLING13d
REVIEWED: 8 (8M) [PATCH v2 stable/linux-6.18.y 2/2] selinux: fix overlayfs mmap() and mprotect() access checks
2026-06-26 · Acked-by -
COLD17d
REVIEWED: 13 (13M) [stable/linux-6.6.y 2/3] lsm: add backing_file LSM hooks
2026-06-22 · Reviewed-by -
COLD17d
REVIEWED: 8 (8M) [stable/linux-6.6.y 3/3] selinux: fix overlayfs mmap() and mprotect() access checks
2026-06-22 · Acked-by -
COOLING14d
REVIEWED: 8 (8M) [stable/linux-6.12.y 2/2] selinux: fix overlayfs mmap() and mprotect() access checks
2026-06-22 · Acked-by -
COOLING14d
REVIEWED: 13 (13M) [stable/linux-6.12.y 1/2] lsm: add backing_file LSM hooks
2026-06-22 · Reviewed-by -
COOLING14d
REVIEWED: 13 (13M) [stable/linux-6.18.y 1/2] lsm: add backing_file LSM hooks
2026-06-22 · Reviewed-by -
COOLING14d
REVIEWED: 8 (8M) [stable/linux-6.18.y 2/2] selinux: fix overlayfs mmap() and mprotect() access checks
2026-06-22 · Acked-by -
STALE91d
REVIEWED: 8 (8M) Re: [PATCH v4 3/3] selinux: fix overlayfs mmap() and mprotect() access checks
2026-04-03 · Acked-by -
STALE91d
REVIEWED: 8 (8M) Re: [PATCH v4 2/3] lsm: add backing_file LSM hooks
2026-04-03 · Reviewed-by -
STALE113d
REVIEWED: 8 (8M) [PATCH 2/3] lsm: add the security_mmap_backing_file() hook
2026-03-16 · Reviewed-by -
STALE122d
REVIEWED: 12 (12M) [PATCH v3 14/15] ovl: remove ovl_lock_rename_workdir()
2026-02-24 · Reviewed-by -
STALE122d
REVIEWED: 12 (12M) [PATCH v3 13/15] ovl: use is_subdir() for testing if one thing is a subdir of another
2026-02-24 · Reviewed-by -
STALE122d
REVIEWED: 8 (8M) [PATCH v3 12/15] ovl: change ovl_create_real() to get a new lock when re-opening created file.
2026-02-24 · Reviewed-by -
STALE122d
REVIEWED: 8 (8M) [PATCH v3 11/15] ovl: pass name buffer to ovl_start_creating_temp()
2026-02-24 · Reviewed-by -
STALE122d
REVIEWED: 12 (12M) [PATCH v3 09/15] ovl: Simplify ovl_lookup_real_one()
2026-02-24 · Reviewed-by -
STALE135d
REVIEWED: 8 (8M) Re: [PATCH v2 09/15] ovl: Simplify ovl_lookup_real_one()
2026-02-23 · Reviewed-by -
STALE135d
REVIEWED: 8 (8M) Re: [PATCH v2 12/15] ovl: change ovl_create_real() to get a new lock when re-opening created file.
2026-02-23 · Reviewed-by -
STALE135d
REVIEWED: 8 (8M) Re: [PATCH v2 11/15] ovl: pass name buffer to ovl_start_creating_temp()
2026-02-23 · Reviewed-by -
STALE135d
REVIEWED: 12 (12M) [PATCH v2 14/15] ovl: remove ovl_lock_rename_workdir()
2026-02-23 · Reviewed-by -
STALE135d
REVIEWED: 12 (12M) [PATCH v2 13/15] ovl: use is_subdir() for testing if one thing is a subdir of another
2026-02-23 · Reviewed-by -
STALE133d
REVIEWED: 8 (8M) Re: [PATCH 2/2] fanotify: call fanotify_events_supported() before path_permission() and security_path_notify()
2026-02-16 · Reviewed-by -
STALE133d
REVIEWED: 8 (8M) Re: [PATCH 1/2] fanotify: avoid/silence premature LSM capability checks
2026-02-16 · Reviewed-by -
STALE137d
REVIEWED: 8 (8M) Re: [PATCH 12/13] ovl: remove ovl_lock_rename_workdir()
2026-02-05 · Reviewed-by -
STALE137d
REVIEWED: 8 (8M) Re: [PATCH 11/13] ovl: use is_subdir() for testing if one thing is a subdir of another
2026-02-05 · Reviewed-by -
STALE178d
REVIEWED: 12 (12M) [PATCH v6 15/15] VFS: introduce end_creating_keep()
2025-11-13 · Reviewed-by -
STALE178d
REVIEWED: 13 (12M) [PATCH v6 14/15] VFS: change vfs_mkdir() to unlock on failure.
2025-11-13 · Reviewed-by -
STALE178d
REVIEWED: 12 (12M) [PATCH v6 13/15] ecryptfs: use new start_creating/start_removing APIs
2025-11-13 · Reviewed-by -
STALE178d
REVIEWED: 12 (12M) [PATCH v6 12/15] Add start_renaming_two_dentries()
2025-11-13 · Reviewed-by -
STALE178d
REVIEWED: 12 (12M) [PATCH v6 11/15] VFS/ovl/smb: introduce start_renaming_dentry()
2025-11-13 · Reviewed-by -
STALE178d
REVIEWED: 12 (12M) [PATCH v6 10/15] VFS/nfsd/ovl: introduce start_renaming() and end_renaming()
2025-11-13 · Reviewed-by -
STALE178d
REVIEWED: 12 (12M) [PATCH v6 09/15] VFS: add start_creating_killable() and start_removing_killable()
2025-11-13 · Reviewed-by -
STALE178d
REVIEWED: 12 (12M) [PATCH v6 08/15] VFS: introduce start_removing_dentry()
2025-11-13 · Reviewed-by -
STALE178d
REVIEWED: 12 (12M) [PATCH v6 06/15] VFS: introduce start_creating_noperm() and start_removing_noperm()
2025-11-13 · Reviewed-by -
STALE178d
REVIEWED: 12 (12M) [PATCH v6 05/15] VFS/nfsd/cachefiles/ovl: introduce start_removing() and end_removing()
2025-11-13 · Reviewed-by -
STALE178d
REVIEWED: 12 (12M) [PATCH v6 04/15] VFS/nfsd/cachefiles/ovl: add start_creating() and end_creating()
2025-11-13 · Reviewed-by -
STALE178d
REVIEWED: 12 (12M) [PATCH v6 03/15] VFS: tidy up do_unlinkat()
2025-11-13 · Reviewed-by -
STALE178d
REVIEWED: 12 (12M) [PATCH v6 02/15] VFS: introduce start_dirop() and end_dirop()
2025-11-13 · Reviewed-by -
STALE178d
REVIEWED: 30 (30M) [PATCH v6 01/15] debugfs: rename end_creating() to debugfs_end_creating()
2025-11-13 · Reviewed-by -
STALE239d
REVIEWED: 8 (8M) [PATCH v5 14/14] VFS: introduce end_creating_keep()
2025-11-06 · Reviewed-by -
STALE239d
REVIEWED: 8 (8M) [PATCH v5 13/14] VFS: change vfs_mkdir() to unlock on failure.
2025-11-06 · Reviewed-by -
STALE239d
REVIEWED: 8 (8M) [PATCH v5 12/14] ecryptfs: use new start_creating/start_removing APIs
2025-11-06 · Reviewed-by -
STALE239d
REVIEWED: 8 (8M) [PATCH v5 11/14] Add start_renaming_two_dentries()
2025-11-06 · Reviewed-by -
STALE239d
REVIEWED: 8 (8M) [PATCH v5 10/14] VFS/ovl/smb: introduce start_renaming_dentry()
2025-11-06 · Reviewed-by -
STALE239d
REVIEWED: 8 (8M) [PATCH v5 09/14] VFS/nfsd/ovl: introduce start_renaming() and end_renaming()
2025-11-06 · Reviewed-by -
STALE239d
REVIEWED: 8 (8M) [PATCH v5 08/14] VFS: add start_creating_killable() and start_removing_killable()
2025-11-06 · Reviewed-by -
STALE239d
REVIEWED: 8 (8M) [PATCH v5 07/14] VFS: introduce start_removing_dentry()
2025-11-06 · Reviewed-by -
STALE239d
REVIEWED: 12 (12M) [PATCH v5 06/14] VFS: introduce start_creating_noperm() and start_removing_noperm()
2025-11-06 · Reviewed-by -
STALE239d
REVIEWED: 8 (8M) [PATCH v5 05/14] VFS/nfsd/cachefiles/ovl: introduce start_removing() and end_removing()
2025-11-06 · Reviewed-by -
STALE239d
REVIEWED: 12 (12M) [PATCH v5 04/14] VFS/nfsd/cachefiles/ovl: add start_creating() and end_creating()
2025-11-06 · Reviewed-by -
STALE239d
REVIEWED: 8 (8M) [PATCH v5 03/14] VFS: tidy up do_unlinkat()
2025-11-06 · Reviewed-by -
STALE239d
REVIEWED: 8 (8M) [PATCH v5 02/14] VFS: introduce start_dirop() and end_dirop()
2025-11-06 · Reviewed-by -
STALE239d
REVIEWED: 30 (30M) [PATCH v5 01/14] debugfs: rename end_creating() to debugfs_end_creating()
2025-11-06 · Reviewed-by -
STALE246d
REVIEWED: 8 (8M) [PATCH v4 14/14] VFS: introduce end_creating_keep()
2025-10-29 · Reviewed-by -
STALE246d
REVIEWED: 8 (8M) [PATCH v4 13/14] VFS: change vfs_mkdir() to unlock on failure.
2025-10-29 · Reviewed-by -
STALE246d
REVIEWED: 8 (8M) [PATCH v4 12/14] ecryptfs: use new start_creating/start_removing APIs
2025-10-29 · Reviewed-by -
STALE246d
REVIEWED: 8 (8M) [PATCH v4 11/14] Add start_renaming_two_dentries()
2025-10-29 · Reviewed-by -
STALE246d
REVIEWED: 8 (8M) [PATCH v4 10/14] VFS/ovl/smb: introduce start_renaming_dentry()
2025-10-29 · Reviewed-by -
STALE246d
REVIEWED: 8 (8M) [PATCH v4 09/14] VFS/nfsd/ovl: introduce start_renaming() and end_renaming()
2025-10-29 · Reviewed-by -
STALE246d
REVIEWED: 8 (8M) [PATCH v4 08/14] VFS: add start_creating_killable() and start_removing_killable()
2025-10-29 · Reviewed-by -
STALE246d
REVIEWED: 8 (8M) [PATCH v4 07/14] VFS: introduce start_removing_dentry()
2025-10-29 · Reviewed-by -
STALE246d
REVIEWED: 12 (12M) [PATCH v4 06/14] VFS: introduce start_creating_noperm() and start_removing_noperm()
2025-10-29 · Reviewed-by -
STALE246d
REVIEWED: 8 (8M) [PATCH v4 05/14] VFS/nfsd/cachefiles/ovl: introduce start_removing() and end_removing()
2025-10-29 · Reviewed-by -
STALE246d
REVIEWED: 12 (12M) [PATCH v4 04/14] VFS/nfsd/cachefiles/ovl: add start_creating() and end_creating()
2025-10-29 · Reviewed-by -
STALE246d
REVIEWED: 8 (8M) [PATCH v4 03/14] VFS: tidy up do_unlinkat()
2025-10-29 · Reviewed-by -
STALE246d
REVIEWED: 8 (8M) [PATCH v4 02/14] VFS: introduce start_dirop() and end_dirop()
2025-10-29 · Reviewed-by -
STALE246d
REVIEWED: 12 (12M) [PATCH v4 01/14] debugfs: rename end_creating() to debugfs_end_creating()
2025-10-29 · Reviewed-by -
STALE821d
REVIEWED: 8 (8M) [PATCH v3 09/10] fs: Rename SB_I_EVM_UNSUPPORTED to SB_I_EVM_HMAC_UNSUPPORTED
2024-02-23 · Suggested-by -
STALE821d
REVIEWED: 8 (8M) [PATCH v3 09/10] fs: Rename SB_I_EVM_UNSUPPORTED to SB_I_EVM_HMAC_UNSUPPORTED
2024-02-23 · Acked-by -
STALE821d
REVIEWED: 8 (8M) [PATCH v3 02/10] security: allow finer granularity in permitting copy-up of security xattrs
2024-02-23 · Acked-by -
STALE821d
REVIEWED: 8 (8M) [PATCH v3 04/10] evm: Use the metadata inode to calculate metadata hash
2024-02-23 · Acked-by -
STALE821d
REVIEWED: 8 (8M) [PATCH v3 01/10] ima: Rename backing_inode to real_inode
2024-02-23 · Suggested-by -
STALE821d
REVIEWED: 8 (8M) [PATCH v3 01/10] ima: Rename backing_inode to real_inode
2024-02-23 · Acked-by -
STALE855d
REVIEWED: 8 (8M) [PATCH v2 21/25] ovl: use vfs_{get,set}_fscaps() for copy-up
2024-02-21 · Reviewed-by -
STALE855d
[PATCH v2 08/25] xattr: add is_fscaps_xattr() helper
2024-02-21 · Suggested-by -
STALE870d
REVIEWED: 8 (8M) Re: [PATCH v2 5/9] evm: Use the inode holding the metadata to calculate metadata hash
2024-02-06 · Acked-by -
STALE870d
REVIEWED: 8 (8M) Re: [PATCH v2 1/9] ima: Rename backing_inode to real_inode
2024-02-06 · Acked-by -
STALE870d
REVIEWED: 8 (8M) Re: [PATCH v2 2/9] security: allow finer granularity in permitting copy-up of security xattrs
2024-02-06 · Acked-by -
STALE870d
REVIEWED: 8 (8M) Re: [PATCH v2 7/9] fs: Rename SB_I_EVM_UNSUPPORTED to SB_I_EVM_HMAC_UNSUPPORTED
2024-02-06 · Acked-by -
STALE870d
[PATCH v2 1/9] ima: Rename backing_inode to real_inode
2024-02-05 · Suggested-by -
STALE870d
[PATCH v2 7/9] fs: Rename SB_I_EVM_UNSUPPORTED to SB_I_EVM_HMAC_UNSUPPORTED
2024-02-05 · Suggested-by -
STALE941d
REVIEWED: 8 (8M) Re: [PATCH 12/16] ovl: use vfs_{get,set}_fscaps() for copy-up
2023-11-30 · Reviewed-by -
STALE1008d
[PATCH v2 89/89] fs: move i_generation into new hole created after timestamp conversion
2023-10-04 · Suggested-by -
STALE2032d
REVIEWED: 8 (8M) Re: [PATCH v2 06/10] ovl: user xattr
2020-12-08 · Reviewed-by -
STALE2032d
REVIEWED: 8 (8M) Re: [PATCH v2 04/10] ovl: make ioctl() safe
2020-12-08 · Reviewed-by -
DORMANTno replies
REVIEWED: 10 (10M) Fwd: [PATCH v3] cap_inode_getsecurity: use d_find_any_alias() instead of d_find_alias()
2018-08-08 · Suggested-by -
DORMANTno replies
REVIEWED: 10 (10M) Fwd: [PATCH v3] cap_inode_getsecurity: use d_find_any_alias() instead of d_find_alias()
2018-08-08 · Acked-by -
DORMANTno replies
REVIEWED: 8 (8M) [PATCH] cap_inode_getsecurity: use d_find_any_alias() instead of d_find_alias()
2018-06-27 · Acked-by