crypto api · Maintained
Maintainers
- M Herbert Xu <herbert@gondor.apana.org.au>
- M "David S. Miller" <davem@davemloft.net>
Paths
- F
Documentation/crypto/ - F
Documentation/devicetree/bindings/crypto/ - F
arch/*/crypto/ - F
crypto/ - F
drivers/crypto/ - F
include/crypto/ - F
include/linux/crypto*
Last 30 days
Recent patches
Most-recent 30 patches in this subsystem on linux-sctp (capped at 30), ordered by date desc.
-
STALE1070d
crypto: api - Use work queue in crypto_destroy_instance
2023-08-03 · Herbert Xu <herbert@gondor.apana.org.au> -
STALE1070d
[RFC 1/1] crypto: Defer transforms destruction to a worker function
2023-08-02 · Florent Revest <hidden> -
STALE1107d
LANDED [PATCH net-next v5 15/16] sock: Remove ->sendpage*() in favour of sendmsg(MSG_SPLICE_PAGES)
2023-06-23 · David Howells <dhowells@redhat.com> -
STALE1111d
[PATCH net-next v4 14/15] sock: Remove ->sendpage*() in favour of sendmsg(MSG_SPLICE_PAGES)
2023-06-23 · David Howells <dhowells@redhat.com> -
STALE1111d
[PATCH 09/11] sysctl: Remove the end element in sysctl table arrays
2023-06-21 · Joel Granados <hidden> -
STALE1097d
[PATCH net-next v3 17/18] sock: Remove ->sendpage*() in favour of sendmsg(MSG_SPLICE_PAGES)
2023-06-20 · David Howells <dhowells@redhat.com> -
STALE1114d
[PATCH net-next v2 16/17] sock: Remove ->sendpage*() in favour of sendmsg(MSG_SPLICE_PAGES)
2023-06-17 · David Howells <dhowells@redhat.com> -
STALE1117d
[PATCH net-next 16/17] sock: Remove ->sendpage*() in favour of sendmsg(MSG_SPLICE_PAGES)
2023-06-16 · David Howells <dhowells@redhat.com> -
STALE1168d
[PATCH v3 55/55] sock: Remove ->sendpage*() in favour of sendmsg(MSG_SPLICE_PAGES)
2023-03-31 · David Howells <dhowells@redhat.com> -
STALE1181d
[RFC PATCH v2 48/48] sock: Remove ->sendpage*() in favour of sendmsg(MSG_SPLICE_PAGES)
2023-03-29 · David Howells <dhowells@redhat.com> -
STALE1201d
[RFC PATCH 28/28] sock: Remove ->sendpage*() in favour of sendmsg(MSG_SPLICE_PAGES)
2023-03-16 · David Howells <dhowells@redhat.com> -
STALE1365d
[PATCH v1 4/5] treewide: use get_random_bytes when possible
2022-10-06 · "Jason A. Donenfeld" <Jason@zx2c4.com> -
STALE1365d
[PATCH v1 2/5] treewide: use get_random_{u8,u16}() when possible
2022-10-06 · "Jason A. Donenfeld" <Jason@zx2c4.com> -
STALE1365d
[PATCH v1 1/5] treewide: use prandom_u32_max() when possible
2022-10-06 · "Jason A. Donenfeld" <Jason@zx2c4.com> -
STALE2120d
[trivial PATCH] treewide: Convert switch/case fallthrough; to break;
2020-09-09 · Joe Perches <joe@perches.com> -
STALE2160d
Re: [PATCH 12/26] netfilter: switch nf_setsockopt to sockptr_t
2020-07-27 · Christoph Hellwig <hch@lst.de> -
STALE2160d
Re: [PATCH 19/26] net/ipv6: switch ipv6_flowlabel_opt to sockptr_t
2020-07-27 · Christoph Hellwig <hch@lst.de> -
STALE2160d
[PATCH 25/26] net: pass a sockptr_t into ->setsockopt
2020-07-23 · Christoph Hellwig <hch@lst.de> -
STALE2177d
[PATCH 24/24] net: pass a sockptr_t into ->setsockopt
2020-07-20 · Christoph Hellwig <hch@lst.de> -
STALE2180d
[PATCH 22/22] net: make ->{get,set}sockopt in proto_ops optional
2020-07-17 · Christoph Hellwig <hch@lst.de> -
STALE2213d
REVIEWED: 19 (19M) [PATCH v5 2/2] mm, treewide: Rename kzfree() to kfree_sensitive()
2020-06-16 · Waiman Long <longman@redhat.com> -
STALE2212d
REVIEWED: 19 (19M) [PATCH v4 2/3] mm, treewide: Rename kzfree() to kfree_sensitive()
2020-06-16 · Waiman Long <longman@redhat.com> -
STALE2253d
[PATCH 01/20] crypto: hash - introduce crypto_shash_tfm_digest()
2020-05-02 · Eric Biggers <ebiggers@kernel.org> -
STALE2214d
[PATCH v2 2/2] crypto: Remove unnecessary memzero_explicit()
2020-04-13 · Waiman Long <longman@redhat.com> -
STALE2214d
[PATCH 2/2] crypto: Remove unnecessary memzero_explicit()
2020-04-13 · Waiman Long <longman@redhat.com> -
STALE2214d
[PATCH 1/2] mm, treewide: Rename kzfree() to kfree_sensitive()
2020-04-13 · Waiman Long <longman@redhat.com> -
STALE2850d
[PATCH] net/sock: move memory_allocated over to percpu_counter variables
2018-09-06 · Olof Johansson <hidden> -
STALE3200d
[PATCH V2] Fix a sleep-in-atomic bug in shash_setkey_unaligned
2017-10-03 · Jia-Ju Bai <hidden> -
DORMANTno replies
[PATCH] Fix a sleep-in-atomic bug in shash_setkey_unaligned
2017-10-03 · Jia-Ju Bai <hidden> -
STALE4762d
Re: [PATCH crypto] crypto: algboss: fix NULL pointer dereference in cryptomgr_probe
2013-06-24 · Herbert Xu <herbert@gondor.apana.org.au>