atm · Maintained
Maintainers
- M Chas Williams <3chas3@gmail.com>
Paths
- F
drivers/atm/ - F
drivers/usb/atm/ - F
include/linux/atm* - F
include/linux/sonet.h - F
include/uapi/linux/atm* - F
include/uapi/linux/sonet.h - F
net/atm/
Last 30 days
Most active threads (last 7 days)
-
WARM2d
[PATCH net-next v2] net: Replace %pK output with 0
2026-07-20 14:40 · 0 replies in 7d · Sebastian Andrzej Siewior <bigeasy@linutronix.de>
Recent patches
Most-recent 30 patches in this subsystem on linux-sctp (capped at 30), ordered by date desc.
-
WARM2d
[PATCH net-next v2] net: Replace %pK output with 0
2026-07-20 · Sebastian Andrzej Siewior <bigeasy@linutronix.de> -
WARM2d
[PATCH net-next] net: Convert %pK back to %p
2026-07-06 · Sebastian Andrzej Siewior <bigeasy@linutronix.de> -
STALE476d
[RFC PATCH 2/4] net: pass 'optlen_t' to proto[ops].getsockopt() hooks
2025-03-31 · Stefan Metzmacher <metze@samba.org> -
STALE476d
[RFC PATCH 1/4] net: introduce get_optlen() and put_optlen() helpers
2025-03-31 · Stefan Metzmacher <metze@samba.org> -
STALE553d
[PATCH] net: Convert proto_ops::getname to sockaddr_storage
2024-12-17 · Kees Cook <kees@kernel.org> -
STALE1121d
LANDED [PATCH net-next v5 15/16] sock: Remove ->sendpage*() in favour of sendmsg(MSG_SPLICE_PAGES)
2023-06-23 · David Howells <dhowells@redhat.com> -
STALE1125d
[PATCH net-next v4 14/15] sock: Remove ->sendpage*() in favour of sendmsg(MSG_SPLICE_PAGES)
2023-06-23 · David Howells <dhowells@redhat.com> -
STALE1111d
[PATCH net-next v3 17/18] sock: Remove ->sendpage*() in favour of sendmsg(MSG_SPLICE_PAGES)
2023-06-20 · David Howells <dhowells@redhat.com> -
STALE1129d
[PATCH net-next v2 16/17] sock: Remove ->sendpage*() in favour of sendmsg(MSG_SPLICE_PAGES)
2023-06-17 · David Howells <dhowells@redhat.com> -
STALE1132d
[PATCH net-next 16/17] sock: Remove ->sendpage*() in favour of sendmsg(MSG_SPLICE_PAGES)
2023-06-16 · David Howells <dhowells@redhat.com> -
STALE1182d
[PATCH v3 55/55] sock: Remove ->sendpage*() in favour of sendmsg(MSG_SPLICE_PAGES)
2023-03-31 · David Howells <dhowells@redhat.com> -
STALE1196d
[RFC PATCH v2 48/48] sock: Remove ->sendpage*() in favour of sendmsg(MSG_SPLICE_PAGES)
2023-03-29 · David Howells <dhowells@redhat.com> -
STALE1216d
[RFC PATCH 28/28] sock: Remove ->sendpage*() in favour of sendmsg(MSG_SPLICE_PAGES)
2023-03-16 · David Howells <dhowells@redhat.com> -
STALE1545d
LANDED [PATCH net-next v3] net: SO_RCVMARK socket option for SO_MARK with recvmsg()
2022-04-27 · Erin MacNeil <hidden> -
STALE1545d
[PATCH net-next v2] net: Add SO_RCVMARK socket option to provide SO_MARK with recvmsg().
2022-04-27 · Erin MacNeil <hidden> -
STALE2134d
[trivial PATCH] treewide: Convert switch/case fallthrough; to break;
2020-09-09 · Joe Perches <joe@perches.com> -
STALE2175d
[PATCH 25/26] net: pass a sockptr_t into ->setsockopt
2020-07-23 · Christoph Hellwig <hch@lst.de> -
STALE2192d
[PATCH 24/24] net: pass a sockptr_t into ->setsockopt
2020-07-20 · Christoph Hellwig <hch@lst.de> -
STALE2194d
[PATCH 01/22] net/atm: remove the atmdev_ops {get,set}sockopt methods
2020-07-17 · Christoph Hellwig <hch@lst.de> -
STALE2227d
REVIEWED: 19 (19M) [PATCH v5 2/2] mm, treewide: Rename kzfree() to kfree_sensitive()
2020-06-16 · Waiman Long <longman@redhat.com> -
STALE2226d
REVIEWED: 19 (19M) [PATCH v4 2/3] mm, treewide: Rename kzfree() to kfree_sensitive()
2020-06-16 · Waiman Long <longman@redhat.com> -
STALE2228d
[PATCH 1/2] mm, treewide: Rename kzfree() to kfree_sensitive()
2020-04-13 · Waiman Long <longman@redhat.com> -
STALE2653d
REVIEWED: 11 (11M) [PATCH v3 1/3] net: rework SIOCGSTAMP ioctl handling
2019-04-17 · Arnd Bergmann <arnd@arndb.de> -
STALE2653d
REVIEWED: 5 (5M) [PATCH net-next 1/3] net: rework SIOCGSTAMP ioctl handling
2019-04-16 · Arnd Bergmann <arnd@arndb.de> -
STALE2862d
[PATCH net-next 1/3] net: rework SIOCGSTAMP ioctl handling
2018-08-29 · Arnd Bergmann <arnd@arndb.de> -
STALE2917d
[PATCH PATCH net-next 11/18] atm: remove blank lines at EOF
2018-07-24 · Stephen Hemminger <stephen@networkplumber.org> -
STALE3040d
[PATCH 3/4] net: Use octal not symbolic permissions
2018-03-23 · Joe Perches <joe@perches.com> -
STALE3082d
[PATCH v2] net: make getname() functions return length rather than use int* parameter
2018-02-12 · Denys Vlasenko <hidden> -
STALE3082d
[PATCH] net: make getname() functions return length rather than use int* parameter
2018-02-12 · Denys Vlasenko <hidden> -
STALE3305d
[PATCH 07/36] net, atm: convert lec_arp_table.usage from atomic_t to refcount_t
2017-07-04 · Elena Reshetova <elena.reshetova@intel.com>