rust · Supported
Maintainers
- M Miguel Ojeda <ojeda@kernel.org>
- R Boqun Feng <boqun@kernel.org>
- R Gary Guo <gary@garyguo.net>
- R Björn Roy Baron <bjorn3_gh@protonmail.com>
- R Benno Lossin <lossin@kernel.org>
- R Andreas Hindborg <a.hindborg@kernel.org>
- R Alice Ryhl <aliceryhl@google.com>
- R Trevor Gross <tmgross@umich.edu>
- R Danilo Krummrich <dakr@kernel.org>
- R Daniel Almeida <daniel.almeida@collabora.com>
- R Tamir Duberstein <tamird@kernel.org>
- R Alexandre Courbot <acourbot@nvidia.com>
- R Onur Özkan <work@onurozkan.dev>
Paths
- F
.clippy.toml - F
.rustfmt.toml - F
Documentation/rust/ - F
include/trace/events/rust_sample.h - F
rust/ - F
samples/rust/ - F
scripts/*rust* - F
tools/testing/selftests/rust/
Last 30 days
Recent patches
Most-recent 23 patches in this subsystem on linux-s390, ordered by date desc.
-
COLD45d
REVIEWED: 12 (12M) [PATCH v6 3/6] rust/bindgen_parameters: Mark s390 types as opaque to prevent repr conflicts
2026-06-08 · Jan Polensky <hidden> -
COLD45d
REVIEWED: 8 (8M) [PATCH v6 6/6] s390: Enable Rust support
2026-06-08 · Jan Polensky <hidden> -
COLD45d
REVIEWED: 2 (2M) [PATCH v6 4/6] rust: helpers: Add memchr wrapper for string operations
2026-06-08 · Jan Polensky <hidden> -
COLD52d
[PATCH v5 4/6] rust: helpers: Add memchr wrapper for string operations
2026-06-01 · Jan Polensky <hidden> -
COLD52d
REVIEWED: 6 (6M) [PATCH v5 6/6] s390: Enable Rust support
2026-06-01 · Jan Polensky <hidden> -
COLD52d
REVIEWED: 10 (10M) [PATCH v5 3/6] rust/bindgen_parameters: Mark s390 types as opaque to prevent repr conflicts
2026-06-01 · Jan Polensky <hidden> -
COLD60d
REVIEWED: 6 (6M) [PATCH v4 6/6] s390: Enable Rust support
2026-05-29 · Jan Polensky <hidden> -
COLD60d
REVIEWED: 10 (10M) [PATCH v4 3/6] rust/bindgen_parameters: Mark s390 types as opaque to prevent repr conflicts
2026-05-29 · Jan Polensky <hidden> -
COLD60d
[PATCH v4 4/6] rust: helpers: Use __builtin_memchr directly on s390
2026-05-29 · Jan Polensky <hidden> -
STALE63d
REVIEWED: 4 (4M) [PATCH v3 3/4] rust/bindgen_parameters: Mark s390 types as opaque to prevent repr conflicts
2026-05-21 · Jan Polensky <hidden> -
STALE63d
[PATCH v3 4/4] s390: Enable Rust support
2026-05-21 · Jan Polensky <hidden> -
STALE71d
[PATCH v2 4/4] s390: enable Rust support
2026-05-19 · Jan Polensky <hidden> -
STALE71d
REVIEWED: 4 (4M) [PATCH v2 3/4] rust/bindgen_parameters: Mark s390 types as opaque to prevent repr conflicts
2026-05-19 · Jan Polensky <hidden> -
STALE73d
[PATCH 4/4] s390: enable Rust support
2026-05-12 · Jan Polensky <hidden> -
STALE73d
[PATCH 3/4] rust/bindgen_parameters: Mark s390 types as opaque to prevent repr conflicts
2026-05-12 · Jan Polensky <hidden> -
STALE93d
[RFC PATCH v1 5/9] uaccess: Switch to copy_{to/from}_user_partial() when relevant
2026-04-27 · "Christophe Leroy (CS GROUP)" <chleroy@kernel.org> -
STALE93d
[RFC PATCH v1 2/9] uaccess: Convert INLINE_COPY_{TO/FROM}_USER to kconfig and reduce ifdefery
2026-04-27 · "Christophe Leroy (CS GROUP)" <chleroy@kernel.org> -
STALE119d
[PATCH net-next] eth: remove the driver for acenic / tigon1&2
2026-04-02 · Jakub Kicinski <kuba@kernel.org> -
STALE142d
Re: [PATCH v1 14/16] mm: rename zap_page_range_single() to zap_vma_range()
2026-03-02 · "David Hildenbrand (Arm)" <david@kernel.org> -
STALE142d
Re: [PATCH v1 02/16] mm/memory: remove "zap_details" parameter from zap_page_range_single()
2026-03-02 · "David Hildenbrand (Arm)" <david@kernel.org> -
STALE142d
[PATCH v1 14/16] mm: rename zap_page_range_single() to zap_vma_range()
2026-02-27 · "David Hildenbrand (Arm)" <david@kernel.org> -
STALE142d
[PATCH v1 02/16] mm/memory: remove "zap_details" parameter from zap_page_range_single()
2026-02-27 · "David Hildenbrand (Arm)" <david@kernel.org> -
STALE187d
[PATCH net-next] net: ethernet: neterion: s2io: remove unused driver
2026-01-23 · Ethan Nelson-Moore <hidden>
Needs attention (review trailers in, no pickup)
Patches with review trailers that haven't landed in mainline and haven't been Acked by a maintainer. Oldest first.
-
STALE71d
REVIEWED: 4 (4M) [PATCH v2 3/4] rust/bindgen_parameters: Mark s390 types as opaque to prevent repr conflicts
2026-05-19 · Jan Polensky <hidden> · 1 Reviewed-by
Quiet for 30+ days
Patches with no review trailers and no replies. Either the author is heads-down elsewhere or these slipped through. Oldest first.
-
STALE142d
Re: [PATCH v1 14/16] mm: rename zap_page_range_single() to zap_vma_range()
2026-03-02 · "David Hildenbrand (Arm)" <david@kernel.org>