Reviews by rick.p.edgecombe@intel.com
· linux-riscv
All review-attestation trailers
(Reviewed-by / Acked-by /
Tested-by / Reported-by /
Suggested-by / Co-developed-by /
Reported-and-tested-by)
by this address on the linux-riscv archive.
44 attestations . (36 Reviewed-by, 6 Suggested-by, 2 Tested-by)
-
STALE108d
REVIEWED: 17 (17M) [PATCH v2 4/5] x86: shstk: Use the new common vm_mmap_shadow_stack() helper
2026-02-25 · Reviewed-by -
STALE108d
REVIEWED: 17 (17M) [PATCH v2 4/5] x86: shstk: Use the new common vm_mmap_shadow_stack() helper
2026-02-25 · Tested-by -
STALE145d
REVIEWED: 2 (2M) Re: [PATCH 4/5] x86: shstk: Use the new common vm_mmap_shadow_stack() helper
2026-02-24 · Reviewed-by -
STALE145d
REVIEWED: 2 (2M) Re: [PATCH 4/5] x86: shstk: Use the new common vm_mmap_shadow_stack() helper
2026-02-24 · Tested-by -
STALE252d
REVIEWED: 2 (1M) [PATCH v4 24/28] KVM: TDX: Use guard() to acquire kvm->lock in tdx_vm_ioctl()
2025-10-30 · Reviewed-by -
STALE252d
REVIEWED: 2 (1M) [PATCH v4 22/28] KVM: TDX: Add tdx_get_cmd() helper to get and validate sub-ioctl command
2025-10-30 · Reviewed-by -
STALE252d
[PATCH v4 19/28] KVM: TDX: Derive error argument names from the local variable names
2025-10-30 · Suggested-by -
STALE252d
REVIEWED: 1 (1M) [PATCH v4 18/28] KVM: TDX: Combine KVM_BUG_ON + pr_tdx_error() into TDX_BUG_ON()
2025-10-30 · Reviewed-by -
STALE252d
REVIEWED: 2 (1M) [PATCH v4 17/28] KVM: TDX: Fold tdx_sept_zap_private_spte() into tdx_sept_remove_private_spte()
2025-10-30 · Reviewed-by -
STALE252d
REVIEWED: 2 (1M) [PATCH v4 16/28] KVM: TDX: ADD pages to the TD image while populating mirror EPT entries
2025-10-30 · Reviewed-by -
STALE252d
REVIEWED: 3 (1M) [PATCH v4 15/28] KVM: TDX: Fold tdx_mem_page_record_premap_cnt() into its sole caller
2025-10-30 · Reviewed-by -
STALE252d
REVIEWED: 3 (1M) [PATCH v4 14/28] KVM: TDX: Use atomic64_dec_return() instead of a poor equivalent
2025-10-30 · Reviewed-by -
STALE252d
REVIEWED: 3 (1M) [PATCH v4 13/28] KVM: TDX: Avoid a double-KVM_BUG_ON() in tdx_sept_zap_private_spte()
2025-10-30 · Reviewed-by -
STALE252d
REVIEWED: 1 (0M) [PATCH v4 11/28] KVM: x86/mmu: Drop the return code from kvm_x86_ops.remove_external_spte()
2025-10-30 · Suggested-by -
STALE252d
REVIEWED: 3 (1M) [PATCH v4 09/28] KVM: TDX: Return -EIO, not -EINVAL, on a KVM_BUG_ON() condition
2025-10-30 · Reviewed-by -
STALE252d
REVIEWED: 4 (1M) [PATCH v4 08/28] KVM: TDX: Drop superfluous page pinning in S-EPT management
2025-10-30 · Suggested-by -
STALE252d
REVIEWED: 4 (1M) [PATCH v4 08/28] KVM: TDX: Drop superfluous page pinning in S-EPT management
2025-10-30 · Reviewed-by -
STALE252d
REVIEWED: 3 (1M) [PATCH v4 07/28] KVM: x86/mmu: Rename kvm_tdp_map_page() to kvm_tdp_page_prefault()
2025-10-30 · Reviewed-by -
STALE252d
REVIEWED: 3 (1M) [PATCH v4 06/28] Revert "KVM: x86/tdp_mmu: Add a helper function to walk down the TDP MMU"
2025-10-30 · Reviewed-by -
STALE252d
REVIEWED: 2 (1M) [PATCH v4 04/28] KVM: x86/mmu: Add dedicated API to map guest_memfd pfn into TDP MMU
2025-10-30 · Reviewed-by -
STALE243d
REVIEWED: 1 (1M) Re: [PATCH v3 21/25] KVM: TDX: Add tdx_get_cmd() helper to get and validate sub-ioctl command
2025-10-21 · Reviewed-by -
STALE243d
REVIEWED: 1 (1M) Re: [PATCH v3 07/25] KVM: TDX: Drop superfluous page pinning in S-EPT management
2025-10-21 · Reviewed-by -
STALE243d
REVIEWED: 1 (1M) Re: [PATCH v3 04/25] KVM: x86/mmu: Add dedicated API to map guest_memfd pfn into TDP MMU
2025-10-21 · Reviewed-by -
STALE243d
REVIEWED: 1 (1M) Re: [PATCH v3 23/25] KVM: TDX: Use guard() to acquire kvm->lock in tdx_vm_ioctl()
2025-10-21 · Reviewed-by -
STALE243d
[PATCH v3 18/25] KVM: TDX: Derive error argument names from the local variable names
2025-10-17 · Suggested-by -
STALE243d
REVIEWED: 1 (1M) [PATCH v3 17/25] KVM: TDX: Combine KVM_BUG_ON + pr_tdx_error() into TDX_BUG_ON()
2025-10-17 · Reviewed-by -
STALE243d
REVIEWED: 1 (1M) [PATCH v3 16/25] KVM: TDX: Fold tdx_sept_zap_private_spte() into tdx_sept_remove_private_spte()
2025-10-17 · Reviewed-by -
STALE243d
REVIEWED: 1 (1M) [PATCH v3 15/25] KVM: TDX: ADD pages to the TD image while populating mirror EPT entries
2025-10-17 · Reviewed-by -
STALE243d
REVIEWED: 1 (1M) [PATCH v3 13/25] KVM: TDX: Fold tdx_mem_page_record_premap_cnt() into its sole caller
2025-10-17 · Reviewed-by -
STALE243d
REVIEWED: 3 (1M) [PATCH v3 12/25] KVM: TDX: Use atomic64_dec_return() instead of a poor equivalent
2025-10-17 · Reviewed-by -
STALE243d
REVIEWED: 2 (1M) [PATCH v3 11/25] KVM: TDX: Avoid a double-KVM_BUG_ON() in tdx_sept_zap_private_spte()
2025-10-17 · Reviewed-by -
STALE243d
REVIEWED: 1 (0M) [PATCH v3 10/25] KVM: x86/mmu: Drop the return code from kvm_x86_ops.remove_external_spte()
2025-10-17 · Suggested-by -
STALE243d
REVIEWED: 3 (1M) [PATCH v3 08/25] KVM: TDX: Return -EIO, not -EINVAL, on a KVM_BUG_ON() condition
2025-10-17 · Reviewed-by -
STALE243d
REVIEWED: 3 (0M) [PATCH v3 07/25] KVM: TDX: Drop superfluous page pinning in S-EPT management
2025-10-17 · Suggested-by -
STALE243d
REVIEWED: 1 (1M) [PATCH v3 06/25] KVM: x86/mmu: Rename kvm_tdp_map_page() to kvm_tdp_page_prefault()
2025-10-17 · Reviewed-by -
STALE243d
REVIEWED: 1 (1M) [PATCH v3 05/25] Revert "KVM: x86/tdp_mmu: Add a helper function to walk down the TDP MMU"
2025-10-17 · Reviewed-by -
STALE612d
REVIEWED: 4 (1M) [PATCH v8 01/29] mm: Introduce ARCH_HAS_USER_SHADOW_STACK
2024-11-11 · Reviewed-by -
STALE589d
REVIEWED: 4 (1M) [PATCH v7 01/32] mm: Introduce ARCH_HAS_USER_SHADOW_STACK
2024-10-29 · Reviewed-by -
STALE629d
REVIEWED: 4 (1M) [PATCH v6 01/33] mm: Introduce ARCH_HAS_USER_SHADOW_STACK
2024-10-08 · Reviewed-by -
STALE643d
LANDED: 52 (49M) [PATCH v13 01/40] mm: Introduce ARCH_HAS_USER_SHADOW_STACK
2024-10-01 · Reviewed-by -
STALE650d
REVIEWED: 4 (1M) [PATCH 01/33] mm: Introduce ARCH_HAS_USER_SHADOW_STACK
2024-10-01 · Reviewed-by -
STALE671d
REVIEWED: 3 (1M) [PATCH v4 01/30] mm: Introduce ARCH_HAS_USER_SHADOW_STACK
2024-09-12 · Reviewed-by -
STALE682d
REVIEWED: 52 (49M) [PATCH v12 01/39] mm: Introduce ARCH_HAS_USER_SHADOW_STACK
2024-08-28 · Reviewed-by -
STALE691d
REVIEWED: 51 (49M) [PATCH v11 01/39] mm: Introduce ARCH_HAS_USER_SHADOW_STACK
2024-08-22 · Reviewed-by