# Re: \[PATCH 04/23\] devtmpfs: refactor devtmpfsd()

- From: Greg Kroah-Hartman \<gregkh@linuxfoundation.org\>
- Date: 2020-07-28 16:59:23 
- List: linux-raid
- Page: https://ratatoskr.run/linux-raid/2020/07/185465
- Thread: https://ratatoskr.run/linux-raid/2020/07/185462/t.md

```text
On Tue, Jul 28, 2020 at 06:33:57PM +0200, Christoph Hellwig wrote:
> Split the main worker loop into a separate function.  This allows
> devtmpfsd_setup to be marked __init, which will allows us to call
> __init routines for the setup work.  devtmpfѕ itself needs a __ref
> marker for that to work, and a comment explaining why it works.
> 
> Signed-off-by: Christoph Hellwig <hch@lst.de>

Reviewed-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
```
