Re: [PATCH 004 of 11] md: Increase the delay before marking metadata clean, and make it configurable.

4 messages, 4 authors, 2006-05-01 · open the first message on its own page

Re: [PATCH 004 of 11] md: Increase the delay before marking metadata clean, and make it configurable.

From: Neil Brown <hidden>
Date: 2006-05-01 06:02:44

On Sunday April 30, akpm@osdl.org wrote:
NeilBrown [off-list ref] wrote:
quoted

When a md array has been idle (no writes) for 20msecs it is marked as
'clean'.  This delay turns out to be too short for some real
workloads.  So increase it to 200msec (the time to update the metadata
should be a tiny fraction of that) and make it sysfs-configurable.


...

+   safe_mode_delay
+     When an md array has seen no write requests for a certain period
+     of time, it will be marked as 'clean'.  When another write
+     request arrive, the array is marked as 'dirty' before the write
+     commenses.  This is known as 'safe_mode'.
+     The 'certain period' is controlled by this file which stores the
+     period as a number of seconds.  The default is 200msec (0.200).
+     Writing a value of 0 disables safemode.
+
Why not make the units milliseconds?  Rename this to safe_mode_delay_msecs
to remove any doubt.
Because umpteen years ago when I was adding thread-usage statistics to
/proc/net/rpc/nfsd I used milliseconds and Linus asked me to make it
seconds - a much more "obvious" unit.  See Email below.
It seems very sensible to me.

...
quoted
+	msec = simple_strtoul(buf, &e, 10);
+	if (e == buf || (*e && *e != '\n'))
+		return -EINVAL;
+	msec = (msec * 1000) / scale;
+	if (msec == 0)
+		mddev->safemode_delay = 0;
+	else {
+		mddev->safemode_delay = (msec*HZ)/1000;
+		if (mddev->safemode_delay == 0)
+			mddev->safemode_delay = 1;
+	}
+	return len;
And most of that goes away.
Maybe it could go in a library :-?

NeilBrown


------------------------------------------------------------
From: Linus Torvalds <torvalds@transmeta.com>
To: Neil Brown <redacted>
cc: nfs-devel@linux.kernel.org
Subject: Re: PATCH knfsd - stats tidy up.
Date: Tue, 18 Jul 2000 12:21:12 -0700 (PDT)
Content-Type: TEXT/PLAIN; charset=US-ASCII



On Tue, 18 Jul 2000, Neil Brown wrote:
The following patch converts jiffies to milliseconds for output, and
also makes the number wrap predicatably at 1,000,000 seconds
(approximately one fortnight).
If no programs depend on the format, I actually prefer format changes like
this to be of the "obvious" kind. One such obvious kind is the format

	0.001

which obviously means 0.001 seconds. 

And yes, I'm _really_ sorry that a lot of the old /proc files contain
jiffies. Lazy. Ugly. Bad. Much of it my bad.

Doing 0.001 doesn't mean that you have to use floating point, in fact
you've done most of the work already in your ms patch, just splitting
things out a bit works well:

	/* gcc knows to combine / and % - generate one "divl" */
	unsigned int sec = time / HZ, msec = time % HZ;
	msec = (msec * 1000) / HZ;

	sprintf(" %d.%03d", sec, msec)

(It's basically the same thing you already do, except it doesn't
re-combine the seconds and milliseconds but just prints them out
separately.. And it has the advantage that if you want to change it to
microseconds some day, you can do so very trivially without breaking the
format. Plus it's readable as hell.)

		Linus

Re: [PATCH 004 of 11] md: Increase the delay before marking metadata clean, and make it configurable.

From: Andrew Morton <hidden>
Date: 2006-05-01 06:14:58

Neil Brown [off-list ref] wrote:
 On Sunday April 30, akpm@osdl.org wrote:
 > NeilBrown [off-list ref] wrote:
 > >
 > > 
 > > When a md array has been idle (no writes) for 20msecs it is marked as
 > > 'clean'.  This delay turns out to be too short for some real
 > > workloads.  So increase it to 200msec (the time to update the metadata
 > > should be a tiny fraction of that) and make it sysfs-configurable.
 > > 
 > > 
 > > ...
 > > 
 > > +   safe_mode_delay
 > > +     When an md array has seen no write requests for a certain period
 > > +     of time, it will be marked as 'clean'.  When another write
 > > +     request arrive, the array is marked as 'dirty' before the write
 > > +     commenses.  This is known as 'safe_mode'.
 > > +     The 'certain period' is controlled by this file which stores the
 > > +     period as a number of seconds.  The default is 200msec (0.200).
 > > +     Writing a value of 0 disables safemode.
 > > +
 > 
 > Why not make the units milliseconds?  Rename this to safe_mode_delay_msecs
 > to remove any doubt.

 Because umpteen years ago when I was adding thread-usage statistics to
 /proc/net/rpc/nfsd I used milliseconds and Linus asked me to make it
 seconds - a much more "obvious" unit.  See Email below.
 It seems very sensible to me.
That's output.  It's easier to do the conversion with output.  And I guess
one could argue that lots of people read /proc files, but few write to
them.

Generally I don't think we should be teaching the kernel to accept
pretend-floating-point numbers like this, especially when a) "delay in
milliseconds" is such a simple concept and b) it's so easy to go from float
to milliseconds in userspace.

Do you really expect that humans (really dumb ones ;)) will be echoing
numbers into this file?  Or will it mainly be a thing for mdadm to fiddle
with?

Re: [PATCH 004 of 11] md: Increase the delay before marking metadata clean, and make it configurable.

From: Nick Piggin <hidden>
Date: 2006-05-01 06:15:15

Neil Brown wrote:
On Sunday April 30, akpm@osdl.org wrote:
quoted
NeilBrown [off-list ref] wrote:
quoted
When a md array has been idle (no writes) for 20msecs it is marked as
'clean'.  This delay turns out to be too short for some real
workloads.  So increase it to 200msec (the time to update the metadata
should be a tiny fraction of that) and make it sysfs-configurable.


...

+   safe_mode_delay
+     When an md array has seen no write requests for a certain period
+     of time, it will be marked as 'clean'.  When another write
+     request arrive, the array is marked as 'dirty' before the write
+     commenses.  This is known as 'safe_mode'.
+     The 'certain period' is controlled by this file which stores the
+     period as a number of seconds.  The default is 200msec (0.200).
+     Writing a value of 0 disables safemode.
+
Why not make the units milliseconds?  Rename this to safe_mode_delay_msecs
to remove any doubt.
Because umpteen years ago when I was adding thread-usage statistics to
/proc/net/rpc/nfsd I used milliseconds and Linus asked me to make it
seconds - a much more "obvious" unit.  See Email below.
It seems very sensible to me.
Either way, all ambiguity is removed if you put the unit in the name. And
don't use jiffies because that obviously is not portable (which sounds like
it was Linus' biggest concern).

Once you do that, I don't much care whether you use seconds or milliseconds.
Other than to note that many of our units now are ms, especially when 
they're
measuring things at or around the ms order of magnitude. But I'm not 
aware of
so many proc values that don't work in integers.

--

Send instant messages to your online friends http://au.messenger.yahoo.com 

Re: [PATCH 004 of 11] md: Increase the delay before marking metadata clean, and make it configurable.

From: Linus Torvalds <torvalds@osdl.org>
Date: 2006-05-01 15:17:40


On Sun, 30 Apr 2006, Andrew Morton wrote:
Generally I don't think we should be teaching the kernel to accept
pretend-floating-point numbers like this, especially when a) "delay in
milliseconds" is such a simple concept and b) it's so easy to go from float
to milliseconds in userspace.

Do you really expect that humans (really dumb ones ;)) will be echoing
numbers into this file?  Or will it mainly be a thing for mdadm to fiddle
with?
I generally hate interfaces that have some "random base".

So "delay in seconds" is not a random base, because "seconds" is a good SI 
base unit, and there's not a lot of question about it. But once you start 
talking milliseconds on microseconds, I'd actually much rather have a 
"fake floating point number" over having different files have different 
(magic) base constants. How do you remember which are milliseconds, which 
are microseconds, and which are just seconds?

It should be easy to have a helper function or two that takes a "struct 
timeval" and reads/writes a "float".

		Linus
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help