raid5d oopses during hot-removal of disk (2.4.27)

From: Leon Woestenberg <hidden>
Date: 2004-12-10 13:59:03

Hello all,

I am experiencing kernel "oops" errors in raid5d.

This is on a Linux 2.4.27 kernel, running RAID-5 across 4 SATA drives
using the Marvell Linux driver (not libata) which acts as a SCSI host.

The oopses occur when a disk is physically hot-removed from the system
and Software RAID finds the disk failed.

I have analyzed the error to occur inside a ITERATE_RDEV loop in
md_update_sb() in the drivers/md/md.c code.

Please note that concurrent to the Software RAID-5 marking the
disk as failed, another process is performing a
"scsi-remove-single-device" action.

I am suspecting that this *might* trigger the fault, but I have not
been able to confirm this. However, I hate guessing here.

I have included the oops, together with a text file in which I
described the steps (ksymoops et al) taken so far to pin-point
the occurence.

Could someone more knowledgeable about md/raid look at this pls,
and tell me how to proceed?

Regards,

Leon Woestenberg.





Attachments

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help