Is data on a `failed-disk' secure after a reboot? (raid1)
From: Norbert Preining <hidden>
Date: 2004-03-11 11:10:57
Hi!
I have set up a raid1 on our server with hda and hdc, but the partitions
of hda are marked as failed-disk in /etc/raidtab.
Then I did mkraid all the devices, mke2fs (-j) and copied all the files.
This worked all very well.
Now: What will happen when I reboot?
Using the persistent superblock option will linux (2.4.25) start syncing
hdc onto hda or will it treat hda still as failed-disk?
I will/would reboot with lilo options
root=/dev/md0
but the kernel is on hda1 (for now, until hda is added to the raid)
Reason for the question: I want to run several tests before completely
switching and want to be able to go back to normal hda behaviour.
In case you need these data:
linux-2.4.25 (self compiled)
debian/woody
raidtools2 0.90.20010914-15
(no I am not using mdadm ATM, because all the howtos were written for
raidtools. I will switch to mdadm, lateron)
Please Cc: me any answer, thanks a lot.
Best wishes
Norbert
-------------------------------------------------------------------------------
Norbert Preining <preining AT logic DOT at> Technische Universität Wien
gpg DSA: 0x09C5B094 fp: 14DF 2E6C 0307 BE6D AD76 A9C0 D2BF 4AA3 09C5 B094
-------------------------------------------------------------------------------
KIRBY MISPERTON (n.)
One who kindly attempts to wipe an apparent kirby (q.v.) off another's
face with a napkin, and then discovers it to be a wart or other
permanent fixture, is said to have committed a 'kirby misperton'.
--- Douglas Adams, The Meaning of Liff
-
To unsubscribe from this list: send the line "unsubscribe linux-raid" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html