credentials · Supported
Maintainers
- M Paul Moore <paul@paul-moore.com>
- R Serge Hallyn <sergeh@kernel.org>
Paths
- F
include/linux/cred.h - F
kernel/cred.c - F
rust/kernel/cred.rs - F
Documentation/security/credentials.rst
Last 30 days
Active reviewers (last 30 days)
-
Alice Ryhl <aliceryhl@google.com>
1 attestation (1 Suggested-by) · last on 2026-09-10 -
Daniel Almeida <daniel.almeida@collabora.com>
1 attestation (1 Reviewed-by) · last on 2026-09-10 -
Igor Korotin <hidden>
1 attestation (1 Acked-by) · last on 2026-09-10 -
Danilo Krummrich <dakr@kernel.org>
1 attestation (1 Acked-by) · last on 2026-09-10 -
Viresh Kumar <viresh.kumar@linaro.org>
1 attestation (1 Acked-by) · last on 2026-09-10 -
Gary Guo <gary@garyguo.net>
1 attestation (1 Reviewed-by) · last on 2026-09-10 -
Andreas Hindborg <a.hindborg@kernel.org>
1 attestation (1 Co-developed-by) · last on 2026-09-10
Recent patches
Most-recent 14 patches in this subsystem on linux-pm, ordered by date desc.
-
COOLING13d
REVIEWED: 34 (33M) [PATCH v21 4/9] rust: rename `AlwaysRefCounted` to `RefCounted`.
2026-09-10 · Andreas Hindborg <a.hindborg@kernel.org> -
COLD18d
REVIEWED: 34 (33M) [PATCH v20 5/8] rust: rename `AlwaysRefCounted` to `RefCounted`.
2026-08-24 · Andreas Hindborg <a.hindborg@kernel.org> -
COLD51d
REVIEWED: 12 (12M) [PATCH v7] rust: aref: make `AlwaysRefCounted::inc_ref` an associated function
2026-06-28 · Trevor Chan <hidden> -
COLD51d
REVIEWED: 12 (12M) [PATCH v6] rust: aref: make `AlwaysRefCounted::inc_ref` an associated function
2026-06-28 · Trevor Chan <hidden> -
STALE80d
REVIEWED: 34 (33M) [PATCH v19 5/8] rust: rename `AlwaysRefCounted` to `RefCounted`.
2026-06-26 · Andreas Hindborg <a.hindborg@kernel.org> -
STALE92d
REVIEWED: 34 (33M) [PATCH v18 5/8] rust: rename `AlwaysRefCounted` to `RefCounted`.
2026-06-25 · Andreas Hindborg <a.hindborg@kernel.org> -
STALE93d
REVIEWED: 34 (33M) [PATCH v17 06/10] rust: rename `AlwaysRefCounted` to `RefCounted`.
2026-06-04 · Andreas Hindborg <a.hindborg@kernel.org> -
STALE208d
REVIEWED: 34 (33M) [PATCH v16 03/10] rust: rename `AlwaysRefCounted` to `RefCounted`.
2026-02-24 · Andreas Hindborg <a.hindborg@kernel.org> -
STALE214d
REVIEWED: 34 (33M) [PATCH v15 2/9] rust: rename `AlwaysRefCounted` to `RefCounted`.
2026-02-20 · Andreas Hindborg <a.hindborg@kernel.org> -
STALE231d
REVIEWED: 7 (7M) [PATCH v14 2/9] rust: rename `AlwaysRefCounted` to `RefCounted`.
2026-02-04 · Andreas Hindborg <a.hindborg@kernel.org> -
STALE235d
[PATCH v13 2/4] rust: `AlwaysRefCounted` is renamed to `RefCounted`.
2025-11-17 · Oliver Mangold <hidden> -
STALE330d
[PATCH v12 2/4] `AlwaysRefCounted` is renamed to `RefCounted`.
2025-10-01 · Oliver Mangold <hidden> -
STALE4768d
REVIEWED: 2 (2M) [PATCH 10/18] efi: Enable secure boot lockdown automatically when enabled in firmware
2013-08-22 · Lee, Chun-Yi <hidden> -
STALE4768d
REVIEWED: 2 (2M) [PATCH 09/18] Secure boot: Add a dummy kernel parameter that will switch on Secure Boot mode
2013-08-22 · Lee, Chun-Yi <hidden>
Needs attention (review trailers in, no pickup)
Patches with review trailers that haven't landed in mainline and haven't been Acked by a maintainer. Oldest first.
-
COLD51d
REVIEWED: 12 (12M) [PATCH v6] rust: aref: make `AlwaysRefCounted::inc_ref` an associated function
2026-06-28 · Trevor Chan <hidden> · 1 Reviewed-by -
COLD51d
REVIEWED: 12 (12M) [PATCH v7] rust: aref: make `AlwaysRefCounted::inc_ref` an associated function
2026-06-28 · Trevor Chan <hidden> · 1 Reviewed-by