apparmor security module · Supported
Maintainers
- M John Johansen <john.johansen@canonical.com>
- M John Johansen <john@apparmor.net>
- M Georgia Garcia <georgia.garcia@canonical.com>
Paths
- F
Documentation/admin-guide/LSM/apparmor.rst - F
security/apparmor/
Last 30 days
Recent patches
Most-recent 10 patches in this subsystem on linux-pm, ordered by date desc.
-
COLD38d
[PATCH 08/11] params: Convert generic kernel_param_ops .get helpers to seq_buf
2026-05-21 · Kees Cook <kees@kernel.org> -
COLD38d
[PATCH 09/11] treewide: Convert custom kernel_param_ops .get callbacks to seq_buf via cocci
2026-05-21 · Kees Cook <kees@kernel.org> -
COLD38d
[PATCH 04/11] treewide: Convert struct kernel_param_ops initializers to DEFINE_KERNEL_PARAM_OPS
2026-05-21 · Kees Cook <kees@kernel.org> -
STALE94d
[PATCH 20/61] apparmor: Prefer IS_ERR_OR_NULL over manual NULL check
2026-03-10 · Philipp Hahn <hidden> -
STALE767d
[PATCH v1 1/1] treewide: Align match_string() with sysfs_match_string()
2024-06-03 · Andy Shevchenko <andriy.shevchenko@linux.intel.com> -
STALE2223d
REVIEWED: 19 (19M) [PATCH v5 2/2] mm, treewide: Rename kzfree() to kfree_sensitive()
2020-06-16 · Waiman Long <longman@redhat.com> -
STALE2222d
REVIEWED: 19 (19M) [PATCH v4 2/3] mm, treewide: Rename kzfree() to kfree_sensitive()
2020-06-16 · Waiman Long <longman@redhat.com> -
STALE2224d
[PATCH 1/2] mm, treewide: Rename kzfree() to kfree_sensitive()
2020-04-13 · Waiman Long <longman@redhat.com> -
STALE2608d
[PATCH 2/3][V2] treewide: rename match_string() -> __match_string()
2019-05-28 · Alexandru Ardelean <hidden> -
STALE2608d
[PATCH 02/16] treewide: rename match_string() -> __match_string()
2019-05-08 · Alexandru Ardelean <hidden>
Quiet for 30+ days
Patches with no review trailers and no replies. Either the author is heads-down elsewhere or these slipped through. Oldest first.
-
STALE94d
[PATCH 20/61] apparmor: Prefer IS_ERR_OR_NULL over manual NULL check
2026-03-10 · Philipp Hahn <hidden>