namespaces: · Maintained
Maintainers
- M Christian Brauner <christian@brauner.io>
- R Pavel Tikhomirov <ptikhomirov@virtuozzo.com>
Paths
- F
rust/kernel/pid_namespace.rs - F
kernel/pid_namespace.c - F
tools/testing/selftests/pid_namespace/
Last 30 days
Active reviewers (last 30 days)
-
Alice Ryhl <aliceryhl@google.com>
1 attestation (1 Suggested-by) · last on 2026-08-24 -
Daniel Almeida <daniel.almeida@collabora.com>
1 attestation (1 Reviewed-by) · last on 2026-08-24 -
Igor Korotin <hidden>
1 attestation (1 Acked-by) · last on 2026-08-24 -
Danilo Krummrich <dakr@kernel.org>
1 attestation (1 Acked-by) · last on 2026-08-24 -
Viresh Kumar <viresh.kumar@linaro.org>
1 attestation (1 Acked-by) · last on 2026-08-24 -
Gary Guo <gary@garyguo.net>
1 attestation (1 Reviewed-by) · last on 2026-08-24 -
Andreas Hindborg <a.hindborg@kernel.org>
1 attestation (1 Co-developed-by) · last on 2026-08-24
Recent patches
Most-recent 12 patches in this subsystem on linux-pci, ordered by date desc.
-
WARM1d
REVIEWED: 34 (33M) [PATCH v20 5/8] rust: rename `AlwaysRefCounted` to `RefCounted`.
2026-08-24 · Andreas Hindborg <a.hindborg@kernel.org> -
COLD35d
REVIEWED: 12 (12M) [PATCH v7] rust: aref: make `AlwaysRefCounted::inc_ref` an associated function
2026-06-28 · Trevor Chan <hidden> -
COLD35d
REVIEWED: 12 (12M) [PATCH v6] rust: aref: make `AlwaysRefCounted::inc_ref` an associated function
2026-06-28 · Trevor Chan <hidden> -
COLD28d
REVIEWED: 12 (12M) [PATCH v5] rust: aref: make `AlwaysRefCounted::inc_ref` an associated function
2026-06-28 · Trevor Chan <hidden> -
STALE64d
REVIEWED: 34 (33M) [PATCH v19 5/8] rust: rename `AlwaysRefCounted` to `RefCounted`.
2026-06-26 · Andreas Hindborg <a.hindborg@kernel.org> -
STALE76d
REVIEWED: 34 (33M) [PATCH v18 5/8] rust: rename `AlwaysRefCounted` to `RefCounted`.
2026-06-25 · Andreas Hindborg <a.hindborg@kernel.org> -
STALE77d
REVIEWED: 34 (33M) [PATCH v17 06/10] rust: rename `AlwaysRefCounted` to `RefCounted`.
2026-06-04 · Andreas Hindborg <a.hindborg@kernel.org> -
STALE191d
REVIEWED: 34 (33M) [PATCH v16 03/10] rust: rename `AlwaysRefCounted` to `RefCounted`.
2026-02-24 · Andreas Hindborg <a.hindborg@kernel.org> -
STALE197d
REVIEWED: 34 (33M) [PATCH v15 2/9] rust: rename `AlwaysRefCounted` to `RefCounted`.
2026-02-20 · Andreas Hindborg <a.hindborg@kernel.org> -
STALE215d
REVIEWED: 7 (7M) [PATCH v14 2/9] rust: rename `AlwaysRefCounted` to `RefCounted`.
2026-02-04 · Andreas Hindborg <a.hindborg@kernel.org> -
STALE219d
[PATCH v13 2/4] rust: `AlwaysRefCounted` is renamed to `RefCounted`.
2025-11-17 · Oliver Mangold <hidden> -
STALE314d
[PATCH v12 2/4] `AlwaysRefCounted` is renamed to `RefCounted`.
2025-10-01 · Oliver Mangold <hidden>
Needs attention (review trailers in, no pickup)
Patches with review trailers that haven't landed in mainline and haven't been Acked by a maintainer. Oldest first.
-
COLD28d
REVIEWED: 12 (12M) [PATCH v5] rust: aref: make `AlwaysRefCounted::inc_ref` an associated function
2026-06-28 · Trevor Chan <hidden> · 1 Reviewed-by -
COLD35d
REVIEWED: 12 (12M) [PATCH v6] rust: aref: make `AlwaysRefCounted::inc_ref` an associated function
2026-06-28 · Trevor Chan <hidden> · 1 Reviewed-by -
COLD35d
REVIEWED: 12 (12M) [PATCH v7] rust: aref: make `AlwaysRefCounted::inc_ref` an associated function
2026-06-28 · Trevor Chan <hidden> · 1 Reviewed-by