module support · Maintained
Maintainers
- M Luis Chamberlain <mcgrof@kernel.org>
- M Petr Pavlu <petr.pavlu@suse.com>
- M Daniel Gomez <da.gomez@kernel.org>
- M Sami Tolvanen <samitolvanen@google.com>
- R Aaron Tomlin <atomlin@atomlin.com>
Paths
- F
include/linux/kmod.h - F
include/linux/module*.h - F
kernel/module/ - F
lib/test_kmod.c - F
lib/tests/module/ - F
rust/kernel/module_param.rs - F
rust/macros/module.rs - F
scripts/module* - F
tools/testing/selftests/kmod/ - F
tools/testing/selftests/module/
Last 30 days
Most active threads (last 7 days)
-
COOLING4d
[PATCH v2 0/3] Bring includes in linux/kmod.h up to date
2026-07-21 13:12 · 2 replies in 7d · Petr Pavlu <petr.pavlu@suse.com>
Active reviewers (last 30 days)
-
Aaron Tomlin <atomlin@atomlin.com>
1 attestation (1 Reviewed-by) · last on 2026-07-21 -
Harry Yoo <hidden>
1 attestation (1 Tested-by) · last on 2026-07-06 -
Gwan-gyeong Mun <hidden>
1 attestation (1 Tested-by) · last on 2026-07-06 -
Yunseong Kim <hidden>
1 attestation (1 Tested-by) · last on 2026-07-06 -
Yeoreum Yun <hidden>
1 attestation (1 Tested-by) · last on 2026-07-06
Recent patches
Most-recent 27 patches in this subsystem on linux-nfs, ordered by date desc.
-
DORMANTno replies
REVIEWED: 1 (1M) [PATCH v2 3/3] module: Bring includes in linux/kmod.h up to date
2026-07-21 · Petr Pavlu <petr.pavlu@suse.com> -
COOLING4d
[PATCH v2 1/3] umh, treewide: Explicitly include linux/umh.h where needed
2026-07-21 · Petr Pavlu <petr.pavlu@suse.com> -
COLD15d
[PATCH 2/2] module: Bring includes in linux/kmod.h up to date
2026-07-08 · Petr Pavlu <petr.pavlu@suse.com> -
COLD15d
[PATCH 1/2] umh, treewide: Explicitly include linux/umh.h where needed
2026-07-08 · Petr Pavlu <petr.pavlu@suse.com> -
COOLING12d
REVIEWED: 4 (0M) [PATCH v19 01/40] dept: implement DEPT(DEPendency Tracker)
2026-07-06 · Byungchul Park <byungchul@sk.com> -
STALE128d
[PATCH v2 2/2] tree-wide: rename do_exit() to task_exit()
2026-03-10 · Christian Brauner <brauner@kernel.org> -
STALE128d
[PATCH v2 1/2] kthread: remove kthread_exit()
2026-03-10 · Christian Brauner <brauner@kernel.org> -
STALE100d
[PATCH 17/61] module: Prefer IS_ERR_OR_NULL over manual NULL check
2026-03-10 · Philipp Hahn <hidden> -
STALE100d
[PATCH 21/61] lib/test: Prefer IS_ERR_OR_NULL over manual NULL check
2026-03-10 · Philipp Hahn <hidden> -
STALE137d
[PATCH] kthread: remove kthread_exit()
2026-03-06 · Christian Brauner <brauner@kernel.org> -
COLD19d
[PATCH v18 34/42] dept: add module support for struct dept_event_site and dept_event_site_dep
2025-12-05 · Byungchul Park <byungchul@sk.com> -
COLD19d
REVIEWED: 4 (0M) [PATCH v18 01/42] dept: implement DEPT(DEPendency Tracker)
2025-12-05 · Byungchul Park <byungchul@sk.com> -
STALE236d
[PATCH v17 39/47] dept: add module support for struct dept_event_site and dept_event_site_dep
2025-10-02 · Byungchul Park <byungchul@sk.com> -
STALE236d
REVIEWED: 2 (0M) [PATCH v17 02/47] dept: implement DEPT(DEPendency Tracker)
2025-10-02 · Byungchul Park <byungchul@sk.com> -
STALE2213d
REVIEWED: 4 (4M) [PATCH 1/5] selftests: kmod: Use variable NAME in kmod_test_0001()
2020-06-10 · "Luis R. Rodriguez" <mcgrof@kernel.org> -
STALE2213d
[PATCH 5/5] selftests: simplify kmod failure value
2020-06-10 · "Luis R. Rodriguez" <mcgrof@kernel.org> -
STALE2213d
REVIEWED: 4 (4M) [PATCH 3/5] test_kmod: Avoid potential double free in trigger_config_run_type()
2020-06-10 · "Luis R. Rodriguez" <mcgrof@kernel.org> -
STALE3236d
[PATCH 4/9] Allow processes to be forked and upcalled into a container
2017-05-22 · David Howells <dhowells@redhat.com> -
STALE5232d
[PATCH 6/6] kmod: optional: Convert the use of xchg to a kref
2012-03-27 · Boaz Harrosh <hidden> -
STALE5232d
[PATCH 5/6] kmod: Add new call_usermodehelper_timeout() API
2012-03-27 · Boaz Harrosh <hidden> -
STALE5232d
[PATCH 3/6] kmod: Move call_usermodehelper_fns() to .c file and unexport all it's helpers
2012-03-27 · Boaz Harrosh <hidden> -
DORMANTno replies
[PATCH 1/6] kmod: Unexport call_usermodehelper_freeinfo()
2012-03-27 · Boaz Harrosh <hidden> -
STALE5232d
[RFC 4/4] {RFC} kmod.c: Add new call_usermodehelper_timeout() API
2012-03-20 · Boaz Harrosh <hidden> -
STALE5232d
[PATCH 3/4] kmod: Move call_usermodehelper_fns() to .c file and unexport it's helpers
2012-03-20 · Boaz Harrosh <hidden> -
DORMANTno replies
[PATCH 1/4] kmod: Un-export call_usermodehelper_freeinfo()
2012-03-20 · Boaz Harrosh <hidden> -
DORMANTno replies
REVIEWED: 2 (0M) [PATCH] KEYS/DNS: Fix ____call_usermodehelper() to not lose the session keyring [ver #2]
2011-06-17 · David Howells <hidden> -
DORMANTno replies
REVIEWED: 2 (0M) [PATCH] KEYS/DNS: Fix ____call_usermodehelper() to not lose the session keyring
2011-06-16 · David Howells <hidden>
Quiet for 30+ days
Patches with no review trailers and no replies. Either the author is heads-down elsewhere or these slipped through. Oldest first.
-
STALE100d
[PATCH 21/61] lib/test: Prefer IS_ERR_OR_NULL over manual NULL check
2026-03-10 · Philipp Hahn <hidden>