# Re: \[PATCH\] module: add in-kernel support for decompressing

- From: Dmitry Torokhov \<dmitry.torokhov@gmail.com\>
- Date: 2021-12-01 20:19:22 
- List: linux-modules
- Page: https://ratatoskr.run/linux-modules/2021/12/1593427
- Thread: https://ratatoskr.run/linux-modules/2021/11/1588769/t.md

```text
On Wed, Dec 01, 2021 at 11:24:35AM -0800, Kees Cook wrote:
> On Sat, Nov 27, 2021 at 09:48:22PM -0800, Dmitry Torokhov wrote:
> >  /* Flags for sys_finit_module: */
> >  #define MODULE_INIT_IGNORE_MODVERSIONS	1
> >  #define MODULE_INIT_IGNORE_VERMAGIC	2
> > +#define MODULE_INIT_COMPRESSED_DATA	4
> 
> bikeshedding: adding "_DATA" seems redundant/misleading? The entire
> module is compressed, so maybe call it just MODULE_INIT_COMPRESSED ?

OK, or maybe MODULE_INIT_COMPRESSED_FILE since we are indeed dealing
with a file?

Thanks.

-- 
Dmitry
```
