io_uring · Maintained
Maintainers
- M Jens Axboe <axboe@kernel.dk>
Paths
- F
include/linux/io_uring/ - F
include/linux/io_uring.h - F
include/linux/io_uring_types.h - F
include/trace/events/io_uring.h - F
include/uapi/linux/io_uring.h - F
include/uapi/linux/io_uring/ - F
io_uring/
Last 30 days
Recent patches
Most-recent 30 patches in this subsystem on linux-mm (capped at 30), ordered by date desc.
-
COLD19d
Re: [syzbot] [mm?] KCSAN: data-race in mas_wr_slot_store / mtree_range_walk
2026-06-10 · Jay Vadayath <hidden> -
COLD29d
[PATCH v2 1/2] block: Add bvec_folio()
2026-05-28 · "Matthew Wilcox (Oracle)" <willy@infradead.org> -
COLD26d
[PATCH] mm/slab: improve kmem_cache_alloc_bulk
2026-05-28 · Christoph Hellwig <hch@lst.de> -
COLD33d
[PATCH] mm/slab: improve kmem_cache_alloc_bulk
2026-05-27 · Christoph Hellwig <hch@lst.de> -
COLD33d
[PATCH] block: Add bvec_folio()
2026-05-22 · "Matthew Wilcox (Oracle)" <willy@infradead.org> -
COLD29d
[PATCH RFC 06/11] folio_wait: rename wait_page_* infrastructure to wait_folio_*
2026-05-20 · Tal Zussman <hidden> -
STALE103d
[PATCH v2 2/2] tree-wide: rename do_exit() to task_exit()
2026-03-10 · Christian Brauner <brauner@kernel.org> -
STALE81d
[RFC PATCH 1/5] io_uring: allocate folio in io_mem_alloc_compound() and function rename
2026-01-30 · Zi Yan <ziy@nvidia.com> -
STALE145d
[PATCH 1/2] io_uring: Support commands with optional file descriptors
2026-01-29 · Gabriel Krisman Bertazi <hidden> -
STALE145d
[PATCH 2/2] io_uring: introduce IORING_OP_MMAP
2026-01-29 · Gabriel Krisman Bertazi <hidden> -
STALE216d
[PATCH net-next 1/3] netmem, io_uring/zcrx: access pp fields through @desc in net_iov
2025-11-21 · Byungchul Park <byungchul@sk.com> -
STALE244d
Re: [RFC mm v4 1/2] page_pool: check if nmdesc->pp is !NULL to confirm its usage as pp for net_iov
2025-10-28 · Byungchul Park <byungchul@sk.com> -
STALE259d
[PATCH v1] mm: Consistently use current->mm in mm_get_unmapped_area()
2025-10-03 · Ryan Roberts <ryan.roberts@arm.com> -
STALE264d
REVIEWED: 3 (2M) [PATCH v2 20/37] io_uring/zcrx: remove nth_page() usage within folio
2025-09-01 · David Hildenbrand <hidden> -
STALE302d
REVIEWED: 2 (2M) [PATCH v1 19/36] io_uring/zcrx: remove nth_page() usage within folio
2025-08-27 · David Hildenbrand <hidden> -
STALE264d
Re: [PATCH RFC 18/35] io_uring/zcrx: remove "struct io_copy_cache" and one nth_page() usage
2025-08-22 · Pavel Begunkov <asml.silence@gmail.com> -
STALE264d
[PATCH RFC 19/35] io_uring/zcrx: remove nth_page() usage within folio
2025-08-21 · David Hildenbrand <hidden> -
STALE264d
[PATCH RFC 18/35] io_uring/zcrx: remove "struct io_copy_cache" and one nth_page() usage
2025-08-21 · David Hildenbrand <hidden> -
STALE320d
REVIEWED: 2 (0M) [PATCH linux-next v3] mm, page_pool: introduce a new page type for page pool in page type
2025-07-29 · Byungchul Park <byungchul@sk.com> -
STALE334d
[PATCH v2 rebase as of Jul 28] mm, page_pool: introduce a new page type for page pool in page type
2025-07-28 · Byungchul Park <byungchul@sk.com> -
STALE334d
[PATCH v2] mm, page_pool: introduce a new page type for page pool in page type
2025-07-28 · Byungchul Park <byungchul@sk.com> -
STALE337d
Re: [PATCH] mm, page_pool: introduce a new page type for page pool in page type
2025-07-25 · Byungchul Park <byungchul@sk.com> -
STALE336d
Re: [PATCH net-next v9 1/8] netmem: introduce struct netmem_desc mirroring struct page
2025-07-14 · Pavel Begunkov <asml.silence@gmail.com> -
STALE362d
Re: [PATCH 5/5] vfio-pci: Best-effort huge pfnmaps with !MAP_FIXED mappings
2025-06-25 · Peter Xu <peterx@redhat.com> -
STALE412d
[RFC 01/19] netmem: rename struct net_iov to struct netmem_desc
2025-05-09 · Byungchul Park <byungchul@sk.com> -
STALE431d
Re: [PATCH v2 1/2] io_uring: Add new functions to handle user fault scenarios
2025-04-23 · Jens Axboe <axboe@kernel.dk> -
STALE431d
[PATCH v2 1/2] io_uring: Add new functions to handle user fault scenarios
2025-04-22 · Zhiwei Jiang <hidden> -
STALE433d
[PATCH 1/2] io_uring: Add new functions to handle user fault scenarios
2025-04-22 · Zhiwei Jiang <hidden> -
STALE454d
[PATCH] mm: Rename vm_area_struct to mm_area
2025-04-01 · "Matthew Wilcox (Oracle)" <willy@infradead.org> -
STALE459d
[PATCH 2/5] treewide: Prepare for kfree() to __kfree() rename
2025-03-21 · Kees Cook <kees@kernel.org>
Quiet for 30+ days
Patches with no review trailers and no replies. Either the author is heads-down elsewhere or these slipped through. Oldest first.
-
STALE145d
[PATCH 1/2] io_uring: Support commands with optional file descriptors
2026-01-29 · Gabriel Krisman Bertazi <hidden> -
COLD29d
[PATCH RFC 06/11] folio_wait: rename wait_page_* infrastructure to wait_folio_*
2026-05-20 · Tal Zussman <hidden>