Reviews by willy@infradead.org
· linux-mm
All review-attestation trailers
(Reviewed-by / Acked-by /
Tested-by / Reported-by /
Suggested-by / Co-developed-by /
Reported-and-tested-by)
by this address on the linux-mm archive.
100 attestations · capped at 100 most-recent. (2 Acked-by, 12 Co-developed-by, 36 Reviewed-by, 50 Suggested-by)
-
HOTtoday
[PATCH v7 09/13] filemap: Add hwpoison handling to filemap_read()
2026-07-28 · Co-developed-by -
HOTtoday
[PATCH v7 13/13] hugetlb: replace hugetlbfs_read_iter() with generic_file_read_iter()
2026-07-28 · Co-developed-by -
WARM1d
REVIEWED: 5 (5M) Re: [PATCH] mm/filemap: __filemap_add_folio() restore index before retrying
2026-07-28 · Reviewed-by -
WARM1d
[PATCH v6 12/12] hugetlb: replace hugetlbfs_read_iter() with generic_file_read_iter()
2026-07-27 · Co-developed-by -
WARM1d
[PATCH v6 08/12] filemap: Add hwpoison handling to filemap_read()
2026-07-27 · Co-developed-by -
WARM2d
[PATCH v5 08/12] filemap: Add hwpoison handling to filemap_read()
2026-07-25 · Co-developed-by -
WARM2d
[PATCH v5 12/12] hugetlb: replace hugetlbfs_read_iter() with generic_file_read_iter()
2026-07-25 · Co-developed-by -
COOLING4d
[PATCH v4 14/14] hugetlb: replace hugetlbfs_read_iter() with generic_file_read_iter()
2026-07-23 · Co-developed-by -
COOLING4d
[PATCH v4 10/14] filemap: Add hwpoison handling to filemap_read()
2026-07-23 · Co-developed-by -
WARM1d
[PATCH 3/3] drm/ttm: allocate pool pages as compound (__GFP_COMP)
2026-07-22 · Suggested-by -
WARM1d
[PATCH 1/3] mm/huge_memory: add folio_split_driver_managed()
2026-07-22 · Suggested-by -
COOLING14d
[PATCH v3 9/9] hugetlb: replace hugetlbfs_read_iter() with generic_file_read_iter()
2026-07-14 · Co-developed-by -
COOLING14d
[PATCH v3 5/9] filemap: Add hwpoison handling to filemap_read()
2026-07-14 · Co-developed-by -
COOLING5d
[PATCH 14/22] mm: set page table page type when allocated
2026-07-14 · Suggested-by -
COOLING5d
[PATCH 13/22] mm: account page table pages when allocated
2026-07-14 · Suggested-by -
COOLING13d
[PATCH v2 08/10] filemap: Add hwpoison handling to filemap_read()
2026-07-09 · Co-developed-by -
COOLING13d
[PATCH v2 10/10] hugetlb: replace hugetlbfs_read_iter() with generic_file_read_iter()
2026-07-09 · Co-developed-by -
COLD15d
REVIEWED: 5 (5M) Re: [PATCH v2] mm/util: don't read __page_2 for order-1 folios in snapshot_page()
2026-07-08 · Reviewed-by -
COLD21d
REVIEWED: 5 (5M) Re: [PATCH 5.15.y 6.1.y 6.6.y 1/1] mm/vmscan: flush deferred TLB before freeing large folios
2026-07-08 · Reviewed-by -
COLD21d
IN LINUX-NEXT: 32 (32M) [PATCH v9 2/3] mm: rename swap.c to folio.c
2026-07-08 · Suggested-by -
COLD21d
IN LINUX-NEXT: 24 (24M) [PATCH v9 1/3] mm/swap: colocate page-cluster sysctl with swap readahead
2026-07-08 · Suggested-by -
COLD20d
[PATCH 3/4] filemap: add hwpoison handling to filemap_read()
2026-07-07 · Suggested-by -
COLD20d
[PATCH 4/4] hugetlbfs: replace hugetlbfs_read_iter() with generic_file_read_iter()
2026-07-07 · Suggested-by -
COLD21d
REVIEWED: 32 (32M) [PATCH v8 2/3] mm: rename swap.c to folio.c
2026-07-07 · Suggested-by -
COLD22d
REVIEWED: 32 (32M) [PATCH v7 2/3] mm: rename swap.c to folio.c
2026-07-05 · Suggested-by -
COOLING7d
IN LINUX-NEXT: 18 (18M) [PATCH v5 06/18] mm/page_alloc: relax GFP WARN in nolock allocs
2026-07-03 · Suggested-by -
COLD30d
REVIEWED: 5 (5M) Re: [PATCH] mm: A second pagecache maintainer
2026-06-29 · Acked-by -
COLD28d
REVIEWED: 7 (7M) [PATCH v3 06/16] mm/page_alloc: relax GFP WARN in nolock allocs
2026-06-29 · Suggested-by -
COLD36d
IN MM: 1 (0M) [PATCH v3] mm: page_ext: add count limit to page_ext_iter_next to prevent invalid PFN access
2026-06-22 · Suggested-by -
COLD37d
[PATCH v2] mm: page_ext: add count limit to page_ext_iter_next to prevent invalid PFN access
2026-06-22 · Suggested-by -
COLD33d
[PATCH v2 04/13] mm/page_alloc: relax GFP WARN in nolock allocs
2026-06-22 · Suggested-by -
COLD35d
REVIEWED: 5 (5M) Re: [PATCH mm-hotfixses] Revert "mm: limit filemap_fault readahead to VMA boundaries"
2026-06-19 · Reviewed-by -
COLD36d
[PATCH v2 05/11] hugetlb: Convert the vmf->pgoff to PAGE_SIZE granularity
2026-06-17 · Suggested-by -
COLD36d
[PATCH v2 04/11] hugetlbfs,filemap: replace hugetlbfs_read_iter() with generic_file_read_iter()
2026-06-17 · Suggested-by -
COLD36d
[PATCH v2 03/11] mm/filemap: add hwpoison handling to filemap_read()
2026-06-17 · Suggested-by -
COLD36d
[PATCH v2 02/11] mm: factor out adjust_range_hwpoison() from hugetlbfs
2026-06-17 · Suggested-by -
DORMANTno replies
REVIEWED: 5 (5M) Re: [PATCH v1] mm/filemap: use folio_next_index() for start
2026-06-01 · Reviewed-by -
COLD43d
IN MM: 36 (36M) [PATCH v6 07/14] fs: remove nr_thps from struct address_space
2026-05-17 · Reviewed-by -
COLD43d
IN MM: 25 (25M) [PATCH v6 06/14] mm: fs: remove filemap_nr_thps*() functions and their users
2026-05-17 · Reviewed-by -
HOTtoday
[PATCH v6 1/4] block: add task-context bio completion infrastructure
2026-05-14 · Suggested-by -
STALE72d
REVIEWED: 35 (35M) [PATCH v5 07/14] fs: remove nr_thps from struct address_space
2026-04-29 · Reviewed-by -
STALE72d
REVIEWED: 22 (22M) [PATCH v5 06/14] mm: fs: remove filemap_nr_thps*() functions and their users
2026-04-29 · Reviewed-by -
STALE92d
REVIEWED: 5 (5M) Re: [PATCH 3/3] mm: remove page_mapped()
2026-04-27 · Reviewed-by -
STALE92d
REVIEWED: 5 (5M) Re: [PATCH 2/3] bpf: arena: use page_ref_count() instead of page_mapped() in arena_free_pages()
2026-04-27 · Reviewed-by -
STALE92d
REVIEWED: 5 (5M) Re: [PATCH 1/3] sh: use folio_mapped() instead of page_mapped() in sh4_flush_cache_page()
2026-04-27 · Reviewed-by -
DORMANTno replies
IN MM: 15 (15M) [PATCH v2] mm/lruvec: preemptively free dead folios during lru_add drain
2026-04-25 · Reviewed-by -
STALE94d
REVIEWED: 35 (35M) [PATCH 7.2 v4 07/12] fs: remove nr_thps from struct address_space
2026-04-24 · Reviewed-by -
STALE94d
REVIEWED: 22 (22M) [PATCH 7.2 v4 06/12] mm: fs: remove filemap_nr_thps*() functions and their users
2026-04-24 · Reviewed-by -
STALE96d
REVIEWED: 5 (5M) Re: [PATCH] mm/lruvec: preemptively free dead folios during lru_add drain
2026-04-23 · Reviewed-by -
STALE93d
REVIEWED: 35 (35M) [PATCH 7.2 v3 07/12] fs: remove nr_thps from struct address_space
2026-04-18 · Reviewed-by -
STALE93d
REVIEWED: 22 (22M) [PATCH 7.2 v3 06/12] mm: fs: remove filemap_nr_thps*() functions and their users
2026-04-18 · Reviewed-by -
STALE104d
REVIEWED: 5 (5M) Re: [PATCH] MAINTAINERS: Add page cache reviewer
2026-04-15 · Acked-by -
STALE103d
REVIEWED: 5 (5M) Re: [PATCH 7.2 v2 07/12] fs: remove nr_thps from struct address_space
2026-04-13 · Reviewed-by -
STALE103d
REVIEWED: 5 (5M) Re: [PATCH 7.2 v2 06/12] mm: fs: remove filemap_nr_thps*() functions and their users
2026-04-13 · Reviewed-by -
STALE76d
[PATCH 1/8] block: add BIO_COMPLETE_IN_TASK for task-context completion
2026-04-09 · Suggested-by -
STALE111d
[PATCH RFC v5 1/3] block: add BIO_COMPLETE_IN_TASK for task-context completion
2026-04-08 · Suggested-by -
STALE118d
IN MM [PATCH v5] mm/page_io: rename swap_iocb fields for clarity
2026-04-02 · Suggested-by -
STALE118d
[PATCH v4 2/2] mm/page_io: rename swap_iocb->pages to swap_iocb->bvecs
2026-04-02 · Suggested-by -
STALE118d
[PATCH v4] mm/page_io: rename swap_iocb->pages to swap_iocb->bvecs
2026-04-02 · Suggested-by -
STALE118d
[PATCH v6 5/6] mm: use vma_start_write_killable() in process_vma_walk_lock()
2026-03-27 · Suggested-by -
STALE118d
[PATCH v6 4/6] mm/vma: use vma_start_write_killable() in vma operations
2026-03-27 · Suggested-by -
STALE118d
REVIEWED: 10 (10M) [PATCH v6 3/6] mm/khugepaged: use vma_start_write_killable() in collapse_huge_page()
2026-03-27 · Suggested-by -
STALE118d
[PATCH v6 2/6] mm: use vma_start_write_killable() in mm syscalls
2026-03-27 · Suggested-by -
STALE124d
[PATCH v5 5/6] mm: use vma_start_write_killable() in process_vma_walk_lock()
2026-03-26 · Suggested-by -
STALE124d
[PATCH v5 4/6] mm/vma: use vma_start_write_killable() in vma operations
2026-03-26 · Suggested-by -
STALE124d
REVIEWED: 10 (10M) [PATCH v5 3/6] mm/khugepaged: use vma_start_write_killable() in collapse_huge_page()
2026-03-26 · Suggested-by -
STALE124d
[PATCH v5 2/6] mm: use vma_start_write_killable() in mm syscalls
2026-03-26 · Suggested-by -
STALE105d
[PATCH RFC v4 1/3] block: add BIO_COMPLETE_IN_TASK for task-context completion
2026-03-25 · Suggested-by -
STALE127d
[PATCH v4 2/4] mm: replace vma_start_write() with vma_start_write_killable()
2026-03-22 · Suggested-by -
STALE148d
[PATCH 3/3] mm/page_alloc: remove pcpu_spin_* wrappers
2026-02-27 · Suggested-by -
STALE132d
REVIEWED: 2 (2M) [PATCH v4 3/6] drm/gem-shmem: Return vm_fault_t from drm_gem_shmem_try_map_pmd()
2026-02-27 · Suggested-by -
STALE146d
[PATCH v3 2/3] mm: replace vma_start_write() with vma_start_write_killable()
2026-02-26 · Suggested-by -
STALE145d
REVIEWED: 21 (21M) [PATCH v2 1/4] mm: Remove stray references to struct pagevec
2026-02-25 · Reviewed-by -
STALE154d
REVIEWED: 5 (5M) Re: [PATCH] mm: Remove stray references to struct pagevec
2026-02-25 · Reviewed-by -
STALE161d
[PATCH v2 2/3] mm: replace vma_start_write() with vma_start_write_killable()
2026-02-17 · Suggested-by -
STALE168d
[PATCH 1/1] mm: replace vma_start_write() with vma_start_write_killable()
2026-02-09 · Suggested-by -
STALE165d
REVIEWED: 5 (5M) Re: [PATCH v2] Docs/mm: fix typos and grammar in page_tables.rst
2026-02-09 · Reviewed-by -
STALE62d
REVIEWED: 2 (2M) [PATCH v3 3/6] drm/gem-shmem: Return vm_fault_t from drm_gem_shmem_try_map_pmd()
2026-02-09 · Suggested-by -
STALE170d
[PATCH v2 1/4] drm/gem-shmem: Return vm_fault_t from drm_gem_shmem_try_map_pmd()
2026-02-04 · Suggested-by -
STALE181d
REVIEWED: 5 (5M) Re: [PATCH] mm: Refactor vma_map_pages to use vm_insert_pages
2026-01-29 · Reviewed-by -
STALE201d
[PATCH] mm/migrate: fix hugetlbfs deadlock by respecting lock ordering
2026-01-09 · Suggested-by -
STALE222d
REVIEWED: 5 (5M) Re: [PATCH] mm/mm_init: Replace simple_strtoul with kstrtobool in set_hashdist
2025-12-18 · Reviewed-by -
STALE180d
REVIEWED: 15 (15M) [PATCH v4 1/3] mm: pagewalk: simplify hugepage boundary calculation
2025-11-28 · Suggested-by -
STALE244d
[PATCH v3 1/3] mm: pagewalk: simplify hugepage boundary calculation using min()
2025-11-27 · Suggested-by -
STALE247d
[PATCH v2 1/3] mm: pagewalk: simplify hugepage boundary calculation using min()
2025-11-23 · Suggested-by -
DORMANTno replies
REVIEWED: 5 (5M) Re: [PATCH] mm/filemap: Fix logic around SIGBUS in filemap_map_pages()
2025-11-20 · Reviewed-by -
DORMANTno replies
REVIEWED: 5 (4M) [PATCH v2] mm/page_alloc: don't warn about large allocations with __GFP_NOFAIL
2025-11-05 · Suggested-by -
STALE266d
[PATCH] mm/page_alloc: don't warn about large allocations with __GFP_NOFAIL
2025-11-05 · Suggested-by -
STALE266d
[PATCH RFC] mm: allow __GFP_NOFAIL allocation up to BLK_MAX_BLOCK_SIZE to support LBS
2025-10-31 · Suggested-by -
STALE289d
REVIEWED: 5 (5M) Re: [PATCH v2] mm/vmscan: Remove redundant __GFP_NOWARN
2025-10-06 · Reviewed-by -
STALE327d
REVIEWED: 5 (5M) [PATCH v3 2/7] aoe: Stop calling page_address() in free_page()
2025-09-03 · Reviewed-by -
STALE327d
REVIEWED: 6 (6M) [PATCH v3 1/7] mm/page_alloc: Add kernel-docs for free_pages()
2025-09-03 · Reviewed-by -
STALE335d
REVIEWED: 5 (5M) Re: [PATCH v2] pagevec.h: add `const` to pointer parameters of getter functions
2025-08-28 · Reviewed-by -
STALE317d
REVIEWED: 5 (5M) [PATCH v2 2/7] aoe: Stop calling page_address() in free_page()
2025-08-26 · Reviewed-by -
STALE317d
REVIEWED: 5 (5M) [PATCH v2 1/7] mm/page_alloc: Add kernel-docs for free_pages()
2025-08-26 · Reviewed-by -
STALE337d
REVIEWED: 5 (5M) Re: [PATCH 2/7] aoe: Stop calling page_address() in free_page()
2025-08-26 · Reviewed-by -
STALE337d
REVIEWED: 5 (5M) Re: [PATCH 1/7] mm/page_alloc: Add kernel-docs for free_pages()
2025-08-26 · Reviewed-by -
STALE338d
REVIEWED: 5 (5M) Re: [PATCH v6] mm/slub: avoid accessing metadata when pointer is invalid in object_err()
2025-08-05 · Reviewed-by -
STALE366d
[PATCH v1 2/2] mm/filemap: Skip non-uptodate folio if there are available folios
2025-07-28 · Suggested-by -
STALE372d
REVIEWED: 5 (5M) Re: [PATCH] mm/page-flags: remove folio_start_writeback_keepwrite()
2025-07-22 · Reviewed-by