Reviews by ryabinin.a.a@gmail.com
· linux-mm
All review-attestation trailers
(Reviewed-by / Acked-by /
Tested-by / Reported-by /
Suggested-by / Co-developed-by /
Reported-and-tested-by)
by this address on the linux-mm archive.
49 attestations . (6 Acked-by, 30 Reviewed-by, 13 Suggested-by)
-
COLD19d
REVIEWED: 4 (2M) [PATCH v3 4/8] riscv: remove unreachable invalid range check in kasan_init()
2026-06-30 · Reviewed-by -
COLD19d
REVIEWED: 2 (2M) [PATCH v3 1/8] arm64: mm: remove unreachable invalid range check in kasan_init_shadow()
2026-06-30 · Reviewed-by -
COLD19d
REVIEWED: 2 (2M) [PATCH v3 2/8] LoongArch: remove unreachable invalid range check in kasan_init()
2026-06-30 · Reviewed-by -
COLD19d
REVIEWED: 4 (2M) [PATCH v2 4/8] riscv: remove unreachable invalid range check in kasan_init()
2026-06-29 · Reviewed-by -
COLD19d
REVIEWED: 2 (2M) [PATCH v2 1/8] arm64: mm: remove unreachable invalid range check in kasan_init_shadow()
2026-06-29 · Reviewed-by -
COLD19d
REVIEWED: 2 (2M) [PATCH v2 2/8] LoongArch: remove unreachable invalid range check in kasan_init()
2026-06-29 · Reviewed-by -
COLD54d
REVIEWED: 2 (2M) [PATCH v12 04/15] x86/kasan: Add arch specific kasan functions
2026-03-30 · Reviewed-by -
COLD54d
REVIEWED: 6 (6M) [PATCH v12 02/15] kasan: arm64: x86: Make special tags arch specific
2026-03-30 · Reviewed-by -
STALE131d
REVIEWED: 2 (2M) [PATCH v11 04/15] x86/kasan: Add arch specific kasan functions
2026-03-10 · Reviewed-by -
STALE131d
REVIEWED: 6 (6M) [PATCH v11 02/15] kasan: arm64: x86: Make special tags arch specific
2026-03-10 · Reviewed-by -
STALE131d
REVIEWED: 2 (2M) Re: [PATCH v2] mm/kasan: Fix double free for kasan pXds
2026-03-05 · Reviewed-by -
DORMANTno replies
FAILED: Patch "mm/slab: use unsigned long for orig_size to ensure proper metadata align" failed to apply to 6.1-stable tree
2026-03-01 · Suggested-by -
DORMANTno replies
FAILED: Patch "mm/slab: use unsigned long for orig_size to ensure proper metadata align" failed to apply to 6.6-stable tree
2026-03-01 · Suggested-by -
DORMANTno replies
FAILED: Patch "mm/slab: use unsigned long for orig_size to ensure proper metadata align" failed to apply to 6.12-stable tree
2026-03-01 · Suggested-by -
STALE136d
REVIEWED: 2 (2M) [PATCH v10 04/13] x86/kasan: Add arch specific kasan functions
2026-02-04 · Reviewed-by -
STALE136d
REVIEWED: 6 (6M) [PATCH v10 02/13] kasan: arm64: x86: Make special tags arch specific
2026-02-04 · Reviewed-by -
STALE178d
REVIEWED: 2 (2M) Re: [PATCH 1/1] kasan: remove unnecessary sync argument from start_report()
2026-01-22 · Acked-by -
STALE144d
REVIEWED: 2 (2M) [PATCH v9 04/13] x86/kasan: Add arch specific kasan functions
2026-01-20 · Reviewed-by -
STALE144d
REVIEWED: 6 (6M) [PATCH v9 02/13] kasan: arm64: x86: Make special tags arch specific
2026-01-20 · Reviewed-by -
STALE178d
REVIEWED: 2 (2M) Re: [PATCH v8 04/14] x86/kasan: Add arch specific kasan functions
2026-01-16 · Reviewed-by -
STALE178d
REVIEWED: 2 (2M) Re: [PATCH v8 02/14] kasan: arm64: x86: Make special tags arch specific
2026-01-16 · Reviewed-by -
STALE188d
[PATCH V6 1/9] mm/slab: use unsigned long for orig_size to ensure proper metadata align
2026-01-13 · Suggested-by -
STALE189d
[PATCH V5 1/8] mm/slab: use unsigned long for orig_size to ensure proper metadata align
2026-01-05 · Suggested-by -
STALE202d
[PATCH V4 1/8] mm/slab: use unsigned long for orig_size to ensure proper metadata align
2025-12-22 · Suggested-by -
STALE285d
REVIEWED: 3 (2M) [PATCH v4 06/10] mm/kasan: Support non-blocking GFP in kasan_populate_vmalloc()
2025-10-07 · Reviewed-by -
STALE286d
REVIEWED: 3 (2M) [PATCH v3 06/10] mm/kasan: Support non-blocking GFP in kasan_populate_vmalloc()
2025-10-01 · Reviewed-by -
DORMANTno replies
REVIEWED: 2 (2M) Re: [PATCH v2 07/10] mm/kasan: Support non-blocking GFP in kasan_populate_vmalloc()
2025-09-18 · Reviewed-by -
STALE299d
REVIEWED: 2 (2M) Re: [PATCH v8 2/2] kasan: apply write-only mode in kasan kunit testcases
2025-09-18 · Reviewed-by -
STALE299d
REVIEWED: 2 (2M) Re: [PATCH v8 1/2] kasan/hw-tags: introduce kasan.write_only option
2025-09-18 · Reviewed-by -
DORMANTno replies
REVIEWED: 2 (2M) Re: [PATCH] mm/vmalloc, mm/kasan: respect gfp mask in kasan_populate_vmalloc()
2025-09-05 · Reviewed-by -
DORMANTno replies
REVIEWED: 2 (2M) Re: [PATCH] kasan: use vmalloc_dump_obj() for vmalloc error reports
2025-07-18 · Acked-by -
STALE368d
REVIEWED: 2 (2M) Re: [PATCH v2] kasan: remove kasan_find_vm_area() to prevent possible deadlock
2025-07-04 · Reviewed-by -
STALE429d
[PATCH v9 1/1] kasan: Avoid sleepable page allocation from atomic context
2025-05-15 · Suggested-by -
STALE431d
REVIEWED: 1 (0M) [PATCH v8 1/1] kasan: Avoid sleepable page allocation from atomic context
2025-05-13 · Suggested-by -
STALE433d
[PATCH v7 1/1] kasan: Avoid sleepable page allocation from atomic context
2025-05-12 · Suggested-by -
STALE434d
[PATCH v6 1/1] kasan: Avoid sleepable page allocation from atomic context
2025-05-08 · Suggested-by -
STALE438d
[PATCH v5 1/1] kasan: Avoid sleepable page allocation from atomic context
2025-05-07 · Suggested-by -
STALE439d
[PATCH v4 1/1] kasan: Avoid sleepable page allocation from atomic context
2025-05-06 · Suggested-by -
STALE439d
[PATCH v3 1/1] kasan: Avoid sleepable page allocation from atomic context
2025-04-29 · Suggested-by -
DORMANTno replies
REVIEWED: 2 (2M) Re: [PATCH mm-unstable] mm/kasan: use SLAB_NO_MERGE flag instead of an empty constructor
2025-03-20 · Acked-by -
STALE518d
REVIEWED: 2 (2M) Re: [PATCH v2] kasan: Don't call find_vm_area() in RT kernel
2025-02-12 · Acked-by -
STALE1871d
REVIEWED: 2 (2M) [patch 09/13] mm/kasan/init.c: fix doc warning
2021-06-05 · Acked-by -
STALE1870d
REVIEWED: 2 (2M) Re: [PATCH] kasan: fix doc warning in init.c
2021-06-03 · Acked-by -
DORMANTno replies
REVIEWED: 2 (2M) Re: [PATCH V2 2/4] mm/kasan: MODULE_VADDR is not available on all archs
2015-09-08 · Reviewed-by -
STALE3968d
REVIEWED: 2 (2M) [PATCH V2 3/4] mm/kasan: Don't use kasan shadow pointer in generic functions
2015-09-07 · Reviewed-by -
STALE3968d
REVIEWED: 2 (2M) [PATCH V2 4/4] mm/kasan: Prevent deadlock in kasan reporting
2015-09-07 · Reviewed-by -
STALE3968d
REVIEWED: 2 (2M) [PATCH V2 1/4] mm/kasan: Rename kasan_enabled to kasan_report_enabled
2015-09-07 · Reviewed-by -
DORMANTno replies
REVIEWED: 2 (2M) Re: [PATCH 4/4] kasan: Prevent deadlock in kasan reporting
2015-09-03 · Reviewed-by -
STALE3973d
REVIEWED: 2 (2M) [PATCH 1/4] kasan: Rename kasan_enabled to kasan_report_enabled
2015-09-03 · Reviewed-by