Reviews by joe@perches.com
· linux-mm
All review-attestation trailers
(Reviewed-by / Acked-by /
Tested-by / Reported-by /
Suggested-by / Co-developed-by /
Reported-and-tested-by)
by this address on the linux-mm archive.
66 attestations . (39 Acked-by, 3 Reported-by, 24 Suggested-by)
-
COOLING4d
IN LINUX-NEXT [PATCH v2 16/19] maple_tree: Change two GFP flags in tests
2026-06-30 · Reported-by -
COLD44d
[PATCH 16/18] maple_tree: Change two GFP flags in tests
2026-06-29 · Reported-by -
STALE1665d
REVIEWED: 3 (3M) [patch 34/55] checkpatch: relax regexp for COMMIT_LOG_LONG_LINE
2022-01-20 · Acked-by -
STALE1736d
REVIEWED: 3 (3M) [patch 41/87] checkpatch: get default codespell dictionary path from package location
2021-11-09 · Acked-by -
STALE1780d
[patch 5/9] slab: clean up function declarations
2021-09-10 · Suggested-by -
STALE1780d
[patch 4/9] checkpatch: add __alloc_size() to known $Attribute
2021-09-10 · Suggested-by -
STALE1783d
REVIEWED: 3 (3M) [patch 125/147] checkpatch: make email address check case insensitive
2021-09-08 · Acked-by -
STALE1784d
[PATCH v2 3/7] slab: Clean up function declarations
2021-08-18 · Suggested-by -
STALE1784d
[PATCH v2 2/7] checkpatch: Add __alloc_size() to known $Attribute
2021-08-18 · Suggested-by -
STALE1856d
REVIEWED: 3 (3M) [patch 175/192] checkpatch: do not complain about positive return values starting with EPOLL
2021-07-01 · Acked-by -
STALE1912d
REVIEWED: 3 (3M) [patch 38/91] checkpatch: improve ALLOC_ARRAY_ARGS test
2021-05-07 · Acked-by -
STALE1912d
REVIEWED: 3 (3M) [patch 37/91] checkpatch: exclude four preprocessor sub-expressions from MACRO_ARG_REUSE
2021-05-07 · Acked-by -
STALE1987d
REVIEWED: 3 (3M) [patch 107/118] checkpatch: do not apply "initialise globals to 0" check to BPF progs
2021-02-26 · Acked-by -
STALE1987d
REVIEWED: 3 (3M) [patch 106/118] checkpatch: don't warn about colon termination in linker scripts
2021-02-26 · Acked-by -
STALE1987d
REVIEWED: 4 (4M) [patch 104/118] checkpatch: add warning for avoiding .L prefix symbols in assembly files
2021-02-26 · Acked-by -
STALE1987d
REVIEWED: 3 (3M) [patch 101/118] checkpatch: trivial style fixes
2021-02-26 · Acked-by -
STALE1987d
REVIEWED: 3 (3M) [patch 100/118] checkpatch: ignore warning designated initializers using NR_CPUS
2021-02-26 · Acked-by -
STALE2064d
REVIEWED: 3 (3M) [patch 56/95] checkpatch: fix TYPO_SPELLING check for words with apostrophe
2020-12-16 · Suggested-by -
STALE2064d
REVIEWED: 3 (3M) [patch 56/95] checkpatch: fix TYPO_SPELLING check for words with apostrophe
2020-12-16 · Acked-by -
STALE2064d
REVIEWED: 4 (3M) [patch 55/95] checkpatch: add warning for lines starting with a '#' in commit log
2020-12-16 · Suggested-by -
STALE2064d
REVIEWED: 4 (3M) [patch 55/95] checkpatch: add warning for lines starting with a '#' in commit log
2020-12-16 · Acked-by -
STALE2064d
REVIEWED: 3 (3M) [patch 54/95] checkpatch: add warning for unnecessary use of %h[xudi] and %hh[xudi]
2020-12-16 · Suggested-by -
STALE2064d
REVIEWED: 3 (3M) [patch 54/95] checkpatch: add warning for unnecessary use of %h[xudi] and %hh[xudi]
2020-12-16 · Acked-by -
STALE2064d
REVIEWED: 3 (3M) [patch 53/95] checkpatch: add fix and improve warning msg for non-standard signature
2020-12-16 · Acked-by -
STALE2064d
REVIEWED: 3 (3M) [patch 52/95] checkpatch: add fix option for LOGICAL_CONTINUATIONS
2020-12-16 · Acked-by -
STALE2064d
REVIEWED: 3 (3M) [patch 51/95] checkpatch: add fix option for ASSIGNMENT_CONTINUATIONS
2020-12-16 · Acked-by -
STALE2064d
REVIEWED: 3 (3M) [patch 50/95] checkpatch: fix unescaped left brace
2020-12-16 · Acked-by -
STALE2064d
REVIEWED: 3 (3M) [patch 49/95] checkpatch: avoid COMMIT_LOG_LONG_LINE warning for signature tags
2020-12-16 · Acked-by -
STALE2064d
REVIEWED: 3 (3M) [patch 48/95] checkpatch: fix spelling errors and remove repeated word
2020-12-16 · Acked-by -
STALE2064d
REVIEWED: 3 (3M) [patch 47/95] checkpatch: improve email parsing
2020-12-16 · Suggested-by -
STALE2064d
REVIEWED: 3 (3M) [patch 47/95] checkpatch: improve email parsing
2020-12-16 · Acked-by -
STALE2064d
REVIEWED: 3 (3M) [patch 45/95] checkpatch: add fix option for GERRIT_CHANGE_ID
2020-12-16 · Acked-by -
STALE2064d
REVIEWED: 3 (3M) [patch 43/95] checkpatch: add a fixer for missing newline at eof
2020-12-16 · Acked-by -
STALE2064d
REVIEWED: 3 (3M) [patch 42/95] checkpatch: extend attributes check to handle more patterns
2020-12-16 · Suggested-by -
STALE2064d
REVIEWED: 3 (3M) [patch 42/95] checkpatch: extend attributes check to handle more patterns
2020-12-16 · Acked-by -
STALE2064d
REVIEWED: 3 (3M) [patch 39/95] checkpatch: ignore generated CamelCase defines and enum values
2020-12-16 · Suggested-by -
STALE2064d
REVIEWED: 3 (3M) [patch 39/95] checkpatch: ignore generated CamelCase defines and enum values
2020-12-16 · Acked-by -
STALE2064d
REVIEWED: 3 (3M) [patch 38/95] checkpatch: fix false positives in REPEATED_WORD warning
2020-12-16 · Acked-by -
STALE2064d
REVIEWED: 3 (3M) [patch 37/95] checkpatch: add new exception to repeated word check
2020-12-16 · Suggested-by -
STALE2064d
REVIEWED: 3 (3M) [patch 37/95] checkpatch: add new exception to repeated word check
2020-12-16 · Acked-by -
DORMANTno replies
REVIEWED: 3 (3M) [patch 133/156] checkpatch: add new warnings to author signoff checks.
2020-10-16 · Suggested-by -
DORMANTno replies
REVIEWED: 3 (3M) [patch 133/156] checkpatch: add new warnings to author signoff checks.
2020-10-16 · Acked-by -
DORMANTno replies
REVIEWED: 3 (3M) [patch 132/156] checkpatch: fix false positive on empty block comment lines
2020-10-16 · Acked-by -
DORMANTno replies
[patch 131/156] checkpatch: fix multi-statement macro checks for while blocks.
2020-10-16 · Suggested-by -
DORMANTno replies
REVIEWED: 5 (5M) [patch 129/156] checkpatch: extend author Signed-off-by check for split From: header
2020-10-16 · Suggested-by -
DORMANTno replies
REVIEWED: 5 (5M) [patch 129/156] checkpatch: extend author Signed-off-by check for split From: header
2020-10-16 · Acked-by -
DORMANTno replies
[patch 124/156] const_structs.checkpatch: add phy_ops
2020-10-16 · Suggested-by -
DORMANTno replies
REVIEWED: 3 (3M) [patch 121/156] checkpatch: add --kconfig-prefix
2020-10-16 · Acked-by -
STALE2141d
REVIEWED: 1 (0M) [patch 5/9] lib/string.c: implement stpcpy
2020-09-26 · Suggested-by -
STALE2139d
[patch 01/15] mailmap: add older email addresses for Kees Cook
2020-09-19 · Reported-by -
STALE2188d
REVIEWED: 3 (3M) [patch 094/165] checkpatch: fix CONST_STRUCT when const_structs.checkpatch is missing
2020-08-12 · Acked-by -
STALE2191d
REVIEWED: 19 (19M) [patch 022/163] mm, treewide: rename kzfree() to kfree_sensitive()
2020-08-07 · Suggested-by -
STALE2247d
REVIEWED: 19 (19M) [PATCH v5 2/2] mm, treewide: Rename kzfree() to kfree_sensitive()
2020-06-16 · Suggested-by -
STALE2246d
REVIEWED: 19 (19M) [PATCH v4 2/3] mm, treewide: Rename kzfree() to kfree_sensitive()
2020-06-16 · Suggested-by -
STALE2253d
REVIEWED: 3 (3M) [patch 06/25] checkpatch: correct check for kernel parameters doc
2020-06-11 · Acked-by -
STALE2051d
REVIEWED: 3 (3M) [patch 07/15] checkpatch: fix a typo in the regex for $allocFunctions
2020-04-21 · Acked-by -
STALE2248d
[PATCH 1/2] mm, treewide: Rename kzfree() to kfree_sensitive()
2020-04-13 · Suggested-by -
STALE2314d
REVIEWED: 3 (3M) [patch 135/166] checkpatch: check proper licensing of Devicetree bindings
2020-04-07 · Acked-by -
STALE2314d
REVIEWED: 3 (3M) [patch 129/166] checkpatch: support "base-commit:" format
2020-04-07 · Suggested-by -
STALE2314d
REVIEWED: 3 (3M) [patch 129/166] checkpatch: support "base-commit:" format
2020-04-07 · Acked-by -
STALE2314d
REVIEWED: 3 (3M) [patch 128/166] checkpatch: check SPDX tags in YAML files
2020-04-07 · Acked-by -
DORMANTno replies
REVIEWED: 3 (3M) [patch 08/15] scripts/get_maintainer.pl: deprioritize old Fixes: addresses
2020-02-21 · Acked-by -
STALE2592d
[PATCH v3 2/5] nds32: Use the correct style for SPDX License Identifier
2019-04-16 · Suggested-by -
DORMANTno replies
Re: [PATCH] mm/memblock: replace u64 with phys_addr_t where appropriate
2018-07-05 · Suggested-by -
STALE2960d
Re: [PATCH] mm/memblock: replace u64 with phys_addr_t where appropriate
2018-07-04 · Suggested-by -
STALE3198d
REVIEWED: 3 (3M) Re: [PATCH] mm/page_alloc: Avoid KERN_CONT uses in warn_alloc
2017-11-09 · Acked-by