Reviews by aliceryhl@google.com
· linux-mm
All review-attestation trailers
(Reviewed-by / Acked-by /
Tested-by / Reported-by /
Suggested-by / Co-developed-by /
Reported-and-tested-by)
by this address on the linux-mm archive.
100 attestations · capped at 100 most-recent. (9 Acked-by, 15 Co-developed-by, 67 Reviewed-by, 8 Suggested-by, 1 Tested-by)
-
HOTtoday
REVIEWED: 12 (12M) Re: [PATCH v4 2/5] binder: Make shrinker rely solely on per-VMA lock
2026-08-07 · Reviewed-by -
HOTtoday
REVIEWED: 22 (22M) [PATCH v4 4/5] binder: Remove mmap_lock fallback
2026-08-06 · Reviewed-by -
COOLING4d
REVIEWED: 12 (12M) Re: [PATCH v3 4/5] binder: Remove mmap_lock fallback
2026-08-03 · Reviewed-by -
COOLING4d
REVIEWED: 12 (12M) Re: [PATCH v3 2/5] binder: Make shrinker rely solely on per-VMA lock
2026-08-03 · Reviewed-by -
DORMANTno replies
REVIEWED: 12 (12M) Re: [PATCH v19 3/8] rust: implement `ForeignOwnable` for `Owned`
2026-07-07 · Reviewed-by -
COLD32d
REVIEWED: 12 (12M) Re: [PATCH v19 4/8] rust: page: convert to `Ownable`
2026-07-07 · Reviewed-by -
WARM2d
REVIEWED: 12 (12M) [PATCH v7] rust: aref: make `AlwaysRefCounted::inc_ref` an associated function
2026-06-28 · Reviewed-by -
WARM3d
REVIEWED: 12 (12M) [PATCH v6] rust: aref: make `AlwaysRefCounted::inc_ref` an associated function
2026-06-28 · Reviewed-by -
COLD41d
REVIEWED: 12 (12M) [PATCH v5] rust: aref: make `AlwaysRefCounted::inc_ref` an associated function
2026-06-28 · Reviewed-by -
COLD32d
REVIEWED: 16 (16M) [PATCH v19 1/8] rust: alloc: add `KBox::into_non_null`
2026-06-26 · Reviewed-by -
COLD32d
REVIEWED: 34 (33M) [PATCH v19 5/8] rust: rename `AlwaysRefCounted` to `RefCounted`.
2026-06-26 · Suggested-by -
COLD32d
REVIEWED: 24 (23M) [PATCH v19 2/8] rust: types: Add Ownable/Owned types
2026-06-26 · Reviewed-by -
COLD43d
REVIEWED: 34 (33M) [PATCH v18 5/8] rust: rename `AlwaysRefCounted` to `RefCounted`.
2026-06-25 · Suggested-by -
COLD43d
REVIEWED: 16 (16M) [PATCH v18 1/8] rust: alloc: add `KBox::into_non_null`
2026-06-25 · Reviewed-by -
COLD43d
REVIEWED: 24 (23M) [PATCH v18 2/8] rust: types: Add Ownable/Owned types
2026-06-25 · Reviewed-by -
COLD44d
REVIEWED: 12 (12M) Re: [PATCH v17 02/10] rust: types: Add Ownable/Owned types
2026-06-16 · Reviewed-by -
COLD44d
REVIEWED: 12 (12M) Re: [PATCH v17 01/10] rust: alloc: add `KBox::into_non_null`
2026-06-16 · Reviewed-by -
DORMANTno replies
REVIEWED: 12 (12M) Re: [PATCH] maple_tree: remove undocumented CONFIG_MAPLE_RCU_DISABLED macro
2026-06-11 · Reviewed-by -
COLD32d
REVIEWED: 12 (12M) [PATCH v2 13/83] block: rust: add `command` getter to `Request`
2026-06-09 · Reviewed-by -
COLD32d
REVIEWED: 12 (12M) [PATCH v2 06/83] block: rust: fix generation of bindings to `BLK_STS_.*`
2026-06-09 · Reviewed-by -
COLD32d
REVIEWED: 12 (12M) [PATCH v2 21/83] block: rust: add Request::sectors() method
2026-06-09 · Reviewed-by -
COLD32d
REVIEWED: 12 (12M) [PATCH v2 22/83] block: rust: mq: add max_hw_discard_sectors support to GenDiskBuilder
2026-06-09 · Reviewed-by -
COLD32d
REVIEWED: 12 (12M) [PATCH v2 28/83] block: rust: mq: add Request::end() method for custom status codes
2026-06-09 · Reviewed-by -
COLD32d
REVIEWED: 12 (12M) [PATCH v2 15/83] block: rust: add `TagSet` flags
2026-06-09 · Reviewed-by -
COLD32d
REVIEWED: 12 (12M) [PATCH v2 03/83] block: rnull: adopt new formatting guidelines
2026-06-09 · Reviewed-by -
COLD32d
REVIEWED: 12 (12M) [PATCH v2 14/83] block: rust: mq: use GFP_KERNEL from prelude
2026-06-09 · Reviewed-by -
COLD44d
REVIEWED: 34 (33M) [PATCH v17 06/10] rust: rename `AlwaysRefCounted` to `RefCounted`.
2026-06-04 · Suggested-by -
STALE71d
REVIEWED: 12 (12M) Re: [PATCH] rust: page: mark Page::nid as inline
2026-05-29 · Reviewed-by -
DORMANTno replies
REVIEWED: 16 (16M) [PATCH v3] rust: maple_tree: implement Send and Sync for MapleTree
2026-05-11 · Reviewed-by -
STALE91d
REVIEWED: 12 (12M) Re: [PATCH] maple_tree: document that "last" in mtree_insert_range() is inclusive
2026-05-07 · Reviewed-by -
STALE105d
REVIEWED: 15 (15M) [PATCH v11 1/5] mm/vmalloc: extract vm_area_free_pages() helper from vfree()
2026-04-20 · Reviewed-by -
STALE110d
REVIEWED: 15 (15M) [PATCH v10 1/4] mm/vmalloc: extract vm_area_free_pages() helper from vfree()
2026-04-04 · Reviewed-by -
STALE123d
REVIEWED: 15 (15M) [PATCH v9 1/4] mm/vmalloc: extract vm_area_free_pages() helper from vfree()
2026-04-01 · Reviewed-by -
STALE129d
REVIEWED: 12 (12M) [PATCH v8 1/6] mm/vmalloc: extract vm_area_free_pages() helper from vfree()
2026-03-27 · Reviewed-by -
STALE136d
REVIEWED: 12 (12M) [PATCH v7 1/6] mm/vmalloc: extract vm_area_free_pages() helper from vfree()
2026-03-24 · Reviewed-by -
STALE139d
REVIEWED: 12 (12M) [PATCH v6 1/6] mm/vmalloc: extract vm_area_free_pages() helper from vfree()
2026-03-21 · Reviewed-by -
STALE139d
REVIEWED: 12 (12M) Re: [PATCH v5 1/3] mm/vmalloc: extract vm_area_free_pages() helper from vfree()
2026-03-17 · Reviewed-by -
STALE66d
REVIEWED: 12 (12M) Re: [PATCH 25/79] block: rust: mq: add Request::end() method for custom status codes
2026-03-16 · Reviewed-by -
STALE66d
REVIEWED: 12 (12M) Re: [PATCH 19/79] block: rust: mq: add max_hw_discard_sectors support to GenDiskBuilder
2026-03-16 · Reviewed-by -
STALE66d
REVIEWED: 12 (12M) Re: [PATCH 18/79] block: rust: add Request::sectors() method
2026-03-16 · Reviewed-by -
STALE66d
REVIEWED: 12 (12M) Re: [PATCH 12/79] block: rust: add `TagSet` flags
2026-03-16 · Reviewed-by -
STALE66d
REVIEWED: 12 (12M) Re: [PATCH 11/79] block: rust: mq: use GFP_KERNEL from prelude
2026-03-16 · Reviewed-by -
STALE66d
REVIEWED: 12 (12M) Re: [PATCH 10/79] block: rust: add `command` getter to `Request`
2026-03-16 · Reviewed-by -
STALE66d
REVIEWED: 12 (12M) Re: [PATCH 04/79] block: rust: fix generation of bindings to `BLK_STS_.*`
2026-03-16 · Reviewed-by -
STALE66d
REVIEWED: 12 (12M) Re: [PATCH 01/79] block: rnull: adopt new formatting guidelines
2026-03-16 · Reviewed-by -
STALE159d
REVIEWED: 34 (33M) [PATCH v16 03/10] rust: rename `AlwaysRefCounted` to `RefCounted`.
2026-02-24 · Suggested-by -
STALE165d
REVIEWED: 34 (33M) [PATCH v15 2/9] rust: rename `AlwaysRefCounted` to `RefCounted`.
2026-02-20 · Suggested-by -
STALE182d
REVIEWED: 7 (7M) [PATCH v14 2/9] rust: rename `AlwaysRefCounted` to `RefCounted`.
2026-02-04 · Suggested-by -
STALE130d
[PATCH v2 3/3] build: rust: provide an option to inline C helpers into Rust
2026-02-03 · Co-developed-by -
STALE201d
REVIEWED: 10 (9M) [PATCH v6] rust: iommu: add io_pgtable abstraction
2026-01-18 · Co-developed-by -
STALE206d
REVIEWED: 12 (12M) Re: [PATCH] rust: fix typo in bindings
2026-01-13 · Reviewed-by -
STALE202d
REVIEWED: 9 (9M) [PATCH v5] io: add io_pgtable abstraction
2026-01-13 · Co-developed-by -
STALE230d
REVIEWED: 2 (2M) [PATCH v4] io: add io_pgtable abstraction
2025-12-19 · Co-developed-by -
STALE213d
[PATCH 4/4] build: rust: provide an option to inline C helpers into Rust
2025-12-02 · Co-developed-by -
STALE206d
REVIEWED: 12 (12M) Re: [PATCH v3 0/4] initial work on making VMA flags a bitmap
2025-11-25 · Acked-by -
STALE187d
[PATCH v13 2/4] rust: `AlwaysRefCounted` is renamed to `RefCounted`.
2025-11-17 · Suggested-by -
STALE237d
[PATCH v3] io: add io_pgtable abstraction
2025-11-12 · Co-developed-by -
STALE301d
Re: [PATCH] mm: use enum for vm_flags
2025-10-08 · Co-developed-by -
STALE305d
REVIEWED: 12 (12M) Re: [linux-next:master 13069/13300] error[E0425]: cannot find value `VM_MERGEABLE` in crate `bindings`
2025-10-02 · Tested-by -
STALE282d
[PATCH v12 2/4] `AlwaysRefCounted` is renamed to `RefCounted`.
2025-10-01 · Suggested-by -
STALE316d
[PATCH v6 2/2] rust: zpool: add abstraction for zpool drivers
2025-09-23 · Co-developed-by -
STALE316d
[PATCH v6 0/2] rust: zpool: add API for C and Rust
2025-09-23 · Co-developed-by -
STALE321d
REVIEWED: 12 (12M) Re: [PATCH] rust: maple_tree: fix intra-doc link
2025-09-12 · Reviewed-by -
DORMANTno replies
[PATCH v5 2/2] rust: zpool: add abstraction for zpool drivers
2025-08-29 · Co-developed-by -
STALE344d
[PATCH v5 0/2] rust: zpool: add abstraction for zpool drivers
2025-08-29 · Co-developed-by -
STALE349d
REVIEWED: 12 (12M) Re: [PATCH] rust: alloc: add missing trait item MIN_ALIGN to Cmalloc
2025-08-24 · Reviewed-by -
STALE336d
[PATCH v4 2/2] rust: zpool: add abstraction for zpool drivers
2025-08-23 · Co-developed-by -
STALE336d
[PATCH v4 0/2] rust: zpool: add abstraction for zpool drivers
2025-08-23 · Co-developed-by -
STALE351d
[PATCH v3] rust: zpool: add abstraction for zpool drivers
2025-08-22 · Co-developed-by -
STALE352d
[PATCH v2] rust: zpool: add abstraction for zpool drivers
2025-08-21 · Co-developed-by -
STALE354d
REVIEWED: 12 (12M) Re: [PATCH] rust: alloc: add ARCH_KMALLOC_MINALIGN to bindgen blocklist
2025-08-18 · Reviewed-by -
DORMANTno replies
REVIEWED: 12 (12M) Re: [PATCH] rust: alloc: fix missing import needed for `rusttest`
2025-08-17 · Acked-by -
STALE352d
REVIEWED: 12 (12M) Re: [PATCH 3/7] rust: mm: update ARef and AlwaysRefCounted imports from sync::aref
2025-08-15 · Acked-by -
STALE352d
REVIEWED: 12 (12M) Re: [PATCH] rust: mm: Mark VmaNew as transparent
2025-08-12 · Reviewed-by -
DORMANTno replies
REVIEWED: 27 (27M) [PATCH v15 4/4] rust: support large alignments in allocations
2025-08-06 · Acked-by -
STALE367d
REVIEWED: 27 (27M) [PATCH v15 3/4] rust: add support for NUMA ids in allocations
2025-08-06 · Acked-by -
STALE372d
REVIEWED: 27 (27M) [PATCH v14 4/4] rust: support large alignments in allocations
2025-07-30 · Acked-by -
STALE372d
REVIEWED: 27 (27M) [PATCH v14 3/4] rust: add support for NUMA ids in allocations
2025-07-30 · Acked-by -
STALE374d
REVIEWED: 12 (12M) Re: [PATCH v13 4/4] rust: support large alignments in allocations
2025-07-24 · Acked-by -
STALE374d
REVIEWED: 12 (12M) Re: [PATCH v13 3/4] rust: add support for NUMA ids in allocations
2025-07-24 · Acked-by -
STALE537d
REVIEWED: 12 (12M) Re: [PATCH 2/6] rust: page: Convert to Ownable
2025-02-03 · Reviewed-by -
STALE537d
REVIEWED: 12 (12M) Re: [PATCH 3/6] rust: page: Make with_page_mapped() and with_pointer_into_page() public
2025-02-03 · Reviewed-by -
STALE537d
REVIEWED: 12 (12M) Re: [PATCH 4/6] rust: addr: Add a module to declare core address types
2025-02-03 · Reviewed-by -
DORMANTno replies
REVIEWED: 13 (12M) [PATCH v4 2/2] mm/memfd: Use strncpy_from_user() to read memfd name
2025-01-10 · Reviewed-by -
STALE575d
REVIEWED: 13 (12M) [PATCH v4 1/2] mm/memfd: Refactor and cleanup the logic in memfd_create()
2025-01-10 · Reviewed-by -
DORMANTno replies
REVIEWED: 12 (12M) Re: [RFC PATCH v2 2/2] selftests/memfd: Add tests for F_SEAL_FUTURE_EXEC
2025-01-10 · Reviewed-by -
STALE575d
REVIEWED: 12 (12M) Re: [PATCH v3 1/2] mm/memfd: Refactor and cleanup the logic in memfd_create()
2025-01-10 · Reviewed-by -
STALE575d
REVIEWED: 12 (12M) [PATCH v3 2/2] mm/memfd: Use strncpy_from_user() to read memfd name
2025-01-09 · Reviewed-by -
STALE576d
REVIEWED: 12 (12M) Re: [PATCH v2 2/2] mm/memfd: Use strncpy_from_user() to read memfd name
2025-01-08 · Reviewed-by -
STALE571d
REVIEWED: 12 (12M) Re: [PATCH v2] rust: generalize userSliceReader to support any Vec
2025-01-08 · Reviewed-by -
STALE630d
LANDED: 17 (16M) [PATCH v9 27/29] rust: alloc: update module comment of alloc.rs
2024-10-04 · Reviewed-by -
STALE630d
LANDED: 17 (16M) [PATCH v9 26/29] rust: str: test: replace `alloc::format`
2024-10-04 · Reviewed-by -
STALE630d
LANDED: 17 (16M) [PATCH v9 24/29] rust: alloc: implement `contains` for `Flags`
2024-10-04 · Reviewed-by -
STALE630d
LANDED: 17 (16M) [PATCH v9 23/29] rust: error: check for config `test` in `Error::name`
2024-10-04 · Reviewed-by -
STALE630d
LANDED: 17 (16M) [PATCH v9 22/29] rust: error: use `core::alloc::LayoutError`
2024-10-04 · Reviewed-by -
STALE630d
LANDED: 17 (16M) [PATCH v9 21/29] rust: alloc: add `Vec` to prelude
2024-10-04 · Reviewed-by -
STALE630d
LANDED: 17 (16M) [PATCH v9 20/29] rust: alloc: remove `VecExt` extension
2024-10-04 · Reviewed-by -
STALE630d
LANDED: 17 (16M) [PATCH v9 19/29] rust: treewide: switch to the kernel `Vec` type
2024-10-04 · Reviewed-by -
STALE630d
LANDED: 13 (12M) [PATCH v9 18/29] rust: alloc: implement `collect` for `IntoIter`
2024-10-04 · Reviewed-by -
STALE630d
LANDED: 17 (16M) [PATCH v9 17/29] rust: alloc: implement `IntoIterator` for `Vec`
2024-10-04 · Reviewed-by