__kmap_atomic_idx >= KM_TYPE_NR or < ZERO is a bug.
Report it even if CONFIG_DEBUG_HIGHMEM is not enabled.
That saves much debugging efforts.
Signed-off-by: Chintan Pandya <redacted>
---
include/linux/highmem.h | 6 +-----
1 file changed, 1 insertion(+), 5 deletions(-)
@@ -93,8 +93,8 @@ static inline int kmap_atomic_idx_push(void)#ifdef CONFIG_DEBUG_HIGHMEMWARN_ON_ONCE(in_irq()&&!irqs_disabled());-BUG_ON(idx>KM_TYPE_NR);#endif+BUG_ON(idx>=KM_TYPE_NR);returnidx;}
@@ -105,13 +105,9 @@ static inline int kmap_atomic_idx(void)staticinlinevoidkmap_atomic_idx_pop(void){-#ifdef CONFIG_DEBUG_HIGHMEMintidx=__this_cpu_dec_return(__kmap_atomic_idx);BUG_ON(idx<0);-#else-__this_cpu_dec(__kmap_atomic_idx);-#endif}#endif
--
Chintan Pandya
QUALCOMM INDIA, on behalf of Qualcomm Innovation Center, Inc. is a
member of the Code Aurora Forum, hosted by The Linux Foundation
--
To unsubscribe, send a message with 'unsubscribe linux-mm' in
the body to majordomo@kvack.org. For more info on Linux MM,
see: http://www.linux-mm.org/ .
Don't email: <a href=mailto:"dont@kvack.org"> email@kvack.org </a>
__kmap_atomic_idx >= KM_TYPE_NR or < ZERO is a bug.
Report it even if CONFIG_DEBUG_HIGHMEM is not enabled.
That saves much debugging efforts.
Please take considerably more care when preparing patch changelogs.
kmap_atomic() is a very commonly called function so we'll need much
more detail than this to justify adding overhead to it.
I don't think CONFIG_DEBUG_HIGHMEM really needs to exist. We could do
s/CONFIG_DEBUG_HIGHMEM/CONFIG_DEBUG_VM/g and perhaps your secret bug
whatever it was would have been found more easily.
--
To unsubscribe, send a message with 'unsubscribe linux-mm' in
the body to majordomo@kvack.org. For more info on Linux MM,
see: http://www.linux-mm.org/ .
Don't email: <a href=mailto:"dont@kvack.org"> email@kvack.org </a>
__kmap_atomic_idx >= KM_TYPE_NR or < ZERO is a bug.
Report it even if CONFIG_DEBUG_HIGHMEM is not enabled.
That saves much debugging efforts.
Please take considerably more care when preparing patch changelogs.
kmap_atomic() is a very commonly called function so we'll need much
more detail than this to justify adding overhead to it.
I don't think CONFIG_DEBUG_HIGHMEM really needs to exist. We could do
s/CONFIG_DEBUG_HIGHMEM/CONFIG_DEBUG_VM/g and perhaps your secret bug
whatever it was would have been found more easily.
Agreed, it would be nice to fold DEBUG_HIGHMEM into DEBUG_VM. However
you'd still need some kind of intermediate option as DEBUG_VM must still
exist if !HIGHMEM.
Thanks,
Davidlohr
--
To unsubscribe, send a message with 'unsubscribe linux-mm' in
the body to majordomo@kvack.org. For more info on Linux MM,
see: http://www.linux-mm.org/ .
Don't email: <a href=mailto:"dont@kvack.org"> email@kvack.org </a>
__kmap_atomic_idx >= KM_TYPE_NR or < ZERO is a bug.
Report it even if CONFIG_DEBUG_HIGHMEM is not enabled.
That saves much debugging efforts.
Please take considerably more care when preparing patch changelogs.
kmap_atomic() is a very commonly called function so we'll need much
more detail than this to justify adding overhead to it.
I don't think CONFIG_DEBUG_HIGHMEM really needs to exist. We could do
s/CONFIG_DEBUG_HIGHMEM/CONFIG_DEBUG_VM/g and perhaps your secret bug
whatever it was would have been found more easily.
Agreed, it would be nice to fold DEBUG_HIGHMEM into DEBUG_VM. However
you'd still need some kind of intermediate option as DEBUG_VM must still
exist if !HIGHMEM.
Actually no, it's a lot more straightforward than I thought.
--
To unsubscribe, send a message with 'unsubscribe linux-mm' in
the body to majordomo@kvack.org. For more info on Linux MM,
see: http://www.linux-mm.org/ .
Don't email: <a href=mailto:"dont@kvack.org"> email@kvack.org </a>
__kmap_atomic_idx>= KM_TYPE_NR or< ZERO is a bug.
Report it even if CONFIG_DEBUG_HIGHMEM is not enabled.
That saves much debugging efforts.
Please take considerably more care when preparing patch changelogs.
Okay. I will prepare new commit message.
kmap_atomic() is a very commonly called function so we'll need much
more detail than this to justify adding overhead to it.
I don't think CONFIG_DEBUG_HIGHMEM really needs to exist. We could do
s/CONFIG_DEBUG_HIGHMEM/CONFIG_DEBUG_VM/g and perhaps your secret bug
whatever it was would have been found more easily.
Um, we didn't get bug directly hitting here.
__kmap_atomic_idx should not be equal to KM_TYPE_NR anyway. So, at least I will share that patch. For changing DEBUG_HIGHMEM to DEBUG_VM, I will work on it.
--
QUALCOMM INDIA, on behalf of Qualcomm Innovation Center, Inc. is a
member of the Code Aurora Forum, hosted by The Linux Foundation
--
To unsubscribe, send a message with 'unsubscribe linux-mm' in
the body to majordomo@kvack.org. For more info on Linux MM,
see: http://www.linux-mm.org/ .
Don't email: <a href=mailto:"dont@kvack.org"> email@kvack.org </a>