# Re: \[PATCH 2/6\] mm: Generalize SYS\_SUPPORTS\_HUGETLBFS (rename as ARCH\_SUPPORTS\_HUGETLBFS)

- From: Michael Ellerman \<mpe@ellerman.id.au\>
- Date: 2021-03-10 05:21:26 
- List: linux-mips
- Page: https://ratatoskr.run/linux-mips/2021/03/201280
- Thread: https://ratatoskr.run/linux-mm/2021/03/201280/t.md

```text
Anshuman Khandual [ref] writes:
> SYS_SUPPORTS_HUGETLBFS config has duplicate definitions on platforms that
> subscribe it. Instead, just make it a generic option which can be selected
> on applicable platforms. Also rename it as ARCH_SUPPORTS_HUGETLBFS instead.
> This reduces code duplication and makes it cleaner.
>
> Cc: Russell King <linux@armlinux.org.uk>
> Cc: Catalin Marinas <catalin.marinas@arm.com>
> Cc: Will Deacon <will@kernel.org>
> Cc: Thomas Bogendoerfer <tsbogend@alpha.franken.de>
> Cc: "James E.J. Bottomley" <James.Bottomley@HansenPartnership.com>
> Cc: Helge Deller <deller@gmx.de>
> Cc: Michael Ellerman <mpe@ellerman.id.au>
> Cc: Benjamin Herrenschmidt <benh@kernel.crashing.org>
> Cc: Paul Mackerras <redacted>
> Cc: Paul Walmsley <redacted>
> Cc: Palmer Dabbelt <palmer@dabbelt.com>
> Cc: Albert Ou <aou@eecs.berkeley.edu>
> Cc: Yoshinori Sato <ysato@users.sourceforge.jp>
> Cc: Rich Felker <dalias@libc.org>
> Cc: Alexander Viro <viro@zeniv.linux.org.uk>
> Cc: <redacted>
> Cc: <redacted>
> Cc: <redacted>
> Cc: <redacted>
> Cc: <redacted>
> Cc: <redacted>
> Cc: <redacted>
> Cc: <redacted>
> Signed-off-by: Anshuman Khandual <redacted>
> ---
>  arch/arm/Kconfig                       | 5 +----
>  arch/arm64/Kconfig                     | 4 +---
>  arch/mips/Kconfig                      | 6 +-----
>  arch/parisc/Kconfig                    | 5 +----
>  arch/powerpc/Kconfig                   | 3 ---
>  arch/powerpc/platforms/Kconfig.cputype | 6 +++---

Acked-by: Michael Ellerman <mpe@ellerman.id.au> (powerpc)

cheers
```
