linux-kernel-mentees archive · September 2025
277 messages across 97 threads, ordered by last activity .
-
STALE303d
[PATCH net-next] selftests/net: add tcp_port_share to .gitignore
2025-09-30 15:50 · 5 replies this month · Gopi Krishna Menon <hidden> -
STALE303d
[PATCH net v2] atm: Fix the cleanup on alloc_mpc failure in atm_mpoa_mpoad_attach
2025-09-30 15:13 · 5 replies this month · Deepak Sharma <hidden> -
STALE303d
[PATCH] net: atlantic: Use kmalloc_array to prevent overflow of dynamic size calculation
2025-09-30 13:12 · 4 replies this month · Bhanu Seshu Kumar Valluri <hidden> -
STALE303d
[PATCH v2] btrfs: Refactor allocation size calculation in kzalloc()
2025-09-30 10:09 · 1 reply this month · Mehdi Ben Hadj Khelifa <hidden> -
STALE303d
[PATCH] btrfs: Refactor allocation size calculation in kzalloc()
2025-09-30 09:26 · 2 replies this month · Mehdi Ben Hadj Khelifa <hidden> -
STALE282d
[PATCH] lib: cpu_rmap.c Refactor allocation size calculation in kzalloc()
2025-09-30 09:23 · 0 replies this month · Mehdi Ben Hadj Khelifa <hidden> -
STALE285d
[PATCH] init: Use kcalloc() instead of kzalloc()
2025-09-30 08:35 · 0 replies this month · Mehdi Ben Hadj Khelifa <hidden> -
STALE303d
REVIEWED: 4 (3M) [PATCH net v4] net: nfc: nci: Add parameter validation for packet data
2025-09-30 08:30 · 1 reply this month · Deepak Sharma <hidden> -
STALE303d
[PATCH] PCI: endpoint: pci-epf-test: Fix sleeping function being called from atomic context
2025-09-30 01:49 · 2 replies this month · Bhanu Seshu Kumar Valluri <hidden> -
STALE304d
[PATCH] mtd: jedec_probe: use struct_size() helper for cfiq allocation
2025-09-29 16:03 · 1 reply this month · Rahul Kumar <hidden> -
STALE304d
[PATCH] mtd: cfi: use struct_size() helper for cfiq allocation
2025-09-29 16:03 · 3 replies this month · Gopi Krishna Menon <hidden> -
STALE304d
[PATCH] mtd: rawnand: atmel: Fix error handling path in atmel_nand_controller_add_nands
2025-09-29 15:55 · 1 reply this month · Erick Karanja <hidden> -
STALE300d
[PATCH] selftests/bpf: Add -Wsign-compare C compilation flag
2025-09-29 15:03 · 4 replies this month · Mehdi Ben Hadj Khelifa <hidden> -
STALE305d
[PATCH] Fix the cleanup on alloc_mpc failure in atm_mpoa_mpoad_attach
2025-09-28 15:26 · 1 reply this month · Deepak Sharma <hidden> -
STALE306d
REVIEWED: 1 (0M) [PATCH net v3] ptp: Add a upper bound on max_vclocks
2025-09-26 22:40 · 3 replies this month · I Viswanath <hidden> -
STALE306d
REVIEWED: 1 (0M) [PATCH net v3] net: usb: Remove disruptive netif_wake_queue in rtl8150_set_multicast
2025-09-26 22:20 · 6 replies this month · I Viswanath <hidden> -
STALE289d
REVIEWED: 1 (0M) [PATCH v3] HID: cp2112: Add parameter validation to data length
2025-09-26 15:00 · 0 replies this month · Deepak Sharma <hidden> -
STALE307d
REVIEWED: 1 (0M) [PATCH RESEND v2] HID: cp2112: Add parameter validation to data length
2025-09-26 14:19 · 1 reply this month · Deepak Sharma <hidden> -
STALE307d
[PATCH v2] docs: perf: Fujitsu: Fix htmldocs build warnings and errors
2025-09-26 13:39 · 6 replies this month · Gopi Krishna Menon <hidden> -
STALE287d
LANDED: 5 (5M) [PATCH v3] drm/komeda: Convert logging in komeda_crtc.c to drm_* with drm_device parameter
2025-09-26 09:30 · 0 replies this month · Rahul Kumar <hidden> -
STALE307d
[PATCH v3 0/3] selftests/bpf: Prepare to add -Wsign-compare for bpf selftests
2025-09-26 08:00 · 8 replies this month · Mehdi Ben Hadj Khelifa <hidden> -
STALE307d
[PATCH RFC 0/4] Add XDP RX queue index metadata via kfuncs
2025-09-26 06:42 · 9 replies this month · Mehdi Ben Hadj Khelifa <hidden> -
STALE307d
[PATCH] i2c: i2c-mux: Simplify boolean assignment in i2c_mux_alloc
2025-09-25 21:41 · 1 reply this month · I Viswanath <hidden> -
STALE307d
[PATCH] docs: perf: cleanup fujitsu_uncore_pmu.rst and fix htmldocs warnings/errors
2025-09-25 20:06 · 1 reply this month · Gopi Krishna Menon <hidden> -
STALE308d
[PATCH bpf-next v2] selftests/bpf: Add -Wsign-compare C compilation flag
2025-09-25 11:58 · 1 reply this month · Mehdi Ben Hadj Khelifa <hidden> -
STALE308d
Re: [PATCH RFC 0/4] Add XDP RX queue index metadata via kfuncs
2025-09-25 11:03 · 1 reply this month · Jakub Sitnicki <jakub@cloudflare.com> -
STALE308d
Re: [PATCH RFC 0/4] Add XDP RX queue index metadata via kfuncs
2025-09-25 10:28 · 1 reply this month · Jakub Sitnicki <jakub@cloudflare.com> -
DORMANTno replies
subscribe
2025-09-25 09:55 · 0 replies this month · Ankan Biswas <hidden> -
STALE308d
Re: [PATCH RFC 0/4] Add XDP RX queue index metadata via kfuncs
2025-09-25 09:55 · 1 reply this month · Jakub Sitnicki <jakub@cloudflare.com> -
STALE308d
REVIEWED: 4 (3M) [PATCH RESEND net v3] net: nfc: nci: Add parameter validation for packet data
2025-09-25 08:45 · 1 reply this month · Deepak Sharma <hidden> -
STALE308d
[PATCH] net: usb: Remove disruptive netif_wake_queue in rtl8150_set_multicast
2025-09-25 06:02 · 14 replies this month · I Viswanath <hidden> -
STALE308d
[PATCH net] net: usb: remove rtl8150 driver
2025-09-24 19:18 · 5 replies this month · I Viswanath <hidden> -
STALE295d
[PATCH] driver/scsi/mpi3mr.h: Fix build warning for mpi3mr_start_watchdog
2025-09-24 16:06 · 0 replies this month · Bartlomiej Kubik <hidden> -
STALE309d
[PATCH] drm/tiny: Use kmalloc_array() instead of kmalloc()
2025-09-24 06:07 · 2 replies this month · Rahul Kumar <hidden> -
DORMANTno replies
REVIEWED: 1 (0M) [RFC PATCH net v2] ptp: Add a hard upper bound on max_vclocks
2025-09-23 16:06 · 0 replies this month · I Viswanath <hidden> -
STALE310d
[PATCH] HID: ft260: Use sysfs_emit to write formatted data to user buffer in sysfs show function.
2025-09-23 14:58 · 2 replies this month · Bhanu Seshu Kumar Valluri <hidden> -
STALE310d
[PATCH] drm/amd/amdgpu: use kmalloc_array instead of kmalloc
2025-09-23 13:47 · 1 reply this month · Moktar SELLAMI <hidden> -
DORMANTno replies
[PATCH] Fix the cleanup on alloc_mpc failure in atm_mpoa_mpoad_attach
2025-09-23 13:31 · 0 replies this month · Deepak Sharma <hidden> -
STALE296d
[PATCH v2] drm/gud: Use kmalloc_array() instead of kmalloc()
2025-09-23 08:53 · 0 replies this month · Mehdi Ben Hadj Khelifa <hidden> -
STALE310d
[PATCH] drm/gud: Use kmalloc_array() instead of kmalloc()
2025-09-23 08:20 · 3 replies this month · Mehdi Ben Hadj Khelifa <hidden> -
STALE310d
REVIEWED: 1 (0M) [RFC PATCH] mm/slab: Add size validation in kmalloc_array_* functions
2025-09-23 06:15 · 5 replies this month · I Viswanath <hidden> -
STALE310d
[PATCH] selftests: Fix Makefile to run targets even the ones in SKIP_TARGETS
2025-09-22 22:57 · 1 reply this month · I Viswanath <hidden> -
STALE311d
[PATCH v2] drm/amdgpu: Use kmalloc_array() instead of kmalloc()
2025-09-22 13:59 · 1 reply this month · Rahul Kumar <hidden> -
STALE311d
[PATCH] gfs2: add bounds check for rd_length in compute_bitstructs()
2025-09-22 11:34 · 1 reply this month · Kriish Sharma <hidden> -
STALE311d
[PATCH net] net/xfrm: Refuse to allocate xfrm_state with SPI value 0
2025-09-22 07:08 · 1 reply this month · Nikola Z. Ivanov <hidden> -
STALE215d
[PATCH RESEND] selftests/powerpc/pmu/: Add check_extended_reg_test to .gitignore
2025-09-22 00:45 · 0 replies this month · Gopi Krishna Menon <hidden> -
DORMANTno replies
[PATCH] mtd: rawnand: atmel: Fix error handling path in atmel_nand_controller_add_nands
2025-09-21 19:09 · 0 replies this month · Erick Karanja <hidden> -
STALE312d
[PATCH] fs/namespace.c: fix mountpath handling in do_lock_mount()
2025-09-21 14:23 · 1 reply this month · Ryan Chung <hidden> -
STALE313d
[PATCH v2] cpuidle: sysfs: Use sysfs_emit/sysfs_emit_at instead of sprintf/scnprintf
2025-09-20 11:07 · 1 reply this month · <hidden> -
STALE313d
REVIEWED: 1 (0M) [PATCH net v3] net: nfc: nci: Add parameter validation for packet data
2025-09-19 18:52 · 2 replies this month · Deepak Sharma <hidden> -
STALE297d
[RESEND PATCH] selftests/filesystems: Fix build warning on anon_inode_test
2025-09-19 10:50 · 0 replies this month · Ranganath V N <hidden> -
STALE315d
[PATCH] docs: driver-api: fix spelling of "buses".
2025-09-18 16:43 · 1 reply this month · Marneni PoornaChandu <hidden> -
STALE315d
[PATCH] drm/komeda: Convert logging in komeda_crtc.c to drm_* with drm_device parameter
2025-09-18 15:10 · 1 reply this month · Rahul Kumar <hidden> -
STALE315d
[PATCH v2] net: nfc: nc: Add parameter validation for packet data
2025-09-18 02:38 · 2 replies this month · Deepak Sharma <hidden> -
STALE299d
[PATCH] drm/msm: Add NULL check in vm_op_enqueue
2025-09-17 18:46 · 0 replies this month · Gopi Krishna Menon <hidden> -
STALE315d
[PATCH] drm/amdgpu: Use kmalloc_array() instead of kmalloc()
2025-09-17 18:25 · 1 reply this month · Rahul Kumar <hidden> -
DORMANTno replies
[PATCH] net: nfc: nc: Add parameter validation for packet data
2025-09-17 11:41 · 0 replies this month · Deepak Sharma <hidden> -
STALE316d
LANDED [PATCH] drm/ssd130x: Use kmalloc_array() instead of kmalloc()
2025-09-17 10:49 · 2 replies this month · James Flowers <hidden> -
STALE289d
LANDED: 1 (0M) [PATCH v4] riscv: dts: spacemit: add UART pinctrl combinations
2025-09-17 09:10 · 5 replies this month · Hendrik Hamerlinck <hidden> -
STALE316d
[PATCH v3] riscv: dts: spacemit: add UART pinctrl combinations
2025-09-17 06:39 · 3 replies this month · Hendrik Hamerlinck <hidden> -
STALE286d
[PATCH] drivers: core: Fix synchronization of removal of device with rpm work
2025-09-17 03:11 · 0 replies this month · Deepak Sharma <hidden> -
STALE316d
[PATCH] selftests/Makefile: include $(INSTALL_DEP_TARGETS) in clean target to clean net/lib dependency
2025-09-16 23:10 · 4 replies this month · Nai-Chen Cheng <hidden> -
STALE317d
[PATCH] sound/core/seq : fix data-race in snd_seq_fifo_cell_out/snd_seq_fifo_poll_wait
2025-09-16 11:05 · 1 reply this month · <hidden> -
DORMANTno replies
[PATCH v2] HID: cp2112: Add parameter validation to data length
2025-09-16 05:12 · 0 replies this month · Deepak Sharma <hidden> -
STALE317d
[PATCH] drm/amd/display: Use kmalloc_array() instead of kmalloc()
2025-09-16 04:09 · 2 replies this month · James Flowers <hidden> -
DORMANTno replies
[PATCH] HID: cp2112: Add parameter validation to data length
2025-09-16 00:56 · 0 replies this month · Deepak Sharma <hidden> -
STALE317d
[PATCH] Documentation/wmi: Fix Typo in lenovo-wmi-gamezone
2025-09-15 21:54 · 3 replies this month · rakuram <hidden> -
STALE317d
[PATCH] Documentation/wmi: Fix Typo Error in doc
2025-09-15 21:49 · 2 replies this month · Alperen Aksu <hidden> -
DORMANTno replies
[PATCH] usb: hub: Fix RPM teardown on usb_disconnect
2025-09-15 17:26 · 0 replies this month · Deepak Sharma <hidden> -
STALE318d
[PATCH v2] riscv: dts: spacemit: add UART pinctrl combinations
2025-09-15 14:26 · 2 replies this month · Hendrik Hamerlinck <hidden> -
STALE294d
[PATCH v3] Input: bcm5974 - Driver cleanup by replacing dprintk with dev_dbg
2025-09-15 14:14 · 1 reply this month · Bhanu Seshu Kumar Valluri <hidden> -
STALE318d
[PATCH v4 RESEND] drm: Replace the deprecated DRM_* logging macros in gem helper files
2025-09-15 10:38 · 5 replies this month · Athul Raj Kollareth <hidden> -
STALE318d
[PATCH] net/smc: replace strncpy with strscpy for ib_name
2025-09-15 09:44 · 7 replies this month · Kriish Sharma <hidden> -
STALE319d
[PATCH] Bluetooth: hci_bcm: use str_low_high() helper instead of ternary operator
2025-09-14 06:56 · 0 replies this month · Nai-Chen Cheng <hidden> -
STALE321d
[PATCH] riscv: dts: spacemit: add UART pinctrl combinations
2025-09-12 13:57 · 2 replies this month · Hendrik Hamerlinck <hidden> -
STALE322d
[PATCH] selftests/filesystems: Fix build warning on anon_inode_test
2025-09-10 18:06 · 1 reply this month · Ranganath V N <hidden> -
STALE323d
[PATCH] selftests/net: fix unused return value warnings in ksft.h
2025-09-10 11:16 · 4 replies this month · Nai-Chen Cheng <hidden> -
STALE323d
Re: [PATCH v2] mtd: sm_ftl: replace strncpy with memcpy
2025-09-10 07:03 · 5 replies this month · Miquel Raynal <miquel.raynal@bootlin.com> -
STALE323d
Thank you for the insightful pre-requisite tasks
2025-09-09 20:43 · 1 reply this month · bhanuseshukumar <hidden> -
STALE324d
[PATCH v2] mtd: sm_ftl: replace strncpy with memcpy
2025-09-09 11:27 · 1 reply this month · Rahul Kumar <hidden> -
DORMANTno replies
[PATCH] wireless/ti/wl1251: Replace strncpy with strscpy in fw_version
2025-09-09 11:09 · 0 replies this month · Rahul Kumar <hidden> -
STALE325d
[PATCH v2] selftests/arm64: Fix grammatical error in string literals
2025-09-08 15:55 · 1 reply this month · Nikola Z. Ivanov <hidden> -
STALE325d
[PATCH 0/3] kselftest/arm64: Cleanups and readability fixes
2025-09-08 15:55 · 1 reply this month · <hidden> -
STALE326d
[PATCH v4] futex: don't leak robust_list pointer on exec race
2025-09-07 10:26 · 3 replies this month · Pranav Tyagi <hidden> -
STALE327d
[PATCH] ALSA: cs4281: Send the PCM period elapsed notification properly
2025-09-06 17:56 · 1 reply this month · Chandra Mohan Sundar <hidden> -
STALE328d
REVIEWED: 5 (4M) [PATCH v3] xfs: Replace strncpy with memcpy
2025-09-05 09:16 · 1 reply this month · Marcelo Moreira <hidden> -
STALE328d
[PATCH] Documentation/i2c: Add missing SPDX-License-Identifier tags
2025-09-04 22:46 · 1 reply this month · I Viswanath <hidden> -
STALE328d
[PATCH] pinctrl: spacemit: fix typo in PRI_TDI pin name
2025-09-04 19:35 · 2 replies this month · Hendrik Hamerlinck <hidden> -
STALE303d
[PATCH 1/1] ipv6: Check AF_UNSPEC in ip6_route_multipath_add()
2025-09-04 16:03 · 1 reply this month · Maksimilijan Marosevic <hidden> -
DORMANTno replies
[PATCH] selftests/powerpc/pmu/: Add check_extended_reg_test to .gitignore
2025-09-04 12:44 · 0 replies this month · Gopi Krishna Menon <hidden> -
STALE330d
[PATCH] mtd: sm_ftl: replace strncpy with memcpy
2025-09-03 14:28 · 1 reply this month · Rahul Kumar <hidden> -
STALE330d
[PATCH v2] Input: bcm5974 - Driver cleanup by replacing dprintk with dev_dbg
2025-09-03 06:41 · 1 reply this month · Bhanu Seshu Kumar Valluri <hidden> -
STALE330d
[PATCH] Input: bcm5974 - Driver cleanup by replacing dprintk with dev_dbg
2025-09-03 05:44 · 1 reply this month · bhanuseshukumar <hidden> -
STALE330d
[PATCH net-next] net: macb: Validate the value of base_time properly
2025-09-02 23:50 · 2 replies this month · Chandra Mohan Sundar <hidden> -
STALE330d
[PATCH v2] net/smc: Replace use of strncpy on NUL-terminated string with strscpy
2025-09-02 23:00 · 5 replies this month · James Flowers <hidden> -
STALE331d
[PATCH] selftests: net: fix spelling and grammar mistakes
2025-09-01 20:20 · 1 reply this month · Praveen Balakrishnan <hidden> -
STALE331d
[PATCH 0/5] iio: imu: New driver for InvenSense ICM-20948 9-Axis sensor
2025-09-01 19:41 · 7 replies this month · Bharadwaj Raju <hidden>