Reviews by mark.rutland@arm.com
· linux-kbuild
All review-attestation trailers
(Reviewed-by / Acked-by /
Tested-by / Reported-by /
Suggested-by / Co-developed-by /
Reported-and-tested-by)
by this address on the linux-kbuild archive.
42 attestations . (32 Acked-by, 1 Reported-by, 3 Reviewed-by, 6 Suggested-by)
-
STALE432d
REVIEWED: 7 (7M) Re: [PATCH 0/4] Make gcc-8.1 and binutils-2.30 the minimum version
2025-04-08 · Acked-by -
STALE432d
REVIEWED: 7 (7M) Re: [PATCH 4/4] arm64: drop binutils version checks
2025-04-08 · Acked-by -
STALE580d
REVIEWED: 7 (7M) Re: [RFC PATCH 02/28] Documentation: Bump minimum GCC version to 8.1
2024-09-27 · Acked-by -
STALE737d
REVIEWED: 7 (7M) Re: [PATCH] arm64: remove redundant 'if HAVE_ARCH_KASAN' in Kconfig
2024-07-15 · Acked-by -
STALE878d
LANDED: 12 (12M) [PATCH v3] kbuild: Use -fmin-function-alignment when available
2024-02-22 · Acked-by -
STALE882d
REVIEWED: 7 (7M) Re: [PATCH v2] kbuild: Use -fmin-function-alignment when available
2024-02-19 · Acked-by -
STALE849d
REVIEWED: 7 (7M) Re: [PATCH 05/11] arm64: Kconfig: Clean up tautological LLVM version checks
2024-01-26 · Acked-by -
STALE849d
REVIEWED: 7 (7M) Re: [PATCH 05/11] arm64: Kconfig: Clean up tautological LLVM version checks
2024-01-26 · Acked-by -
STALE1688d
REVIEWED: 7 (7M) [PATCH v3 02/25] kcsan: Remove redundant zero-initialization of globals
2021-11-30 · Acked-by -
STALE1688d
REVIEWED: 7 (7M) [PATCH v3 01/25] kcsan: Refactor reading of instrumented memory
2021-11-30 · Acked-by -
STALE1695d
REVIEWED: 7 (7M) Re: [PATCH v2 02/23] kcsan: Remove redundant zero-initialization of globals
2021-11-18 · Acked-by -
STALE1695d
REVIEWED: 7 (7M) Re: [PATCH v2 01/23] kcsan: Refactor reading of instrumented memory
2021-11-18 · Acked-by -
STALE1853d
REVIEWED: 7 (7M) Re: [PATCH v2 3/3] Kconfig: add ARCH_WANTS_NO_INSTR+CC_HAS_NO_PROFILE_FN_ATTR, depend on for GCOV and PGO
2021-06-22 · Acked-by -
STALE1930d
LANDED: 12 (12M) [PATCH v6 16/18] arm64: ftrace: use function_nocfi for ftrace_call
2021-04-08 · Acked-by -
STALE1930d
LANDED: 13 (12M) [PATCH v6 13/18] arm64: use function_nocfi with __pa_symbol
2021-04-08 · Acked-by -
STALE1930d
LANDED: 13 (12M) [PATCH v6 12/18] arm64: implement function_nocfi
2021-04-08 · Acked-by -
STALE1930d
LANDED: 13 (12M) [PATCH v6 11/18] psci: use function_nocfi for cpu_resume
2021-04-08 · Acked-by -
STALE1930d
LANDED: 13 (12M) [PATCH v6 03/18] mm: add generic function_nocfi macro
2021-04-08 · Acked-by -
STALE1932d
REVIEWED: 7 (7M) Re: [PATCH v5 16/18] arm64: ftrace: use function_nocfi for ftrace_call
2021-04-06 · Acked-by -
STALE1932d
REVIEWED: 7 (7M) Re: [PATCH v5 13/18] arm64: use function_nocfi with __pa_symbol
2021-04-06 · Acked-by -
STALE1932d
REVIEWED: 7 (7M) Re: [PATCH v5 12/18] arm64: implement function_nocfi
2021-04-06 · Acked-by -
STALE1932d
REVIEWED: 7 (7M) Re: [PATCH v5 11/18] psci: use function_nocfi for cpu_resume
2021-04-06 · Acked-by -
STALE1932d
REVIEWED: 7 (7M) Re: [PATCH v5 03/18] mm: add generic function_nocfi macro
2021-04-06 · Acked-by -
STALE2380d
REVIEWED: 15 (15M) [PATCH v4 09/10] locking/atomics, kcsan: Add KCSAN instrumentation
2019-11-14 · Reviewed-by -
STALE2441d
REVIEWED: 7 (7M) [PATCH v3 8/9] locking/atomics, kcsan: Add KCSAN instrumentation
2019-11-04 · Reviewed-by -
STALE2462d
REVIEWED: 7 (7M) Re: [PATCH v2 7/8] locking/atomics, kcsan: Add KCSAN instrumentation
2019-10-22 · Reviewed-by -
STALE2773d
REVIEWED: 7 (7M) [PATCH v13 09/25] arm64: move untagged_addr macro from uaccess.h to memory.h
2018-12-06 · Acked-by -
STALE2773d
[PATCH v13 07/25] kasan: rename kasan_zero_page to kasan_early_shadow_page
2018-12-06 · Suggested-by -
STALE2773d
[PATCH v13 13/25] kasan, arm64: fix up fault handling logic
2018-12-06 · Suggested-by -
STALE2785d
REVIEWED: 7 (7M) [PATCH v12 09/25] arm64: move untagged_addr macro from uaccess.h to memory.h
2018-11-27 · Acked-by -
STALE2785d
[PATCH v12 07/25] kasan: rename kasan_zero_page to kasan_early_shadow_page
2018-11-27 · Suggested-by -
STALE2785d
[PATCH v12 13/25] kasan, arm64: fix up fault handling logic
2018-11-27 · Suggested-by -
STALE2793d
REVIEWED: 7 (7M) Re: [PATCH v11 09/24] arm64: move untagged_addr macro from uaccess.h to memory.h
2018-11-23 · Acked-by -
STALE2793d
[PATCH v11 13/24] kasan, arm64: fix up fault handling logic
2018-11-19 · Suggested-by -
STALE2793d
[PATCH v11 07/24] kasan: rename kasan_zero_page to kasan_early_shadow_page
2018-11-19 · Suggested-by -
DORMANTno replies
[PATCH] Makefile: Fix CONFIG_CC_STACKPROTECTOR_AUTO to not enable SSP
2017-10-03 · Reported-by -
STALE3933d
REVIEWED: 7 (7M) Re: [PATCH] ARM64: dts: vexpress: Use a symlink to vexpress-v2m-rs1.dtsi from arch=arm
2015-10-12 · Acked-by -
STALE3961d
REVIEWED: 20 (19M) [PATCH v5] dtb: Create a common home for cross-architecture dtsi files.
2015-08-03 · Acked-by -
STALE3998d
REVIEWED: 20 (19M) [PATCH v4] dtb: Create a common home for cross-architecture dtsi files.
2015-08-03 · Acked-by -
STALE4005d
REVIEWED: 20 (19M) [PATCH v4] dtb: Create a common home for cross-architecture dtsi files.
2015-08-03 · Acked-by -
STALE4006d
REVIEWED: 7 (7M) Re: [PATCH v3] dtb: Create a common home for cross-architecture dtsi files.
2015-07-31 · Acked-by -
STALE4009d
REVIEWED: 7 (7M) Re: [PATCH v2] dtb: Create a common home for cross-architecture dtsi files.
2015-07-27 · Acked-by