Reviews by vasant.hegde@amd.com · linux-iommu

All review-attestation trailers (Reviewed-by / Acked-by / Tested-by / Reported-by / Suggested-by / Co-developed-by / Reported-and-tested-by) by this address on the linux-iommu archive.

100 attestations · capped at 100 most-recent. (2 Acked-by, 7 Co-developed-by, 87 Reviewed-by, 4 Suggested-by)

LastMessageTrailer
[PATCH v6 4/7] iommu/amd: Program guest-mode IRTEs for GAPPI wakeup when IRTE[IsRun] = 0
Sairaj Kodilkar REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
[PATCH v6 3/7] iommu/amd: KVM: SVM: Add explicit vCPU running state to IOMMU interface
Sairaj Kodilkar REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
[PATCH v6 2/7] iommu/amd: KVM: SVM: Rename ga_log_intr to wakeup_intr in IOMMU interface
Sairaj Kodilkar REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
[PATCH v6 1/7] iommu/amd: KVM: SVM: Rename cpu to apicid in IOMMU interface
Sairaj Kodilkar REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
Re: [PATCH] MAINTAINER: Make Vasant Hegde AMD IOMMU maintainer
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Acked-by
[PATCH v5 4/7] iommu/amd: Program guest-mode IRTEs for GAPPI wakeup when IRTE[IsRun] = 0
Sairaj Kodilkar SUPERSEDED: 1 review, 1 by a maintainer
Reviewed-by
[PATCH v5 3/7] iommu/amd: KVM: SVM: Add explicit vCPU running state to IOMMU interface
Sairaj Kodilkar SUPERSEDED: 1 review, 1 by a maintainer
Reviewed-by
[PATCH v5 2/7] iommu/amd: KVM: SVM: Rename ga_log_intr to wakeup_intr in IOMMU interface
Sairaj Kodilkar SUPERSEDED: 1 review, 1 by a maintainer
Reviewed-by
[PATCH v5 1/7] iommu/amd: KVM: SVM: Rename cpu to apicid in IOMMU interface
Sairaj Kodilkar SUPERSEDED: 1 review, 1 by a maintainer
Reviewed-by
Re: [PATCH v2 2/2] iommu/amd: Don't allocate kdump device table from DMA32
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
[PATCH v2 1/2] iommu/amd: Program device table when kdump reuse fails
Matt Fleming REVIEWED: 3 reviews, 2 by maintainers
Reviewed-by
Re: [PATCH 1/2] iommu/amd: Program device table when kdump reuse fails
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
Re: [PATCH v6 3/5] iommu/x86: Add architectural MSI reserved region helper
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
[PATCH v6 07/24] iommu/amd: Add support for AMD vIOMMU VF MMIO region
Suravee Suthikulpanit REVIEWED: 1 review, 1 by a maintainer
Co-developed-by
[PATCH v5 07/24] iommu/amd: Add support for AMD vIOMMU VF MMIO region
Suravee Suthikulpanit SUPERSEDED: 1 review, 1 by a maintainer
Co-developed-by
Re: [PATCH v4 2/4] iommu/amd: Remove iommu_ignore_device()
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
[PATCH v4 4/4] PCI/ATS: Mandate checking pci_ats_supported() before pci_prepare_ats()
Pranjal Shrivastava REVIEWED: 3 reviews, 2 by maintainers
Reviewed-by
[PATCH v4 3/4] iommu/amd: Fail probe on ATS configuration failure
Pranjal Shrivastava REVIEWED: 3 reviews, 2 by maintainers
Reviewed-by
[PATCH v4 2/4] iommu/amd: Remove iommu_ignore_device()
Pranjal Shrivastava
Suggested-by
[PATCH v4 1/4] iommu/amd: Refactor device probe and capability initialization
Pranjal Shrivastava REVIEWED: 2 reviews, 2 by maintainers
Reviewed-by
[PATCH v4 1/4] iommu/amd: Refactor device probe and capability initialization
Pranjal Shrivastava REVIEWED: 2 reviews, 2 by maintainers
Suggested-by
[PATCH 6.12.y 2/2] x86/sev: Fix broken SNP support with KVM module built-in
Sean Christopherson REVIEWED: 1 review, 0 by maintainers
Co-developed-by
[PATCH 6.12.y 1/2] iommu/amd: remove return value of amd_iommu_detect
Sean Christopherson REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
Re: [PATCH] iommu/amd: Fix ineffective error check in nested domain allocation
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
Re: [PATCH] iommu/amd: Do not reallocate GA log buffers on resume
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
Re: [PATCH v3 2/5] iommu/amd: Fix DTE clearing and rename iommu_ignore_device()
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
Re: [PATCH v3 1/5] iommu/amd: Refactor device probe and capability initialization
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
[PATCH v3 5/5] PCI/ATS: Mandate checking pci_ats_supported() before pci_prepare_ats()
Pranjal Shrivastava REVIEWED: 2 reviews, 1 by a maintainer
Reviewed-by
[PATCH v3 4/5] iommu/amd: Fail probe on ATS configuration failure
Pranjal Shrivastava SUPERSEDED: 1 review, 1 by a maintainer
Reviewed-by
[PATCH v3 3/5] iommu/amd: Split probe error paths to preserve IRQ remapping
Pranjal Shrivastava SUPERSEDED: 1 review, 1 by a maintainer
Reviewed-by
[PATCH v3 1/5] iommu/amd: Refactor device probe and capability initialization
Pranjal Shrivastava SUPERSEDED
Suggested-by
Re: [PATCH v2 3/5] iommu/amd: Split probe error paths to preserve IRQ remapping
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
Re: [PATCH v2 4/5] iommu/amd: Fail probe on ATS configuration failure
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
Re: [PATCH v2 5/5] PCI/ATS: Mandate checking pci_ats_supported() before pci_prepare_ats()
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
Re: [PATCH v4 4/7] iommu/amd: Program guest-mode IRTEs for GAPPI wakeup when IRTE[IsRun] = 0
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
Re: [PATCH v4 3/7] iommu/amd: KVM: SVM: Add explicit vCPU running state to IOMMU interface
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
Re: [PATCH v4 2/7] iommu/amd: KVM: SVM: Rename ga_log_intr to wakeup_intr in IOMMU interface
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
Re: [PATCH v4 1/7] iommu/amd: KVM: SVM: Rename cpu to apicid in IOMMU interface
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
[PATCH v2 1/5] iommu/amd: Refactor device probe and capability initialization
Pranjal Shrivastava SUPERSEDED
Suggested-by
[PATCH 07/24] iommu/amd: Add support for AMD vIOMMU VF MMIO region
Suravee Suthikulpanit SUPERSEDED
Co-developed-by
Re: [PATCH] iommu/amd: Put PCI device after handling PPR faults
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
Re: [PATCH] iommu/amd: Wait for completion instead of returning early in iommu_completion_wait()
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
[PATCH v2 3/3] iommu/amd: Dynamically verify Southbridge IOAPIC via PCI config space
Wei Wang REVIEWED: 2 reviews, 1 by a maintainer
Reviewed-by
[PATCH v2 2/3] iommu/amd: Fix false positive in SB IOAPIC IVRS validation
Wei Wang REVIEWED: 2 reviews, 1 by a maintainer
Reviewed-by
[PATCH v2 1/3] iommu/amd: Prevent SB IOAPIC from overriding IVRS validation errors
Wei Wang REVIEWED: 2 reviews, 1 by a maintainer
Reviewed-by
[PATCH v3 07/22] iommu/amd: Add support for AMD vIOMMU VF MMIO region
Suravee Suthikulpanit SUPERSEDED
Co-developed-by
[PATCH 6.12] iommu: Skip PASID validation for devices without PASID capability
Dmitrii Chervov REVIEWED: 2 reviews, 2 by maintainers
Reviewed-by
Re: [PATCH 0/5] Improve the invalidation path in AMD
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
Re: [PATCH v2 1/1] iommu/amd: Don't split flush for amd_iommu_domain_flush_all()
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
Re: [PATCH v1 3/3] iommu/amd: Dynamically verify Southbridge IOAPIC via PCI config space
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
Re: [PATCH v1 2/3] iommu/amd: Fix false positive in SB IOAPIC IVRS validation
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
Re: [PATCH v1 1/3] iommu/amd: Prevent SB IOAPIC from overriding IVRS validation errors
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
Re: [PATCH 1/2] MAINTAINERS: Add Vasant Hegde to reviewers of AMD IOMMU
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Acked-by
[PATCH v2 07/26] iommu/amd: Add support for AMD vIOMMU VF MMIO region
Suravee Suthikulpanit SUPERSEDED
Co-developed-by
Re: [PATCH v5 3/4] iommu_pt: add kunit config for 32-bit VA (amdv1_cfg_1)
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
Re: [PATCH v5 2/4] iommu_pt: support small VA for AMDv1
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
Re: [PATCH] iommu/amd: Explicitly bail from enable_iommus_vapic() when in legacy mode
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
Re: [PATCH] iommu/amd: Fix a stale comment about which legacy mode is user visible
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
Re: [PATCH] iommu/amd: Fix precedence order in set_dte_passthrough()
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
Re: [PATCH] iommu/amd: Fix precedence order in set_dte_passthrough()
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
[PATCH v5 4/4] iommu/amd: Adhere to IVINFO[VASIZE] for address limits
Ankit Soni REVIEWED: 2 reviews, 2 by maintainers
Reviewed-by
Re: [PATCH v4] iommu/amd: Invalidate IRT cache for DMA aliases
Vasant Hegde LANDED: 1 review, 1 by a maintainer
Reviewed-by
[PATCH v4 3/3] iommu/amd: Adhere to IVINFO[VASIZE] for address limits
Ankit Soni SUPERSEDED: 2 reviews, 2 by maintainers
Reviewed-by
Re: [PATCH] iommupt/amdv1: mark amdv1pt_install_leaf_entry as __always_inline
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
Re: [PATCH 2/2] iommu/amd: Fix illegal cap/mmio access in IOMMU debugfs
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
Re: [PATCH 1/2] iommu/amd: Fix illegal device-id access in IOMMU debugfs
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
[PATCH 07/22] iommu/amd: Add support for AMD vIOMMU VF MMIO region
Suravee Suthikulpanit SUPERSEDED
Co-developed-by
Re: [PATCH v3 2/2] iommu/amd: Adhere to IVINFO[VASIZE] for address limits
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
Re: [PATCH v3 1/2] iommu/amd: Remove PT_FEAT_DYNAMIC_TOP from PT_FORCE_ENABLED_FEATURES
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
Re: [PATCH] iommu/amd: Block identity domain when SNP enabled
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
Re: [PATCH v3] iommu: Fix mapping check for 0x0 to avoid re-mapping it
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
Re: [PATCH V2] iommu/sva: Fix crash in iommu_sva_unbind_device()
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
Re: [PATCH rc 2/2] iommupt: Fix short gather if the unmap goes into a large mapping
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
Re: [PATCH rc 1/2] iommu: Do not call drivers for empty gathers
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
Re: [PATCH] iommu/amd: Add NUMA node affinity for IOMMU log buffers
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
[PATCH AUTOSEL 6.19-6.6] iommu/amd: move wait_on_sem() out of spinlock
Sasha Levin REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
Re: [PATCH v2] iommu/amd: serialize sequence allocation under concurrent TLB invalidations
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
Re: [PATCH] iommu/amd: Fix type of type parameter to amd_iommufd_hw_info()
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
Re: [PATCH v5 1/2] iommupt: Do not set C-bit on MMIO backed PTEs
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
[PATCH v6 05/13] iommufd: Introduce data struct for AMD nested domain allocation
Suravee Suthikulpanit REVIEWED: 3 reviews, 2 by maintainers
Reviewed-by
[PATCH v6 03/13] iommu/amd: Make amd_iommu_make_clear_dte() non-static inline
Suravee Suthikulpanit REVIEWED: 3 reviews, 2 by maintainers
Reviewed-by
[PATCH v6 02/13] iommu/amd: Rename DEV_DOMID_MASK to DTE_DOMID_MASK
Suravee Suthikulpanit REVIEWED: 3 reviews, 2 by maintainers
Reviewed-by
[PATCH v6 01/13] iommu/amd: Add support for hw_info for iommu capability query
Suravee Suthikulpanit REVIEWED: 3 reviews, 2 by maintainers
Reviewed-by
Re: [PATCH v2] iommu: simplify list initialization in iommu_create_device_direct_mappings() and iommu_group_show_resv_regions()
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
Re: [PATCH] iommu/amd: move wait_on_sem() out of spinlock
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
Re: [PATCH kernel v3 3/4] iommu/amd: Report SEV-TIO support
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
Re: [PATCH] iommupt: Fix unlikely flows in increase_top()
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
[PATCH v2 2/2] amd/iommu: Make protection domain ID functions non-static
Sairaj Kodilkar REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
[PATCH v2 1/2] amd/iommu: Preserve domain ids inside the kdump kernel
Sairaj Kodilkar REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
Re: [PATCH v2] iommu/amd: Relay __modify_irte_ga() error in modify_irte_ga()
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
Re: [PATCH] iommu/amd: Propagate the error code returned by __modify_irte_ga() in modify_irte_ga()
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
[PATCH v3 3/3] iommu: Allow drivers to say if they use report_iommu_fault()
Jason Gunthorpe REVIEWED: 3 reviews, 3 by maintainers
Reviewed-by
[PATCH v3 2/3] iommu/amd: Don't call report_iommu_fault()
Jason Gunthorpe REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
Re: [PATCH 1/2] amd/iommu: Preserve domain ids inside the kdump kernel
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
Re: [PATCH 2/2] amd/iommu: Make protection domain ID functions non-static
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
Re: [PATCH v5] iommu/amd: Enhance "Completion-wait Time-out" error message
Vasant Hegde REVIEWED: 1 review, 1 by a maintainer
Reviewed-by
[PATCH v5 02/14] iommu/amd: Make amd_iommu_pdom_id_alloc() non-static
Suravee Suthikulpanit SUPERSEDED: 3 reviews, 2 by maintainers
Reviewed-by
[PATCH v5 06/14] iommufd: Introduce data struct for AMD nested domain allocation
Suravee Suthikulpanit SUPERSEDED: 3 reviews, 2 by maintainers
Reviewed-by
[PATCH v5 04/14] iommu/amd: Make amd_iommu_make_clear_dte() non-static inline
Suravee Suthikulpanit SUPERSEDED: 2 reviews, 1 by a maintainer
Reviewed-by
[PATCH v5 03/14] iommu/amd: Make amd_iommu_pdom_id_free() non-static
Suravee Suthikulpanit SUPERSEDED: 3 reviews, 2 by maintainers
Reviewed-by
Keyboard shortcuts
hback out one level
jnext message in thread / next series-diff position
kprevious message in thread / previous series-diff position
ldrill in
Escclose help / fold thread tree
?toggle this help