capabilities · Supported
Maintainers
- M Serge Hallyn <serge@hallyn.com>
Paths
- F
include/linux/capability.h - F
include/trace/events/capability.h - F
include/uapi/linux/capability.h - F
kernel/capability.c - F
security/commoncap.c - F
security/commoncap_test.c
Last 30 days
Recent patches
Most-recent 30 patches in this subsystem on linux-integrity (capped at 30), ordered by date desc.
-
COOLING9d
[PATCH 13/27] fs: port xattr to const mnt_idmap
2026-09-01 · Christian Brauner <brauner@kernel.org> -
COOLING9d
[PATCH 08/27] fs: port privilege checking helpers to const mnt_idmap
2026-09-01 · Christian Brauner <brauner@kernel.org> -
STALE205d
[PATCH] lsm: move inode IS_PRIVATE checks to individual LSMs
2026-02-20 · <hidden> -
STALE230d
REVIEWED: 21 (21M) [PATCH v5 08/34] lsm: replace the name field with a pointer to the lsm_id struct
2025-10-17 · Paul Moore <paul@paul-moore.com> -
STALE342d
REVIEWED: 16 (16M) [PATCH v4 08/34] lsm: replace the name field with a pointer to the lsm_id struct
2025-09-16 · Paul Moore <paul@paul-moore.com> -
STALE370d
REVIEWED: 16 (16M) [PATCH v3 08/34] lsm: replace the name field with a pointer to the lsm_id struct
2025-08-14 · Paul Moore <paul@paul-moore.com> -
STALE415d
REVIEWED: 15 (15M) [RFC PATCH v2 08/34] lsm: replace the name field with a pointer to the lsm_id struct
2025-07-21 · Paul Moore <paul@paul-moore.com> -
STALE422d
[RFC PATCH 29/29] lsm: add support for counting lsm_prop support among LSMs
2025-04-09 · Paul Moore <paul@paul-moore.com> -
STALE422d
[RFC PATCH 05/29] lsm: replace the name field with a pointer to the lsm_id struct
2025-04-09 · Paul Moore <paul@paul-moore.com> -
STALE610d
LANDED: 4 (2M) [PATCH v23 2/8] security: Add EXEC_RESTRICT_FILE and EXEC_DENY_INTERACTIVE securebits
2024-12-12 · Mickaël Salaün <mic@digikod.net> -
STALE645d
REVIEWED: 2 (2M) [PATCH v22 2/8] security: Add EXEC_RESTRICT_FILE and EXEC_DENY_INTERACTIVE securebits
2024-12-05 · Mickaël Salaün <mic@digikod.net> -
STALE651d
REVIEWED: 2 (2M) [PATCH v21 2/6] security: Add EXEC_RESTRICT_FILE and EXEC_DENY_INTERACTIVE securebits
2024-11-12 · Mickaël Salaün <mic@digikod.net> -
STALE702d
[PATCH v20 2/6] security: Add EXEC_RESTRICT_FILE and EXEC_DENY_INTERACTIVE securebits
2024-10-11 · Mickaël Salaün <mic@digikod.net> -
STALE779d
[PATCH v1 1/2] lsm: Refactor return value of LSM hook vm_enough_memory
2024-07-24 · Xu Kuohai <xukuohai@huaweicloud.com> -
STALE786d
[PATCH bpf-next v4 03/20] lsm: Refactor return value of LSM hook inode_getsecurity
2024-07-11 · Xu Kuohai <xukuohai@huaweicloud.com> -
STALE786d
[PATCH bpf-next v4 01/20] lsm: Refactor return value of LSM hook vm_enough_memory
2024-07-11 · Xu Kuohai <xukuohai@huaweicloud.com> -
STALE786d
[PATCH bpf-next v4 02/20] lsm: Refactor return value of LSM hook inode_need_killpriv
2024-07-11 · Xu Kuohai <xukuohai@huaweicloud.com> -
STALE769d
[RFC PATCH v19 2/5] security: Add new SHOULD_EXEC_CHECK and SHOULD_EXEC_RESTRICT securebits
2024-07-04 · Mickaël Salaün <mic@digikod.net> -
STALE925d
[PATCH v2 22/25] fs: use vfs interfaces for capabilities xattrs
2024-02-21 · "Seth Forshee (DigitalOcean)" <sforshee@kernel.org> -
STALE925d
REVIEWED: 5 (5M) [PATCH v2 23/25] commoncap: remove cap_inode_getsecurity()
2024-02-21 · "Seth Forshee (DigitalOcean)" <sforshee@kernel.org> -
STALE925d
[PATCH v2 24/25] commoncap: use vfs fscaps interfaces
2024-02-21 · "Seth Forshee (DigitalOcean)" <sforshee@kernel.org> -
STALE925d
[PATCH v2 06/25] capability: provide helpers for converting between xattrs and vfs_caps
2024-02-21 · "Seth Forshee (DigitalOcean)" <sforshee@kernel.org> -
STALE925d
REVIEWED: 5 (5M) [PATCH v2 05/25] capability: use vfsuid_t for vfs_caps rootids
2024-02-21 · "Seth Forshee (DigitalOcean)" <sforshee@kernel.org> -
STALE925d
[PATCH v2 07/25] capability: provide a helper for converting vfs_caps to xattr for userspace
2024-02-21 · "Seth Forshee (DigitalOcean)" <sforshee@kernel.org> -
STALE925d
[PATCH v2 09/25] commoncap: use is_fscaps_xattr()
2024-02-21 · "Seth Forshee (DigitalOcean)" <sforshee@kernel.org> -
STALE925d
REVIEWED: 8 (8M) [PATCH v2 04/25] capability: rename cpu_vfs_cap_data to vfs_caps
2024-02-21 · "Seth Forshee (DigitalOcean)" <sforshee@kernel.org> -
STALE925d
[PATCH v2 03/25] capability: add static asserts for comapatibility of vfs_cap_data and vfs_ns_cap_data
2024-02-21 · "Seth Forshee (DigitalOcean)" <sforshee@kernel.org> -
STALE1315d
[PATCH v15 11/26] ima: Define mac_admin_ns_capable() as a wrapper for ns_capable()
2023-02-06 · Stefan Berger <stefanb@linux.ibm.com> -
STALE1359d
[PATCH v14 11/26] ima: Define mac_admin_ns_capable() as a wrapper for ns_capable()
2022-09-15 · Stefan Berger <stefanb@linux.ibm.com> -
STALE1533d
[PATCH v13 11/26] ima: Define mac_admin_ns_capable() as a wrapper for ns_capable()
2022-07-07 · Stefan Berger <stefanb@linux.ibm.com>