Reviews by zohar@linux.ibm.com
· linux-integrity
All review-attestation trailers
(Reviewed-by / Acked-by /
Tested-by / Reported-by /
Suggested-by / Co-developed-by /
Reported-and-tested-by)
by this address on the linux-integrity archive.
100 attestations · capped at 100 most-recent. (2 Acked-by, 3 Reported-by, 81 Reviewed-by, 13 Suggested-by, 1 Tested-by)
-
DORMANTno replies
[PATCH v2 2/2] ima: don't measure/appraise files on configfs
2026-08-19 · Suggested-by -
WARM3d
[PATCH v2 1/2] configfs: move CONFIGFS_MAGIC definition to magic.h
2026-08-19 · Suggested-by -
WARM3d
[PATCH 2/2] ima: don't measure/appraise files on configfs
2026-08-18 · Suggested-by -
WARM3d
[PATCH 1/2] configfs: move CONFIGFS_MAGIC definition to magic.h
2026-08-18 · Suggested-by -
COOLING9d
REVIEWED: 5 (5M) Re: [PATCH v2 2/2] ima_policy.sh: Require kernel 4.5+ for test02
2026-08-14 · Reviewed-by -
COOLING9d
[PATCH 1/1] ima_setup.sh: Use tst_umount()
2026-08-13 · Reported-by -
COOLING9d
REVIEWED: 5 (5M) Re: [PATCH v2 1/2] ima_setup.sh: Fix check_policy_writable() for kernel < 4.5
2026-08-12 · Reviewed-by -
STALE76d
REVIEWED: 5 (5M) [PATCH v7 08/12] ima: Introduce ima_dump_measurement()
2026-06-05 · Reviewed-by -
STALE76d
REVIEWED: 5 (5M) [PATCH v7 07/12] ima: Use snprintf() in create_securityfs_measurement_lists
2026-06-05 · Reviewed-by -
STALE76d
REVIEWED: 5 (5M) [PATCH v7 05/12] ima: Introduce _ima_measurements_start() and _ima_measurements_next()
2026-06-05 · Reviewed-by -
STALE76d
REVIEWED: 5 (5M) [PATCH v7 03/12] ima: Introduce per binary measurements list type ima_num_records counter
2026-06-05 · Reviewed-by -
STALE76d
REVIEWED: 5 (5M) [PATCH v7 02/12] ima: Replace static htable queue with dynamically allocated array
2026-06-05 · Reviewed-by -
COLD51d
REVIEWED: 5 (5M) [PATCH v6 2/4] security: ima: introduce IMA_INIT_LATE_SYNC option
2026-06-05 · Suggested-by -
COLD51d
REVIEWED: 5 (5M) [PATCH v6 2/4] security: ima: introduce IMA_INIT_LATE_SYNC option
2026-06-05 · Reviewed-by -
STALE76d
REVIEWED: 5 (5M) Re: [PATCH v5 2/4] security: ima: introduce IMA_INIT_LATE_SYNC option
2026-06-02 · Reviewed-by -
STALE79d
REVIEWED: 5 (5M) [PATCH v6 08/12] ima: Introduce ima_dump_measurement()
2026-06-02 · Reviewed-by -
STALE79d
REVIEWED: 5 (5M) [PATCH v6 07/12] ima: Use snprintf() in create_securityfs_measurement_lists
2026-06-02 · Reviewed-by -
STALE79d
REVIEWED: 5 (5M) [PATCH v6 05/12] ima: Introduce _ima_measurements_start() and _ima_measurements_next()
2026-06-02 · Reviewed-by -
STALE79d
REVIEWED: 5 (5M) [PATCH v6 03/12] ima: Introduce per binary measurements list type ima_num_records counter
2026-06-02 · Reviewed-by -
STALE79d
REVIEWED: 5 (5M) [PATCH v6 02/12] ima: Replace static htable queue with dynamically allocated array
2026-06-02 · Reviewed-by -
STALE76d
[PATCH v5 2/4] security: ima: introduce IMA_INIT_LATE_SYNC option
2026-06-01 · Suggested-by -
STALE82d
REVIEWED: 5 (5M) Re: [PATCH v5 11/13] ima: Support staging and deleting N measurements entries
2026-05-26 · Reviewed-by -
STALE76d
[PATCH v4 2/3] security: ima: introduce IMA_INIT_LATE_SYNC option
2026-05-25 · Suggested-by -
STALE82d
REVIEWED: 5 (5M) Re: [PATCH v5 08/13] ima: Introduce ima_dump_measurement()
2026-05-21 · Reviewed-by -
STALE82d
REVIEWED: 5 (5M) Re: [PATCH v5 07/13] ima: Use snprintf() in create_securityfs_measurement_lists
2026-05-21 · Reviewed-by -
STALE82d
REVIEWED: 5 (5M) Re: [PATCH v5 05/13] ima: Introduce _ima_measurements_start() and _ima_measurements_next()
2026-05-21 · Reviewed-by -
STALE82d
REVIEWED: 5 (5M) Re: [PATCH v5 03/13] ima: Introduce per binary measurements list type ima_num_entries counter
2026-05-21 · Reviewed-by -
STALE82d
REVIEWED: 5 (5M) Re: [PATCH v5 02/13] ima: Replace static htable queue with dynamically allocated array
2026-05-21 · Reviewed-by -
STALE127d
[PATCH v5 1/3] ima: make ima event log trimming configurable
2026-04-01 · Suggested-by -
STALE159d
REVIEWED: 5 (5M) [PATCH v3 1/2] EVM: add comment describing why ino field is still unsigned long
2026-03-16 · Reviewed-by -
STALE159d
REVIEWED: 5 (5M) Re: [PATCH v2 2/2] EVM: add comment describing why ino field is still unsigned long
2026-03-13 · Reviewed-by -
DORMANTno replies
REVIEWED: 5 (5M) FAILED: Patch "ima: verify the previous kernel's IMA buffer lies in addressable RAM" failed to apply to 5.10-stable tree
2026-03-01 · Reviewed-by -
DORMANTno replies
REVIEWED: 5 (5M) FAILED: Patch "ima: verify the previous kernel's IMA buffer lies in addressable RAM" failed to apply to 5.15-stable tree
2026-03-01 · Reviewed-by -
DORMANTno replies
REVIEWED: 5 (5M) FAILED: Patch "ima: verify the previous kernel's IMA buffer lies in addressable RAM" failed to apply to 6.1-stable tree
2026-03-01 · Reviewed-by -
DORMANTno replies
REVIEWED: 5 (5M) FAILED: Patch "ima: verify the previous kernel's IMA buffer lies in addressable RAM" failed to apply to 6.6-stable tree
2026-03-01 · Reviewed-by -
DORMANTno replies
REVIEWED: 5 (5M) FAILED: Patch "ima: verify the previous kernel's IMA buffer lies in addressable RAM" failed to apply to 6.12-stable tree
2026-03-01 · Reviewed-by -
STALE176d
REVIEWED: 8 (8M) [PATCH 2/2] powerpc/ima: Drop unnecessary check for CONFIG_MODULE_SIG
2026-02-26 · Reviewed-by -
STALE176d
REVIEWED: 8 (8M) [PATCH 1/2] ima: efi: Drop unnecessary check for CONFIG_MODULE_SIG/CONFIG_KEXEC_SIG
2026-02-26 · Reviewed-by -
STALE177d
REVIEWED: 5 (5M) [PATCH v6 6/6] docs: trusted-encryped: add PKWM as a new trust source
2026-02-01 · Reviewed-by -
STALE177d
REVIEWED: 16 (16M) [PATCH v6 5/6] keys/trusted_keys: establish PKWM as a trusted source
2026-02-01 · Reviewed-by -
STALE177d
REVIEWED: 11 (11M) [PATCH v6 2/6] powerpc/pseries: move the PLPKS config inside its own sysfs directory
2026-02-01 · Reviewed-by -
STALE206d
REVIEWED: 5 (5M) Re: [LTP] [PATCH] ima_setup.sh: Fix signed policy requirement check
2026-01-28 · Tested-by -
STALE206d
[LTP] [PATCH] ima_setup.sh: Fix signed policy requirement check
2026-01-28 · Reported-by -
STALE206d
REVIEWED: 5 (5M) [PATCH v5 6/6] docs: trusted-encryped: add PKWM as a new trust source
2026-01-27 · Reviewed-by -
STALE206d
REVIEWED: 13 (13M) [PATCH v5 5/6] keys/trusted_keys: establish PKWM as a trusted source
2026-01-27 · Reviewed-by -
STALE206d
REVIEWED: 8 (8M) [PATCH v5 2/6] powerpc/pseries: move the PLPKS config inside its own sysfs directory
2026-01-27 · Reviewed-by -
STALE207d
[LTP] [PATCH] ima_setup.sh: Fix check of signed policy requirement
2026-01-21 · Suggested-by -
STALE178d
REVIEWED: 5 (5M) Re: [PATCH 1/3] integrity: Make arch_ima_get_secureboot integrity-wide
2026-01-15 · Reviewed-by -
STALE178d
REVIEWED: 5 (5M) Re: [PATCH 2/3] evm: Don't enable fix mode when secure boot is enabled
2026-01-15 · Reviewed-by -
STALE211d
REVIEWED: 5 (5M) [PATCH v4 6/6] docs: trusted-encryped: add PKWM as a new trust source
2026-01-15 · Reviewed-by -
STALE211d
REVIEWED: 5 (5M) [PATCH v4 5/6] keys/trusted_keys: establish PKWM as a trusted source
2026-01-15 · Reviewed-by -
STALE211d
REVIEWED: 5 (5M) [PATCH v4 2/6] powerpc/pseries: move the PLPKS config inside its own sysfs directory
2026-01-15 · Reviewed-by -
STALE221d
REVIEWED: 5 (5M) [PATCH v3 6/6] docs: trusted-encryped: add PKWM as a new trust source
2026-01-06 · Reviewed-by -
STALE221d
REVIEWED: 5 (5M) [PATCH v3 5/6] keys/trusted_keys: establish PKWM as a trusted source
2026-01-06 · Reviewed-by -
STALE221d
REVIEWED: 5 (5M) [PATCH v3 2/6] powerpc/pseries: move the PLPKS config inside its own sysfs directory
2026-01-06 · Reviewed-by -
STALE229d
REVIEWED: 5 (5M) Re: [PATCH v2 6/6] docs: trusted-encryped: add PKWM as a new trust source
2026-01-02 · Reviewed-by -
STALE229d
REVIEWED: 5 (5M) Re: [PATCH v2 5/6] keys/trusted_keys: establish PKWM as a trusted source
2026-01-02 · Reviewed-by -
STALE229d
REVIEWED: 5 (5M) Re: [PATCH v2 2/6] powerpc/pseries: move the PLPKS config inside its own sysfs directory
2026-01-02 · Reviewed-by -
STALE249d
[LTP] [PATCH] ima_selinux: Fix requirements
2025-12-08 · Reported-by -
STALE277d
[PATCH v4] ima: Access decompressed kernel module to verify appended signature
2025-11-19 · Suggested-by -
STALE277d
[PATCH v3] ima: Access decompressed kernel module to verify appended signature
2025-11-19 · Suggested-by -
STALE277d
[PATCH v2] lsm,ima: new LSM hook security_kernel_module_read_file to access decompressed kernel module
2025-10-31 · Suggested-by -
STALE205d
REVIEWED: 5 (5M) [PATCH v5 08/11] ima,evm: move initcalls to the LSM framework
2025-10-17 · Acked-by -
STALE205d
REVIEWED: 7 (6M) [PATCH v5 22/34] lsm: group lsm_order_parse() with the other lsm_order_*() functions
2025-10-17 · Reviewed-by -
STALE205d
REVIEWED: 7 (6M) [PATCH v5 21/34] lsm: output available LSMs when debugging
2025-10-17 · Reviewed-by -
STALE205d
REVIEWED: 21 (21M) [PATCH v5 17/34] lsm: cleanup initialize_lsm() and rename to lsm_init_single()
2025-10-17 · Reviewed-by -
STALE205d
REVIEWED: 21 (21M) [PATCH v5 16/34] lsm: cleanup the LSM blob size code
2025-10-17 · Reviewed-by -
STALE205d
REVIEWED: 7 (6M) [PATCH v5 13/34] lsm: rename exists_ordered_lsm() to lsm_order_exists()
2025-10-17 · Reviewed-by -
STALE205d
REVIEWED: 7 (6M) [PATCH v5 12/34] lsm: rework the LSM enable/disable setter/getter functions
2025-10-17 · Reviewed-by -
STALE205d
REVIEWED: 7 (6M) [PATCH v5 10/34] lsm: rework lsm_active_cnt and lsm_idlist[]
2025-10-17 · Reviewed-by -
STALE205d
REVIEWED: 21 (21M) [PATCH v5 09/34] lsm: rename the lsm order variables for consistency
2025-10-17 · Reviewed-by -
STALE205d
REVIEWED: 21 (21M) [PATCH v5 08/34] lsm: replace the name field with a pointer to the lsm_id struct
2025-10-17 · Reviewed-by -
STALE205d
REVIEWED: 7 (6M) [PATCH v5 07/34] lsm: rename ordered_lsm_init() to lsm_init_ordered()
2025-10-17 · Reviewed-by -
STALE205d
REVIEWED: 7 (6M) [PATCH v5 06/34] lsm: integrate lsm_early_cred() and lsm_early_task() into caller
2025-10-17 · Reviewed-by -
STALE205d
REVIEWED: 7 (6M) [PATCH v5 05/34] lsm: integrate report_lsm_order() code into caller
2025-10-17 · Reviewed-by -
STALE205d
REVIEWED: 7 (6M) [PATCH v5 04/34] lsm: introduce looping macros for the initialization code
2025-10-17 · Reviewed-by -
STALE205d
REVIEWED: 7 (6M) [PATCH v5 03/34] lsm: consolidate lsm_allowed() and prepare_lsm() into lsm_prepare()
2025-10-17 · Reviewed-by -
STALE205d
REVIEWED: 21 (21M) [PATCH v5 02/34] lsm: split the init code out into lsm_init.c
2025-10-17 · Reviewed-by -
STALE205d
REVIEWED: 21 (21M) [PATCH v5 01/34] lsm: split the notifier code out into lsm_notifier.c
2025-10-17 · Reviewed-by -
STALE312d
REVIEWED: 5 (5M) Re: [PATCH] keys: Remove redundant less-than-zero checks
2025-10-13 · Reviewed-by -
STALE316d
REVIEWED: 5 (5M) Re: [PATCH v4 31/34] ima,evm: move initcalls to the LSM framework
2025-10-10 · Acked-by -
STALE264d
[PATCH v2 1/2] evm: fix security.evm for a file with IMA signature
2025-09-30 · Suggested-by -
STALE316d
REVIEWED: 5 (5M) Re: [PATCH v4 11/34] lsm: get rid of the lsm_names list and do some cleanup
2025-09-19 · Reviewed-by -
STALE316d
REVIEWED: 5 (5M) Re: [PATCH v4 13/34] lsm: rename exists_ordered_lsm() to lsm_order_exists()
2025-09-19 · Reviewed-by -
STALE316d
REVIEWED: 5 (5M) Re: [PATCH v4 12/34] lsm: rework the LSM enable/disable setter/getter functions
2025-09-19 · Reviewed-by -
STALE316d
REVIEWED: 5 (5M) Re: [PATCH v4 10/34] lsm: rework lsm_active_cnt and lsm_idlist[]
2025-09-19 · Reviewed-by -
STALE316d
REVIEWED: 5 (5M) Re: [PATCH v4 09/34] lsm: rename the lsm order variables for consistency
2025-09-19 · Reviewed-by -
STALE316d
REVIEWED: 5 (5M) Re: [PATCH v4 08/34] lsm: replace the name field with a pointer to the lsm_id struct
2025-09-19 · Reviewed-by -
STALE316d
REVIEWED: 5 (5M) Re: [PATCH v4 07/34] lsm: rename ordered_lsm_init() to lsm_init_ordered()
2025-09-19 · Reviewed-by -
STALE316d
REVIEWED: 5 (5M) Re: [PATCH v4 06/34] lsm: integrate lsm_early_cred() and lsm_early_task() into caller
2025-09-19 · Reviewed-by -
STALE316d
REVIEWED: 5 (5M) Re: [PATCH v4 05/34] lsm: integrate report_lsm_order() code into caller
2025-09-19 · Reviewed-by -
STALE316d
REVIEWED: 5 (5M) Re: [PATCH v4 04/34] lsm: introduce looping macros for the initialization code
2025-09-19 · Reviewed-by -
STALE316d
REVIEWED: 5 (5M) Re: [PATCH v4 03/34] lsm: consolidate lsm_allowed() and prepare_lsm() into lsm_prepare()
2025-09-19 · Reviewed-by -
STALE316d
REVIEWED: 5 (5M) Re: [PATCH v4 02/34] lsm: split the init code out into lsm_init.c
2025-09-19 · Reviewed-by -
STALE316d
REVIEWED: 5 (5M) Re: [PATCH v4 01/34] lsm: split the notifier code out into lsm_notifier.c
2025-09-19 · Reviewed-by -
STALE316d
REVIEWED: 5 (5M) Re: [PATCH v4 22/34] lsm: group lsm_order_parse() with the other lsm_order_*() functions
2025-09-18 · Reviewed-by -
STALE316d
REVIEWED: 5 (5M) Re: [PATCH v4 23/34] lsm: introduce an initcall mechanism into the LSM framework
2025-09-18 · Reviewed-by -
STALE316d
REVIEWED: 5 (5M) Re: [PATCH v4 21/34] lsm: output available LSMs when debugging
2025-09-18 · Reviewed-by -
STALE316d
REVIEWED: 5 (5M) Re: [PATCH v4 17/34] lsm: cleanup initialize_lsm() and rename to lsm_init_single()
2025-09-18 · Reviewed-by -
STALE316d
REVIEWED: 5 (5M) Re: [PATCH v4 16/34] lsm: cleanup the LSM blob size code
2025-09-18 · Reviewed-by