Reviews by john.johansen@canonical.com
· linux-integrity
All review-attestation trailers
(Reviewed-by / Acked-by /
Tested-by / Reported-by /
Suggested-by / Co-developed-by /
Reported-and-tested-by)
by this address on the linux-integrity archive.
100 attestations · capped at 100 most-recent. (5 Acked-by, 95 Reviewed-by)
-
STALE173d
REVIEWED: 15 (15M) [PATCH v5 06/11] apparmor: move initcalls to the LSM framework
2025-10-17 · Acked-by -
STALE173d
REVIEWED: 21 (21M) [PATCH v5 17/34] lsm: cleanup initialize_lsm() and rename to lsm_init_single()
2025-10-17 · Reviewed-by -
STALE173d
REVIEWED: 21 (21M) [PATCH v5 16/34] lsm: cleanup the LSM blob size code
2025-10-17 · Reviewed-by -
STALE173d
REVIEWED: 21 (21M) [PATCH v5 09/34] lsm: rename the lsm order variables for consistency
2025-10-17 · Reviewed-by -
STALE173d
REVIEWED: 21 (21M) [PATCH v5 08/34] lsm: replace the name field with a pointer to the lsm_id struct
2025-10-17 · Reviewed-by -
STALE173d
REVIEWED: 21 (21M) [PATCH v5 02/34] lsm: split the init code out into lsm_init.c
2025-10-17 · Reviewed-by -
STALE173d
REVIEWED: 21 (21M) [PATCH v5 01/34] lsm: split the notifier code out into lsm_notifier.c
2025-10-17 · Reviewed-by -
STALE284d
REVIEWED: 15 (15M) [PATCH v4 29/34] apparmor: move initcalls to the LSM framework
2025-09-16 · Acked-by -
STALE284d
REVIEWED: 16 (16M) [PATCH v4 17/34] lsm: cleanup initialize_lsm() and rename to lsm_init_single()
2025-09-16 · Reviewed-by -
STALE284d
REVIEWED: 16 (16M) [PATCH v4 16/34] lsm: cleanup the LSM blob size code
2025-09-16 · Reviewed-by -
STALE284d
REVIEWED: 16 (16M) [PATCH v4 09/34] lsm: rename the lsm order variables for consistency
2025-09-16 · Reviewed-by -
STALE284d
REVIEWED: 16 (16M) [PATCH v4 08/34] lsm: replace the name field with a pointer to the lsm_id struct
2025-09-16 · Reviewed-by -
STALE284d
REVIEWED: 16 (16M) [PATCH v4 02/34] lsm: split the init code out into lsm_init.c
2025-09-16 · Reviewed-by -
STALE284d
REVIEWED: 16 (16M) [PATCH v4 01/34] lsm: split the notifier code out into lsm_notifier.c
2025-09-16 · Reviewed-by -
STALE312d
REVIEWED: 1 (1M) Re: [PATCH v3 29/34] apparmor: move initcalls to the LSM framework
2025-09-08 · Acked-by -
STALE312d
REVIEWED: 1 (1M) Re: [PATCH v3 20/34] lsm: cleanup the debug and console output in lsm_init.c
2025-09-03 · Reviewed-by -
STALE312d
REVIEWED: 1 (1M) Re: [PATCH v3 21/34] lsm: output available LSMs when debugging
2025-09-03 · Reviewed-by -
STALE312d
REVIEWED: 1 (1M) Re: [PATCH v3 19/34] lsm: add/tweak function header comment blocks in lsm_init.c
2025-09-03 · Reviewed-by -
STALE312d
REVIEWED: 1 (1M) Re: [PATCH v3 18/34] lsm: fold lsm_init_ordered() into security_init()
2025-09-03 · Reviewed-by -
STALE312d
REVIEWED: 1 (1M) Re: [PATCH v3 15/34] lsm: rename/rework ordered_lsm_parse() to lsm_order_parse()
2025-09-03 · Reviewed-by -
STALE312d
REVIEWED: 1 (1M) Re: [PATCH v3 14/34] lsm: rename/rework append_ordered_lsm() into lsm_order_append()
2025-09-03 · Reviewed-by -
STALE312d
REVIEWED: 1 (1M) Re: [PATCH v3 34/34] lsm: add a LSM_STARTED_ALL notification event
2025-09-02 · Reviewed-by -
STALE312d
REVIEWED: 1 (1M) Re: [PATCH v3 33/34] lsm: consolidate all of the LSM framework initcalls
2025-09-02 · Reviewed-by -
STALE312d
REVIEWED: 1 (1M) Re: [PATCH v3 30/34] lockdown: move initcalls to the LSM framework
2025-09-02 · Reviewed-by -
STALE312d
REVIEWED: 1 (1M) Re: [PATCH v3 28/34] safesetid: move initcalls to the LSM framework
2025-09-02 · Reviewed-by -
STALE312d
REVIEWED: 1 (1M) Re: [PATCH v3 27/34] tomoyo: move initcalls to the LSM framework
2025-09-02 · Reviewed-by -
STALE312d
REVIEWED: 1 (1M) Re: [PATCH v3 26/34] smack: move initcalls to the LSM framework
2025-09-02 · Reviewed-by -
STALE312d
REVIEWED: 1 (1M) Re: [PATCH v3 25/34] ipe: move initcalls to the LSM framework
2025-09-02 · Reviewed-by -
STALE312d
REVIEWED: 1 (1M) Re: [PATCH v3 24/34] loadpin: move initcalls to the LSM framework
2025-09-02 · Reviewed-by -
STALE312d
REVIEWED: 1 (1M) Re: [PATCH v3 23/34] lsm: introduce an initcall mechanism into the LSM framework
2025-09-02 · Reviewed-by -
STALE312d
REVIEWED: 1 (1M) Re: [PATCH v3 22/34] lsm: group lsm_order_parse() with the other lsm_order_*() functions
2025-09-02 · Reviewed-by -
STALE312d
REVIEWED: 1 (1M) Re: [PATCH v3 13/34] lsm: rename exists_ordered_lsm() to lsm_order_exists()
2025-09-02 · Reviewed-by -
STALE312d
REVIEWED: 1 (1M) Re: [PATCH v3 12/34] lsm: rework the LSM enable/disable setter/getter functions
2025-09-02 · Reviewed-by -
STALE312d
REVIEWED: 1 (1M) Re: [PATCH v3 10/34] lsm: rework lsm_active_cnt and lsm_idlist[]
2025-09-02 · Reviewed-by -
STALE312d
REVIEWED: 1 (1M) Re: [PATCH v3 07/34] lsm: rename ordered_lsm_init() to lsm_init_ordered()
2025-09-02 · Reviewed-by -
STALE312d
REVIEWED: 1 (1M) Re: [PATCH v3 06/34] lsm: integrate lsm_early_cred() and lsm_early_task() into caller
2025-09-02 · Reviewed-by -
STALE312d
REVIEWED: 1 (1M) Re: [PATCH v3 05/34] lsm: integrate report_lsm_order() code into caller
2025-09-02 · Reviewed-by -
STALE312d
REVIEWED: 1 (1M) Re: [PATCH v3 04/34] lsm: introduce looping macros for the initialization code
2025-09-02 · Reviewed-by -
STALE312d
REVIEWED: 15 (15M) [PATCH v3 17/34] lsm: cleanup initialize_lsm() and rename to lsm_init_single()
2025-08-14 · Reviewed-by -
STALE312d
REVIEWED: 16 (16M) [PATCH v3 16/34] lsm: cleanup the LSM blob size code
2025-08-14 · Reviewed-by -
STALE312d
REVIEWED: 16 (16M) [PATCH v3 09/34] lsm: rename the lsm order variables for consistency
2025-08-14 · Reviewed-by -
STALE312d
REVIEWED: 16 (16M) [PATCH v3 08/34] lsm: replace the name field with a pointer to the lsm_id struct
2025-08-14 · Reviewed-by -
STALE312d
REVIEWED: 16 (16M) [PATCH v3 02/34] lsm: split the init code out into lsm_init.c
2025-08-14 · Reviewed-by -
STALE312d
REVIEWED: 16 (16M) [PATCH v3 01/34] lsm: split the notifier code out into lsm_notifier.c
2025-08-14 · Reviewed-by -
STALE358d
REVIEWED: 15 (15M) [RFC PATCH v2 17/34] lsm: cleanup initialize_lsm() and rename to lsm_init_single()
2025-07-21 · Reviewed-by -
STALE358d
REVIEWED: 15 (15M) [RFC PATCH v2 16/34] lsm: cleanup the LSM blob size code
2025-07-21 · Reviewed-by -
STALE358d
REVIEWED: 15 (15M) [RFC PATCH v2 09/34] lsm: rename the lsm order variables for consistency
2025-07-21 · Reviewed-by -
STALE358d
REVIEWED: 15 (15M) [RFC PATCH v2 08/34] lsm: replace the name field with a pointer to the lsm_id struct
2025-07-21 · Reviewed-by -
STALE358d
REVIEWED: 15 (15M) [RFC PATCH v2 02/34] lsm: split the init code out into lsm_init.c
2025-07-21 · Reviewed-by -
STALE358d
REVIEWED: 15 (15M) [RFC PATCH v2 01/34] lsm: split the notifier code out into lsm_notifier.c
2025-07-21 · Reviewed-by -
STALE365d
REVIEWED: 1 (1M) Re: [RFC PATCH 27/29] lsm: consolidate all of the LSM framework initcalls
2025-05-14 · Reviewed-by -
STALE365d
REVIEWED: 1 (1M) Re: [RFC PATCH 28/29] lsm: add a LSM_STARTED_ALL notification event
2025-05-14 · Reviewed-by -
STALE365d
REVIEWED: 1 (1M) Re: [RFC PATCH 23/29] apparmor: move initcalls to the LSM framework
2025-05-14 · Acked-by -
STALE365d
REVIEWED: 1 (1M) Re: [RFC PATCH 24/29] lockdown: move initcalls to the LSM framework
2025-05-14 · Reviewed-by -
STALE365d
REVIEWED: 1 (1M) Re: [RFC PATCH 22/29] safesetid: move initcalls to the LSM framework
2025-05-14 · Reviewed-by -
STALE365d
REVIEWED: 1 (1M) Re: [RFC PATCH 21/29] tomoyo: move initcalls to the LSM framework
2025-05-14 · Reviewed-by -
STALE365d
REVIEWED: 1 (1M) Re: [RFC PATCH 19/29] ipe: move initcalls to the LSM framework
2025-05-14 · Reviewed-by -
STALE365d
REVIEWED: 1 (1M) Re: [RFC PATCH 16/29] lsm: output available LSMs when debugging
2025-05-14 · Reviewed-by -
STALE365d
REVIEWED: 1 (1M) Re: [RFC PATCH 17/29] lsm: introduce an initcall mechanism into the LSM framework
2025-05-14 · Reviewed-by -
STALE365d
REVIEWED: 1 (1M) Re: [RFC PATCH 18/29] loadpin: move initcalls to the LSM framework
2025-05-14 · Reviewed-by -
STALE365d
REVIEWED: 1 (1M) Re: [RFC PATCH 14/29] lsm: add missing function header comment blocks in lsm_init.c
2025-05-14 · Reviewed-by -
STALE365d
REVIEWED: 1 (1M) Re: [RFC PATCH 11/29] lsm: cleanup initialize_lsm() and rename to lsm_init_single()
2025-04-15 · Reviewed-by -
STALE365d
REVIEWED: 1 (1M) Re: [RFC PATCH 10/29] lsm: cleanup the LSM blob size code
2025-04-15 · Reviewed-by -
STALE365d
REVIEWED: 1 (1M) Re: [RFC PATCH 06/29] lsm: cleanup and normalize the LSM order symbols naming
2025-04-15 · Reviewed-by -
STALE365d
REVIEWED: 1 (1M) Re: [RFC PATCH 05/29] lsm: replace the name field with a pointer to the lsm_id struct
2025-04-15 · Reviewed-by -
STALE365d
REVIEWED: 1 (1M) Re: [RFC PATCH 03/29] lsm: simplify prepare_lsm() and rename to lsm_prep_single()
2025-04-15 · Reviewed-by -
STALE365d
REVIEWED: 1 (1M) Re: [RFC PATCH 02/29] lsm: split the init code out into lsm_init.c
2025-04-15 · Reviewed-by -
STALE365d
REVIEWED: 1 (1M) Re: [RFC PATCH 01/29] lsm: split the notifier code out into lsm_notifier.c
2025-04-15 · Reviewed-by -
STALE693d
REVIEWED: 8 (7M) [PATCH 10/13] LSM: Create new security_cred_getlsmblob LSM hook
2024-08-25 · Reviewed-by -
STALE693d
REVIEWED: 8 (7M) [PATCH 08/13] LSM: Use lsmblob in security_inode_getsecid
2024-08-25 · Reviewed-by -
STALE693d
REVIEWED: 8 (7M) [PATCH 07/13] LSM: Use lsmblob in security_current_getsecid
2024-08-25 · Reviewed-by -
STALE767d
REVIEWED: 1 (1M) Re: [PATCH v3] ima: Avoid blocking in RCU read-side critical section
2024-06-04 · Acked-by -
STALE757d
REVIEWED: 9 (7M) [PATCH v39 16/42] LSM: Ensure the correct LSM context releaser
2023-12-15 · Reviewed-by -
STALE757d
REVIEWED: 8 (7M) [PATCH v39 13/42] LSM: Create new security_cred_getlsmblob LSM hook
2023-12-15 · Reviewed-by -
STALE757d
REVIEWED: 8 (7M) [PATCH v39 10/42] LSM: Use lsmblob in security_current_getsecid
2023-12-15 · Reviewed-by -
STALE757d
REVIEWED: 8 (7M) [PATCH v39 11/42] LSM: Use lsmblob in security_inode_getsecid
2023-12-15 · Reviewed-by -
STALE757d
REVIEWED: 6 (6M) [PATCH v39 01/42] integrity: disassociate ima_filter_rule from security_audit_rule
2023-12-15 · Reviewed-by -
STALE1236d
REVIEWED: 9 (7M) [PATCH v38 21/39] LSM: Ensure the correct LSM context releaser
2022-09-27 · Reviewed-by -
STALE1236d
REVIEWED: 8 (7M) [PATCH v38 19/39] LSM: Use lsmblob in security_cred_getsecid
2022-09-27 · Reviewed-by -
STALE1236d
REVIEWED: 8 (7M) [PATCH v38 18/39] LSM: Use lsmblob in security_inode_getsecid
2022-09-27 · Reviewed-by -
STALE1236d
REVIEWED: 8 (7M) [PATCH v38 17/39] LSM: Use lsmblob in security_current_getsecid
2022-09-27 · Reviewed-by -
STALE1236d
REVIEWED: 6 (6M) [PATCH v38 07/39] integrity: disassociate ima_filter_rule from security_audit_rule
2022-09-27 · Reviewed-by -
STALE1470d
REVIEWED: 9 (7M) [PATCH v37 15/33] LSM: Ensure the correct LSM context releaser
2022-06-28 · Reviewed-by -
STALE1470d
REVIEWED: 8 (7M) [PATCH v37 13/33] LSM: Use lsmblob in security_cred_getsecid
2022-06-28 · Reviewed-by -
STALE1470d
REVIEWED: 8 (7M) [PATCH v37 12/33] LSM: Use lsmblob in security_inode_getsecid
2022-06-28 · Reviewed-by -
STALE1470d
REVIEWED: 8 (7M) [PATCH v37 11/33] LSM: Use lsmblob in security_current_getsecid
2022-06-28 · Reviewed-by -
STALE1470d
REVIEWED: 6 (6M) [PATCH v37 01/33] integrity: disassociate ima_filter_rule from security_audit_rule
2022-06-28 · Reviewed-by -
STALE1490d
REVIEWED: 9 (7M) [PATCH v36 15/33] LSM: Ensure the correct LSM context releaser
2022-06-09 · Reviewed-by -
STALE1490d
REVIEWED: 8 (7M) [PATCH v36 12/33] LSM: Use lsmblob in security_inode_getsecid
2022-06-09 · Reviewed-by -
STALE1490d
REVIEWED: 8 (7M) [PATCH v36 13/33] LSM: Use lsmblob in security_cred_getsecid
2022-06-09 · Reviewed-by -
STALE1490d
REVIEWED: 8 (7M) [PATCH v36 11/33] LSM: Use lsmblob in security_current_getsecid
2022-06-09 · Reviewed-by -
STALE1490d
REVIEWED: 6 (6M) [PATCH v36 01/33] integrity: disassociate ima_filter_rule from security_audit_rule
2022-06-09 · Reviewed-by -
STALE1546d
REVIEWED: 9 (7M) [PATCH v35 15/29] LSM: Ensure the correct LSM context releaser
2022-04-18 · Reviewed-by -
STALE1546d
REVIEWED: 8 (7M) [PATCH v35 12/29] LSM: Use lsmblob in security_inode_getsecid
2022-04-18 · Reviewed-by -
STALE1546d
REVIEWED: 8 (7M) [PATCH v35 13/29] LSM: Use lsmblob in security_cred_getsecid
2022-04-18 · Reviewed-by -
STALE1546d
REVIEWED: 8 (7M) [PATCH v35 11/29] LSM: Use lsmblob in security_current_getsecid
2022-04-18 · Reviewed-by -
STALE1558d
REVIEWED: 9 (7M) [PATCH v34 15/29] LSM: Ensure the correct LSM context releaser
2022-04-15 · Reviewed-by -
STALE1558d
REVIEWED: 8 (7M) [PATCH v34 13/29] LSM: Use lsmblob in security_cred_getsecid
2022-04-15 · Reviewed-by -
STALE1558d
REVIEWED: 8 (7M) [PATCH v34 12/29] LSM: Use lsmblob in security_inode_getsecid
2022-04-15 · Reviewed-by -
STALE1558d
REVIEWED: 8 (7M) [PATCH v34 11/29] LSM: Use lsmblob in security_current_getsecid
2022-04-15 · Reviewed-by