DORMANTno replies

[PATCH] HID: use swap() to make code cleaner

From: Lv Ruyi <hidden>
Date: 2021-10-27 23:53:00
Also in: lkml
Subsystem: hid core layer, the rest · Maintainers: Jiri Kosina, Benjamin Tissoires, Linus Torvalds

From: Yang Guang <redacted>

Using swap() make it more readable.

Reported-by: Zeal Robot <redacted>
Signed-off-by: Yang Guang <redacted>
---
 drivers/hid/hid-tmff.c | 5 +----
 1 file changed, 1 insertion(+), 4 deletions(-)
diff --git a/drivers/hid/hid-tmff.c b/drivers/hid/hid-tmff.c
index 90acef304536..f5b902d1a174 100644
--- a/drivers/hid/hid-tmff.c
+++ b/drivers/hid/hid-tmff.c
@@ -78,7 +78,6 @@ static int tmff_play(struct input_dev *dev, void *data,
 	struct hid_field *ff_field = tmff->ff_field;
 	int x, y;
 	int left, right;	/* Rumbling */
-	int motor_swap;
 
 	switch (effect->type) {
 	case FF_CONSTANT:
@@ -105,9 +104,7 @@ static int tmff_play(struct input_dev *dev, void *data,
 
 		/* 2-in-1 strong motor is left */
 		if (hid->product == THRUSTMASTER_DEVICE_ID_2_IN_1_DT) {
-			motor_swap = left;
-			left = right;
-			right = motor_swap;
+			swap(left, right);
 		}
 
 		dbg_hid("(left,right)=(%08x, %08x)\n", left, right);
-- 
2.30.2
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help