[PATCH v2] Input: Allocate keycode for SNIP key

Subsystems: input (keyboard, mouse, joystick, touchscreen) drivers, the rest

STALE2367d

4 messages, 2 authors, 2020-03-13 · open the first message on its own page

[PATCH v2] Input: Allocate keycode for SNIP key

From: Rajat Jain <hidden>
Date: 2020-03-04 00:21:45

New chromeos keyboards have a "snip" key that is basically a selective
screenshot (allows a user to select an area of screen to be copied).
Allocate a keyvode for it.

Signed-off-by: Rajat Jain <redacted>
---
V2: Drop patch [1/2] and instead rebase this on top of Linus' tree.

 include/uapi/linux/input-event-codes.h | 3 +++
 1 file changed, 3 insertions(+)
diff --git a/include/uapi/linux/input-event-codes.h b/include/uapi/linux/input-event-codes.h
index 0f1db1cccc3fd..08c8572891efb 100644
--- a/include/uapi/linux/input-event-codes.h
+++ b/include/uapi/linux/input-event-codes.h
@@ -652,6 +652,9 @@
 /* Electronic privacy screen control */
 #define KEY_PRIVACY_SCREEN_TOGGLE	0x279
 
+/* Selective Screenshot */
+#define KEY_SNIP                        0x280
+
 /*
  * Some keyboards have keys which do not have a defined meaning, these keys
  * are intended to be programmed / bound to macros by the user. For most
-- 
2.25.0.265.gbab2e86ba0-goog

Re: [PATCH v2] Input: Allocate keycode for SNIP key

From: Rajat Jain <hidden>
Date: 2020-03-12 19:33:28

Hi Dmitry,


On Tue, Mar 3, 2020 at 4:21 PM Rajat Jain [off-list ref] wrote:
New chromeos keyboards have a "snip" key that is basically a selective
screenshot (allows a user to select an area of screen to be copied).
Allocate a keyvode for it.
Any comments on this patch?

Thanks & Best Regards,

Rajat
quoted hunk
Signed-off-by: Rajat Jain <redacted>
---
V2: Drop patch [1/2] and instead rebase this on top of Linus' tree.

 include/uapi/linux/input-event-codes.h | 3 +++
 1 file changed, 3 insertions(+)
diff --git a/include/uapi/linux/input-event-codes.h b/include/uapi/linux/input-event-codes.h
index 0f1db1cccc3fd..08c8572891efb 100644
--- a/include/uapi/linux/input-event-codes.h
+++ b/include/uapi/linux/input-event-codes.h
@@ -652,6 +652,9 @@
 /* Electronic privacy screen control */
 #define KEY_PRIVACY_SCREEN_TOGGLE      0x279

+/* Selective Screenshot */
+#define KEY_SNIP                        0x280
+
 /*
  * Some keyboards have keys which do not have a defined meaning, these keys
  * are intended to be programmed / bound to macros by the user. For most
--
2.25.0.265.gbab2e86ba0-goog

Re: [PATCH v2] Input: Allocate keycode for SNIP key

From: Harry Cutts <hidden>
Date: 2020-03-12 20:31:51

On Tue, 3 Mar 2020 at 16:21, Rajat Jain [off-list ref] wrote:
quoted hunk
New chromeos keyboards have a "snip" key that is basically a selective
screenshot (allows a user to select an area of screen to be copied).
Allocate a keyvode for it.

Signed-off-by: Rajat Jain <redacted>
---
V2: Drop patch [1/2] and instead rebase this on top of Linus' tree.

 include/uapi/linux/input-event-codes.h | 3 +++
 1 file changed, 3 insertions(+)
diff --git a/include/uapi/linux/input-event-codes.h b/include/uapi/linux/input-event-codes.h
index 0f1db1cccc3fd..08c8572891efb 100644
--- a/include/uapi/linux/input-event-codes.h
+++ b/include/uapi/linux/input-event-codes.h
@@ -652,6 +652,9 @@
 /* Electronic privacy screen control */
 #define KEY_PRIVACY_SCREEN_TOGGLE      0x279

+/* Selective Screenshot */
+#define KEY_SNIP                        0x280
+
It's not very obvious to me what KEY_SNIP represents, without the
comment above. Maybe you could call it something like
KEY_SELECTIVE_SCREENSHOT, so that its purpose is more apparent to
someone seeing it in use.

Harry Cutts
Chrome OS Touch/Input team
 /*
  * Some keyboards have keys which do not have a defined meaning, these keys
  * are intended to be programmed / bound to macros by the user. For most
--
2.25.0.265.gbab2e86ba0-goog

Re: [PATCH v2] Input: Allocate keycode for SNIP key

From: Rajat Jain <hidden>
Date: 2020-03-13 17:47:19

On Thu, Mar 12, 2020 at 1:31 PM Harry Cutts [off-list ref] wrote:
On Tue, 3 Mar 2020 at 16:21, Rajat Jain [off-list ref] wrote:
quoted
New chromeos keyboards have a "snip" key that is basically a selective
screenshot (allows a user to select an area of screen to be copied).
Allocate a keyvode for it.

Signed-off-by: Rajat Jain <redacted>
---
V2: Drop patch [1/2] and instead rebase this on top of Linus' tree.

 include/uapi/linux/input-event-codes.h | 3 +++
 1 file changed, 3 insertions(+)
diff --git a/include/uapi/linux/input-event-codes.h b/include/uapi/linux/input-event-codes.h
index 0f1db1cccc3fd..08c8572891efb 100644
--- a/include/uapi/linux/input-event-codes.h
+++ b/include/uapi/linux/input-event-codes.h
@@ -652,6 +652,9 @@
 /* Electronic privacy screen control */
 #define KEY_PRIVACY_SCREEN_TOGGLE      0x279

+/* Selective Screenshot */
+#define KEY_SNIP                        0x280
+
It's not very obvious to me what KEY_SNIP represents, without the
comment above. Maybe you could call it something like
KEY_SELECTIVE_SCREENSHOT, so that its purpose is more apparent to
someone seeing it in use.
Sure, I do not have any preference, so I will change this to
KEY_SELECTIVE_SCREENSHOT.

Thanks,

Rajat
Harry Cutts
Chrome OS Touch/Input team
quoted
 /*
  * Some keyboards have keys which do not have a defined meaning, these keys
  * are intended to be programmed / bound to macros by the user. For most
--
2.25.0.265.gbab2e86ba0-goog
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help