DORMANTno replies

[PATCH 0222/1285] Replace numeric parameter like 0444 with macro

From: Baole Ni <hidden>
Date: 2016-08-02 18:15:41
Also in: lkml
Subsystem: hid core layer, picolcd hid driver, the rest · Maintainers: Jiri Kosina, Benjamin Tissoires, Bruno Prémont, Linus Torvalds

I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.

Signed-off-by: Chuansheng Liu <redacted>
Signed-off-by: Baole Ni <redacted>
---
 drivers/hid/hid-picolcd_core.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/hid/hid-picolcd_core.c b/drivers/hid/hid-picolcd_core.c
index c1b29a9..894d884 100644
--- a/drivers/hid/hid-picolcd_core.c
+++ b/drivers/hid/hid-picolcd_core.c
@@ -306,7 +306,7 @@ static ssize_t picolcd_operation_mode_store(struct device *dev,
 	return count;
 }
 
-static DEVICE_ATTR(operation_mode, 0644, picolcd_operation_mode_show,
+static DEVICE_ATTR(operation_mode, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH, picolcd_operation_mode_show,
 		picolcd_operation_mode_store);
 
 /*
@@ -334,7 +334,7 @@ static ssize_t picolcd_operation_mode_delay_store(struct device *dev,
 	return count;
 }
 
-static DEVICE_ATTR(operation_mode_delay, 0644, picolcd_operation_mode_delay_show,
+static DEVICE_ATTR(operation_mode_delay, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH, picolcd_operation_mode_delay_show,
 		picolcd_operation_mode_delay_store);
 
 /*
-- 
2.9.2
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help