[PATCH 0278/1285] Replace numeric parameter like 0444 with macro

DORMANTno replies

From: Baole Ni <hidden>
Date: 2016-08-02 18:04:31
Also in: lkml
Subsystem: ati_remote2 driver, input (keyboard, mouse, joystick, touchscreen) drivers, the rest · Maintainers: Ville Syrjala, Dmitry Torokhov, Linus Torvalds

I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.

Signed-off-by: Chuansheng Liu <redacted>
Signed-off-by: Baole Ni <redacted>
---
 drivers/input/misc/ati_remote2.c | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/input/misc/ati_remote2.c b/drivers/input/misc/ati_remote2.c
index 1c5914c..2c03a41 100644
--- a/drivers/input/misc/ati_remote2.c
+++ b/drivers/input/misc/ati_remote2.c
@@ -98,7 +98,7 @@ static const struct kernel_param_ops param_ops_channel_mask = {
 	.set = ati_remote2_set_channel_mask,
 	.get = ati_remote2_get_channel_mask,
 };
-module_param(channel_mask, channel_mask, 0644);
+module_param(channel_mask, channel_mask, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
 MODULE_PARM_DESC(channel_mask, "Bitmask of channels to accept <15:Channel16>...<1:Channel2><0:Channel1>");
 
 static unsigned int mode_mask = ATI_REMOTE2_MAX_MODE_MASK;
@@ -107,7 +107,7 @@ static const struct kernel_param_ops param_ops_mode_mask = {
 	.set = ati_remote2_set_mode_mask,
 	.get = ati_remote2_get_mode_mask,
 };
-module_param(mode_mask, mode_mask, 0644);
+module_param(mode_mask, mode_mask, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
 MODULE_PARM_DESC(mode_mask, "Bitmask of modes to accept <4:PC><3:AUX4><2:AUX3><1:AUX2><0:AUX1>");
 
 static struct usb_device_id ati_remote2_id_table[] = {
@@ -785,10 +785,10 @@ static ssize_t ati_remote2_store_mode_mask(struct device *dev,
 	return count;
 }
 
-static DEVICE_ATTR(channel_mask, 0644, ati_remote2_show_channel_mask,
+static DEVICE_ATTR(channel_mask, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH, ati_remote2_show_channel_mask,
 		   ati_remote2_store_channel_mask);
 
-static DEVICE_ATTR(mode_mask, 0644, ati_remote2_show_mode_mask,
+static DEVICE_ATTR(mode_mask, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH, ati_remote2_show_mode_mask,
 		   ati_remote2_store_mode_mask);
 
 static struct attribute *ati_remote2_attrs[] = {
-- 
2.9.2
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help