[PATCH 26/26] Input: synaptics-rmi4: Change the rmi device's name to be less generic

Subsystems: input (keyboard, mouse, joystick, touchscreen) drivers, the rest

STALE3933d

2 messages, 2 authors, 2015-11-09 · open the first message on its own page

[PATCH 26/26] Input: synaptics-rmi4: Change the rmi device's name to be less generic

From: Andrew Duggan <hidden>
Date: 2015-11-05 23:43:30

Currently, the rmi device has the name sensorXX. Sensor is very generic
and in cases when there is little context it is hard to tell what the
device is (ie in /sys/devices or /proc/interrupts). This patch changes
the name to rmiXX which at least indicates that it is an rmi device.

Signed-off-by: Andrew Duggan <redacted>
---
Linus Walleij suggested that we use the TM number as the device name.
But, we need to set the device name when we add the device before we
read the TM number. Changing the name to rmiXX is a compromise since
it's not as unique as the TM, but not as generic as sensor.

 drivers/input/rmi4/rmi_bus.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/input/rmi4/rmi_bus.c b/drivers/input/rmi4/rmi_bus.c
index a04468d..998b4e1 100644
--- a/drivers/input/rmi4/rmi_bus.c
+++ b/drivers/input/rmi4/rmi_bus.c
@@ -66,7 +66,7 @@ int rmi_register_transport_device(struct rmi_transport_dev *xport)
 	rmi_dev->xport = xport;
 	rmi_dev->number = atomic_inc_return(&transport_device_count) - 1;
 
-	dev_set_name(&rmi_dev->dev, "sensor%02d", rmi_dev->number);
+	dev_set_name(&rmi_dev->dev, "rmi%02d", rmi_dev->number);
 
 	rmi_dev->dev.bus = &rmi_bus_type;
 	rmi_dev->dev.type = &rmi_device_type;
-- 
2.1.4

Re: [PATCH 26/26] Input: synaptics-rmi4: Change the rmi device's name to be less generic

From: Linus Walleij <hidden>
Date: 2015-11-09 13:38:06

On Fri, Nov 6, 2015 at 12:43 AM, Andrew Duggan [off-list ref] wrote:
Currently, the rmi device has the name sensorXX. Sensor is very generic
and in cases when there is little context it is hard to tell what the
device is (ie in /sys/devices or /proc/interrupts). This patch changes
the name to rmiXX which at least indicates that it is an rmi device.

Signed-off-by: Andrew Duggan <redacted>
---
Linus Walleij suggested that we use the TM number as the device name.
But, we need to set the device name when we add the device before we
read the TM number. Changing the name to rmiXX is a compromise since
it's not as unique as the TM, but not as generic as sensor.
OK OK I give up. No big deal anyway, the device works.
Squash into core patch?

Acked-by: Linus Walleij <redacted>

Yours,
Linus Walleij
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help