serial touchscreen and inputattach

From: Markus Heidelberg <hidden>
Date: 2008-06-15 19:01:15

Hello,

I'm currently working on a serial touchscreen driver and have some questions.

What's the rule for creating a new name for serio protocol in serio.h for use
in serio_device_id.proto and input_dev.id.vendor? Can I just take a free
number? I guess then I should take the next one (currently 0x37 after
SERIO_ZHENHUA), however there are some gaps in the list.

Is there an official version of inputattach? I found different sources. The
last change at [1] is about 2 years ago. At [2] there is a broken CVS link to
[1]. The inputattach tool in buildroot's tslib package is derived from [1] with
some minor changes. The inputattach from Debian's joystick package is derived
from a three years old version of [1], the tool from Gentoo's joystick package
is the same as in [1].

So it seems as if [1] is quite official, because everything is pointing to it.
But there is another inputattach at [3] with a reworked code base, which is
only 1 year old and supports some more devices, mainly touchscreens.

Or is there another preferred way beside inputattach to bind the touchscreen to
its driver and inputattach is obsolete?

[1] http://linuxconsole.cvs.sourceforge.net/linuxconsole/ruby/utils/
[2] http://atrey.karlin.mff.cuni.cz/~vojtech/input/
[3] http://kernel.org/pub/linux/kernel/people/dtor/

Markus
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help