Reviews by lance.yang@linux.dev
· linux-fsdevel
All review-attestation trailers
(Reviewed-by / Acked-by /
Tested-by / Reported-by /
Suggested-by / Co-developed-by /
Reported-and-tested-by)
by this address on the linux-fsdevel archive.
68 attestations . (1 Acked-by, 64 Reviewed-by, 3 Tested-by)
-
COOLING11d
REVIEWED: 3 (3M) Re: [PATCH 3/3] mm/mseal: remove further superfluous comments, do_mseal()
2026-07-17 · Acked-by -
COOLING5d
IN LINUX-NEXT: 6 (6M) [PATCH v2 11/13] mm/mlock: convert mlock code to use vma_flags_t
2026-07-11 · Reviewed-by -
COOLING5d
IN LINUX-NEXT: 6 (6M) [PATCH v2 09/13] mm/vma: update create_init_stack_vma() to use vma_flags_t
2026-07-11 · Reviewed-by -
COOLING5d
IN LINUX-NEXT: 6 (6M) [PATCH v2 07/13] mm/vma: rename vma_get_page_prot to vma_flags_to_page_prot
2026-07-11 · Reviewed-by -
COOLING5d
IN LINUX-NEXT: 6 (6M) [PATCH v2 06/13] mm/vma: convert vm_pgprot_modify() to use vma_flags_t and rename
2026-07-11 · Reviewed-by -
COOLING5d
IN LINUX-NEXT: 6 (6M) [PATCH v2 05/13] mm: prefer mm->def_vma_flags in mm logic
2026-07-11 · Reviewed-by -
COOLING5d
IN LINUX-NEXT: 6 (6M) [PATCH v2 04/13] mm: update generic_get_unmapped_area[_topdown]() to use vma_flags_t
2026-07-11 · Reviewed-by -
COOLING5d
IN LINUX-NEXT: 6 (6M) [PATCH v2 03/13] mm: convert __get_unmapped_area() to use vma_flags_t
2026-07-11 · Reviewed-by -
COOLING5d
IN LINUX-NEXT: 6 (6M) [PATCH v2 02/13] mm/vma: update do_mmap() to use vma_flags_t
2026-07-11 · Reviewed-by -
COOLING5d
IN LINUX-NEXT: 6 (6M) [PATCH v2 01/13] mm: introduce vma_flags_can_grow() and vma_can_grow()
2026-07-11 · Reviewed-by -
COOLING13d
REVIEWED: 3 (3M) Re: [PATCH stable] mm/khugepaged: write all dirty file folios when collapsing
2026-07-03 · Tested-by -
COLD16d
REVIEWED: 3 (3M) Re: [PATCH 11/13] mm/mlock: convert mlock code to use vma_flags_t
2026-07-02 · Reviewed-by -
COLD16d
REVIEWED: 3 (3M) Re: [PATCH 09/13] mm/vma: update create_init_stack_vma() to use vma_flags_t
2026-07-02 · Reviewed-by -
COLD16d
REVIEWED: 3 (3M) Re: [PATCH 07/13] mm/vma: rename vma_get_page_prot to vma_flags_to_page_prot
2026-07-02 · Reviewed-by -
COLD16d
REVIEWED: 3 (3M) Re: [PATCH 06/13] mm/vma: convert vm_pgprot_modify() to use vma_flags_t and rename
2026-07-02 · Reviewed-by -
COLD16d
REVIEWED: 3 (3M) Re: [PATCH 05/13] mm: prefer mm->def_vma_flags in mm logic
2026-07-02 · Reviewed-by -
COLD16d
REVIEWED: 3 (3M) Re: [PATCH 04/13] mm: update generic_get_unmapped_area[_topdown]() to use vma_flags_t
2026-07-02 · Reviewed-by -
COLD16d
REVIEWED: 3 (3M) Re: [PATCH 03/13] mm: convert __get_unmapped_area() to use vma_flags_t
2026-07-02 · Reviewed-by -
COLD16d
REVIEWED: 3 (3M) Re: [PATCH 02/13] mm/vma: update do_mmap() to use vma_flags_t
2026-07-02 · Reviewed-by -
COLD16d
REVIEWED: 3 (3M) Re: [PATCH 01/13] mm: introduce vma_flags_can_grow() and vma_can_grow()
2026-07-02 · Reviewed-by -
COLD41d
IN MM: 3 (3M) [PATCH v6 13/14] mm/khugepaged: enable clean pagecache folio collapse for writable files
2026-05-17 · Reviewed-by -
COLD41d
IN MM: 30 (30M) [PATCH v6 08/14] mm/huge_memory: remove folio split check for READ_ONLY_THP_FOR_FS
2026-05-17 · Reviewed-by -
COLD41d
IN MM: 18 (18M) [PATCH v6 09/14] mm/truncate: use folio_split() in truncate_inode_partial_folio()
2026-05-17 · Reviewed-by -
COLD41d
IN MM: 25 (25M) [PATCH v6 06/14] mm: fs: remove filemap_nr_thps*() functions and their users
2026-05-17 · Reviewed-by -
COLD41d
IN MM: 36 (36M) [PATCH v6 07/14] fs: remove nr_thps from struct address_space
2026-05-17 · Reviewed-by -
COLD41d
IN MM: 31 (31M) [PATCH v6 05/14] mm: remove READ_ONLY_THP_FOR_FS Kconfig option
2026-05-17 · Reviewed-by -
COLD41d
IN MM: 21 (21M) [PATCH v6 04/14] mm/khugepaged: remove READ_ONLY_THP_FOR_FS check in hugepage_enabled()
2026-05-17 · Reviewed-by -
COLD41d
IN MM: 21 (21M) [PATCH v6 02/14] mm/khugepaged: add folio dirty check after try_to_unmap()
2026-05-17 · Reviewed-by -
COLD41d
IN MM: 21 (21M) [PATCH v6 01/14] mm/khugepaged: remove READ_ONLY_THP_FOR_FS check
2026-05-17 · Reviewed-by -
COLD41d
IN MM: 19 (19M) [PATCH v6 03/14] mm/huge_memory: remove READ_ONLY_THP_FOR_FS from file_thp_enabled()
2026-05-17 · Reviewed-by -
STALE70d
REVIEWED: 3 (3M) Re: [PATCH v5 04/14] mm/khugepaged: remove READ_ONLY_THP_FOR_FS check in hugepage_enabled()
2026-05-11 · Reviewed-by -
STALE70d
REVIEWED: 3 (3M) Re: [PATCH v5 13/14] mm/khugepaged: enable clean pagecache folio collapse for writable files
2026-05-08 · Reviewed-by -
STALE70d
REVIEWED: 3 (3M) Re: [PATCH v5 09/14] mm/truncate: use folio_split() in truncate_inode_partial_folio()
2026-05-08 · Reviewed-by -
STALE70d
REVIEWED: 3 (3M) Re: [PATCH v5 06/14] mm: fs: remove filemap_nr_thps*() functions and their users
2026-05-07 · Reviewed-by -
STALE70d
REVIEWED: 3 (3M) Re: [PATCH v5 05/14] mm: remove READ_ONLY_THP_FOR_FS Kconfig option
2026-05-07 · Reviewed-by -
STALE70d
REVIEWED: 3 (3M) Re: [PATCH v5 03/14] mm/huge_memory: remove READ_ONLY_THP_FOR_FS from file_thp_enabled()
2026-05-07 · Reviewed-by -
STALE70d
REVIEWED: 3 (3M) Re: [PATCH v5 02/14] mm/khugepaged: add folio dirty check after try_to_unmap()
2026-05-06 · Reviewed-by -
STALE70d
REVIEWED: 30 (30M) [PATCH v5 08/14] mm/huge_memory: remove folio split check for READ_ONLY_THP_FOR_FS
2026-04-29 · Reviewed-by -
STALE70d
REVIEWED: 35 (35M) [PATCH v5 07/14] fs: remove nr_thps from struct address_space
2026-04-29 · Reviewed-by -
STALE70d
REVIEWED: 5 (5M) [PATCH v5 01/14] mm/khugepaged: remove READ_ONLY_THP_FOR_FS check
2026-04-29 · Reviewed-by -
STALE93d
REVIEWED: 15 (15M) [PATCH 7.2 v4 08/12] mm/huge_memory: remove folio split check for READ_ONLY_THP_FOR_FS
2026-04-24 · Reviewed-by -
STALE93d
REVIEWED: 35 (35M) [PATCH 7.2 v4 07/12] fs: remove nr_thps from struct address_space
2026-04-24 · Reviewed-by -
STALE93d
REVIEWED: 5 (5M) [PATCH 7.2 v4 01/12] mm/khugepaged: remove READ_ONLY_THP_FOR_FS check
2026-04-24 · Reviewed-by -
STALE91d
REVIEWED: 3 (3M) Re: [PATCH 7.2 v3 01/12] mm/khugepaged: remove READ_ONLY_THP_FOR_FS check
2026-04-23 · Reviewed-by -
STALE91d
REVIEWED: 15 (15M) [PATCH 7.2 v3 08/12] mm/huge_memory: remove folio split check for READ_ONLY_THP_FOR_FS
2026-04-18 · Reviewed-by -
STALE91d
REVIEWED: 35 (35M) [PATCH 7.2 v3 07/12] fs: remove nr_thps from struct address_space
2026-04-18 · Reviewed-by -
STALE101d
REVIEWED: 13 (13M) [PATCH 7.2 v2 08/12] mm/huge_memory: remove folio split check for READ_ONLY_THP_FOR_FS
2026-04-13 · Reviewed-by -
STALE101d
REVIEWED: 28 (28M) [PATCH 7.2 v2 07/12] fs: remove nr_thps from struct address_space
2026-04-13 · Reviewed-by -
STALE106d
REVIEWED: 3 (3M) Re: [PATCH v1 06/10] mm/huge_memory: remove folio split check for READ_ONLY_THP_FOR_FS
2026-03-30 · Reviewed-by -
STALE106d
REVIEWED: 3 (3M) Re: [PATCH v1 04/10] fs: remove nr_thps from struct address_space
2026-03-30 · Reviewed-by -
STALE106d
REVIEWED: 3 (3M) Re: [PATCH v1 03/10] mm: fs: remove filemap_nr_thps*() functions and their users
2026-03-27 · Reviewed-by -
STALE106d
REVIEWED: 3 (3M) Re: [PATCH v1 02/10] mm/khugepaged: remove READ_ONLY_THP_FOR_FS check
2026-03-27 · Reviewed-by -
STALE138d
REVIEWED: 15 (15M) [PATCH v2] docs: filesystems: clarify KernelPageSize vs. MMUPageSize in smaps
2026-03-06 · Reviewed-by -
STALE144d
REVIEWED: 3 (3M) Re: [PATCH v1] docs: filesystems: clarify KernelPageSize vs. MMUPageSize in smaps
2026-03-05 · Reviewed-by -
STALE146d
REVIEWED: 3 (3M) [PATCH v2] mm/huge_memory: fix a folio_split() race condition with folio_try_get()
2026-03-02 · Tested-by -
STALE147d
REVIEWED: 3 (3M) Re: [PATCH] mm/huge_memory: fix a folio_split() race condition with folio_try_get()
2026-02-28 · Tested-by -
STALE195d
REVIEWED: 3 (3M) Re: [PATCH v4 2/9] mm: add atomic VMA flags and set VM_MAYBE_GUARD as such
2025-11-20 · Reviewed-by -
STALE195d
REVIEWED: 3 (3M) Re: [PATCH v4 1/9] mm: introduce VM_MAYBE_GUARD and make visible in /proc/$pid/smaps
2025-11-20 · Reviewed-by -
STALE264d
REVIEWED: 9 (8M) [PATCH v5 3/3] mm/huge_memory: fix kernel-doc comments for folio_split() and related.
2025-10-31 · Reviewed-by -
STALE264d
REVIEWED: 11 (8M) [PATCH v5 1/3] mm/huge_memory: add split_huge_page_to_order()
2025-10-31 · Reviewed-by -
STALE264d
REVIEWED: 15 (12M) [PATCH v5 2/3] mm/memory-failure: improve large block size folio handling.
2025-10-31 · Reviewed-by -
STALE269d
REVIEWED: 3 (3M) Re: [PATCH v4 3/3] mm/huge_memory: fix kernel-doc comments for folio_split() and related.
2025-10-30 · Reviewed-by -
STALE269d
REVIEWED: 3 (3M) Re: [PATCH v4 2/3] mm/memory-failure: improve large block size folio handling.
2025-10-30 · Reviewed-by -
STALE269d
REVIEWED: 3 (3M) Re: [PATCH v4 1/3] mm/huge_memory: add split_huge_page_to_order()
2025-10-30 · Reviewed-by -
STALE270d
REVIEWED: 3 (3M) Re: [PATCH v4] mm/huge_memory: preserve PG_has_hwpoisoned if a folio is split to >0 order
2025-10-24 · Reviewed-by -
STALE344d
REVIEWED: 3 (3M) Re: [PATCH v1 1/2] mm/migrate: remove MIGRATEPAGE_UNMAP
2025-08-13 · Reviewed-by -
STALE334d
REVIEWED: 3 (3M) Re: [PATCH v3 01/11] mm/huge_memory: move more common code into insert_pmd()
2025-08-12 · Reviewed-by -
STALE378d
REVIEWED: 3 (3M) Re: [PATCH RFC 01/14] mm/memory: drop highest_memmap_pfn sanity check in vm_normal_page()
2025-07-03 · Reviewed-by