slab allocator · Maintained
Maintainers
- M Vlastimil Babka <vbabka@kernel.org>
- M Harry Yoo <harry@kernel.org>
- M Andrew Morton <akpm@linux-foundation.org>
- R Hao Li <hao.li@linux.dev>
- R Christoph Lameter <cl@gentwo.org>
- R David Rientjes <rientjes@google.com>
- R Roman Gushchin <roman.gushchin@linux.dev>
Paths
- F
Documentation/admin-guide/mm/slab.rst - F
Documentation/mm/slab.rst - F
include/linux/mempool.h - F
include/linux/slab.h - F
lib/tests/slub_kunit.c - F
mm/failslab.c - F
mm/mempool.c - F
mm/slab.h - F
mm/slab_common.c - F
mm/slub.c - F
scripts/gdb/linux/slab.py - F
tools/cgroup/memcg_slabinfo.py - F
tools/include/linux/slab.h - F
tools/lib/slab.c - F
tools/mm/slabinfo-gnuplot.sh - F
tools/mm/slabinfo.c
Last 30 days
Most active threads (last 7 days)
-
HOTtoday
[PATCH 6.12 0/7] Backport object allocation APIs and two fscrypt fixes
2026-07-17 04:46 · 4 replies in 7d · Eric Biggers <ebiggers@kernel.org>
Active reviewers (last 30 days)
-
Vlastimil Babka <hidden>
2 attestations (2 Acked-by) · last on 2026-07-17 -
Harry Yoo (Oracle) <harry@kernel.org>
1 attestation (1 Acked-by) · last on 2026-07-17
Recent patches
Most-recent 12 patches in this subsystem on linux-fscrypt, ordered by date desc.
-
HOTtoday
REVIEWED: 2 (2M) [PATCH 6.12 5/7] slab: recognize @GFP parameter as optional in kernel-doc
2026-07-17 · Eric Biggers <ebiggers@kernel.org> -
HOTtoday
REVIEWED: 1 (0M) [PATCH 6.12 1/7] slab: Introduce kmalloc_obj() and family
2026-07-17 · Eric Biggers <ebiggers@kernel.org> -
HOTtoday
REVIEWED: 1 (0M) [PATCH 6.12 2/7] slab: Introduce kmalloc_flex() and family
2026-07-17 · Eric Biggers <ebiggers@kernel.org> -
HOTtoday
[PATCH 6.12 3/7] add default_gfp() helper macro and use it in the new *alloc_obj() helpers
2026-07-17 · Eric Biggers <ebiggers@kernel.org> -
STALE245d
[PATCH 3/9] mempool: add mempool_{alloc,free}_bulk
2025-10-31 · Christoph Hellwig <hch@lst.de> -
STALE245d
[PATCH 2/9] mempool: add error injection support
2025-10-31 · Christoph Hellwig <hch@lst.de> -
STALE245d
[PATCH 1/9] mempool: update kerneldoc comments
2025-10-31 · Christoph Hellwig <hch@lst.de> -
STALE2221d
REVIEWED: 4 (4M) [PATCH v5 1/2] mm/slab: Use memzero_explicit() in kzfree()
2020-06-16 · Waiman Long <longman@redhat.com> -
STALE2221d
REVIEWED: 19 (19M) [PATCH v5 2/2] mm, treewide: Rename kzfree() to kfree_sensitive()
2020-06-16 · Waiman Long <longman@redhat.com> -
STALE2220d
REVIEWED: 19 (19M) [PATCH v4 2/3] mm, treewide: Rename kzfree() to kfree_sensitive()
2020-06-16 · Waiman Long <longman@redhat.com> -
STALE2220d
[PATCH v4 1/3] mm/slab: Use memzero_explicit() in kzfree()
2020-06-16 · Waiman Long <longman@redhat.com> -
STALE2222d
[PATCH 1/2] mm, treewide: Rename kzfree() to kfree_sensitive()
2020-04-13 · Waiman Long <longman@redhat.com>