pwm subsystem · Maintained
Maintainers
- M Uwe Kleine-König <ukleinek@kernel.org>
Paths
- F
Documentation/devicetree/bindings/pwm/ - F
Documentation/driver-api/pwm.rst - F
drivers/pwm/ - F
include/dt-bindings/pwm/ - F
include/linux/pwm.h
Last 30 days
Recent patches
Most-recent 30 patches in this subsystem on linux-fbdev (capped at 30), ordered by date desc.
-
STALE331d
[PATCH] dt-bindings: Remove extra blank lines
2025-10-23 · "Rob Herring (Arm)" <robh@kernel.org> -
STALE743d
[PATCH 4/8] pwm: Export pwm_get_state_hw
2024-08-15 · Guillaume Stols <hidden> -
STALE1011d
REVIEWED: 19 (16M) [PATCH v10 1/6] pwm: Rename pwm_apply_state() to pwm_apply_might_sleep()
2023-12-19 · Sean Young <sean@mess.org> -
STALE1013d
REVIEWED: 19 (16M) [PATCH v9 1/6] pwm: Rename pwm_apply_state() to pwm_apply_might_sleep()
2023-12-18 · Sean Young <sean@mess.org> -
STALE1014d
REVIEWED: 6 (4M) [PATCH v8 1/6] pwm: Rename pwm_apply_state() to pwm_apply_might_sleep()
2023-12-12 · Sean Young <sean@mess.org> -
STALE1021d
REVIEWED: 6 (4M) [PATCH v7 1/4] pwm: Rename pwm_apply_state() to pwm_apply_might_sleep()
2023-12-11 · Sean Young <sean@mess.org> -
STALE1021d
REVIEWED: 6 (4M) [PATCH v6 1/4] pwm: rename pwm_apply_state() to pwm_apply_might_sleep()
2023-11-29 · Sean Young <sean@mess.org> -
STALE1033d
REVIEWED: 2 (0M) [PATCH v5 1/4] pwm: rename pwm_apply_state() to pwm_apply_cansleep()
2023-11-18 · Sean Young <sean@mess.org> -
DORMANTno replies
REVIEWED: 2 (0M) [PATCH v4 1/4] pwm: rename pwm_apply_state() to pwm_apply_cansleep()
2023-10-27 · Sean Young <sean@mess.org> -
STALE1068d
[PATCH v3 1/3] pwm: make it possible to apply pwm changes in atomic context
2023-10-17 · Sean Young <sean@mess.org> -
STALE1997d
[PATCH] pwm: Rename pwm_get_state() to better reflect its semantic
2021-04-06 · Uwe Kleine-König <hidden> -
STALE2291d
[PATCH 2/2] pwm: iqs620a: Use 64-bit division
2020-06-15 · Thierry Reding <hidden> -
STALE2372d
[RFC PATCH 5/7] pwm: replace polarity enum with macros
2020-03-17 · Oleksandr Suvorov <hidden> -
STALE2531d
Re: [PATCH] backlight: pwm_bl: configure pwm only once per backlight toggle
2019-10-17 · Thierry Reding <hidden> -
STALE2531d
Re: [PATCH] backlight: pwm_bl: configure pwm only once per backlight toggle
2019-10-17 · Thierry Reding <hidden> -
STALE2637d
[PATCH v1 12/22] docs: driver-api: add .rst files from the main dir
2019-06-18 · Mauro Carvalho Chehab <mchehab+samsung@kernel.org> -
STALE3113d
[PATCH 11/16] treewide: simplify Kconfig dependencies for removed archs
2018-03-14 · Arnd Bergmann <arnd@arndb.de> -
STALE3131d
[PATCH v3 10/10] pwm: atmel: add push-pull mode support
2018-02-22 · Claudiu Beznea <hidden> -
STALE3131d
REVIEWED: 6 (6M) [PATCH v3 09/10] pwm: add documentation for pwm push-pull mode
2018-02-22 · Claudiu Beznea <hidden> -
STALE3131d
[PATCH v3 08/10] pwm: add push-pull mode support
2018-02-22 · Claudiu Beznea <hidden> -
STALE3131d
[PATCH v3 07/10] pwm: atmel: add pwm capabilities
2018-02-22 · Claudiu Beznea <hidden> -
STALE3131d
[PATCH v3 06/10] pwm: add PWM modes
2018-02-22 · Claudiu Beznea <hidden> -
STALE3131d
[PATCH v3 05/10] pwm: add PWM mode to pwm_config()
2018-02-22 · Claudiu Beznea <hidden> -
STALE3131d
[PATCH v3 04/10] pwm: pxa: populate PWM mode in of_xlate function
2018-02-22 · Claudiu Beznea <hidden> -
STALE3131d
[PATCH v3 03/10] pwm: cros-ec: populate PWM mode in of_xlate function
2018-02-22 · Claudiu Beznea <hidden> -
STALE3131d
[PATCH v3 02/10] pwm: clps711x: populate PWM mode in of_xlate function
2018-02-22 · Claudiu Beznea <hidden> -
STALE3131d
[PATCH v3 01/10] pwm: extend PWM framework with PWM modes
2018-02-22 · Claudiu Beznea <hidden> -
STALE3142d
[PATCH v2 03/20] kconfig: Remove leftover references to AVR32 symbol
2018-02-05 · Ulf Magnusson <hidden> -
STALE3142d
[PATCH 03/20] kconfig: Remove leftover references to AVR32 symbol
2018-02-05 · Ulf Magnusson <hidden> -
STALE3331d
[PATCH 3/3] mfd: twl: move header file out of I2C realm
2017-05-21 · Wolfram Sang <hidden>