It seems these are not used. Just delete them.
regards,
dan carpenter
The dpms enum is used in the definition of the
ddk750_set_dpms function in ddk750_power.h file and
this function is called in ddk750_display.c on line 158.
If I were to delete it, what changes should I make to
the function mentioned above ?
this is my first contribution, thanks for all the help.
best regards,
Gabriel Lima
It seems these are not used. Just delete them.
regards,
dan carpenter
The dpms enum is used in the definition of the
ddk750_set_dpms function in ddk750_power.h file and
this function is called in ddk750_display.c on line 158.
If I were to delete it, what changes should I make to
the function mentioned above ?
this is my first contribution, thanks for all the help.
Huh. Using a enum for shifting isn't the right thing. It should
be unsigned int.
The enum does serve as documentation. Maybe just change it to
a comment or something next to the ddk750_set_dpms() function.
The ddk750_set_dpms() function does a weird thing:
value = (value & ~SYSTEM_CTRL_DPMS_MASK) | state;
state is something in 0x3 but SYSTEM_CTRL_DPMS_MASK is
(0x3u << 30). I bet it should match the on both sides of the
if statement:
value = (value & ~SYSTEM_CTRL_DPMS_MASK) | (state << 30);
But I can't test it so who knows?
regards,
dan carpenter